summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-07-11 09:00:45 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-07-11 09:00:45 +0000
commit173f6dbaec1a8492314eef2d749a1f53e9c30097 (patch)
tree2a2aff80d824d186075c28f04f43cf6040fcbdf9 /www-apache
parentConvert to ruby-ng. Add USE=doc to make dev-ruby/rdtool dependency optional. (diff)
downloadgentoo-2-173f6dbaec1a8492314eef2d749a1f53e9c30097.tar.gz
gentoo-2-173f6dbaec1a8492314eef2d749a1f53e9c30097.tar.bz2
gentoo-2-173f6dbaec1a8492314eef2d749a1f53e9c30097.zip
improve ebuild quality
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_nss/ChangeLog5
-rw-r--r--www-apache/mod_nss/mod_nss-1.0.8-r1.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/www-apache/mod_nss/ChangeLog b/www-apache/mod_nss/ChangeLog
index 0609117d08c8..8c5b0730eff5 100644
--- a/www-apache/mod_nss/ChangeLog
+++ b/www-apache/mod_nss/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-apache/mod_nss
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_nss/ChangeLog,v 1.2 2010/07/11 08:53:37 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_nss/ChangeLog,v 1.3 2010/07/11 09:00:45 lxnay Exp $
+
+ 11 Jul 2010; Fabio Erculiani <lxnay@gentoo.org> mod_nss-1.0.8-r1.ebuild:
+ improve ebuild quality
11 Jul 2010; Fabio Erculiani <lxnay@gentoo.org> metadata.xml:
set apache herd in metadata.xml
diff --git a/www-apache/mod_nss/mod_nss-1.0.8-r1.ebuild b/www-apache/mod_nss/mod_nss-1.0.8-r1.ebuild
index c37f38b9f5a4..73781e2d7f9b 100644
--- a/www-apache/mod_nss/mod_nss-1.0.8-r1.ebuild
+++ b/www-apache/mod_nss/mod_nss-1.0.8-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_nss/mod_nss-1.0.8-r1.ebuild,v 1.1 2010/07/07 13:36:56 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_nss/mod_nss-1.0.8-r1.ebuild,v 1.2 2010/07/11 09:00:45 lxnay Exp $
EAPI="2"
WANT_AUTOMAKE="1.6"
-inherit base autotools apache-module flag-o-matic
+inherit base autotools apache-module
DESCRIPTION="SSL/TLS module for the Apache HTTP server"
HOMEPAGE="http://directory.fedoraproject.org/wiki/Mod_nss"
@@ -19,7 +19,8 @@ IUSE="+ecc"
DEPEND=">=dev-libs/nss-3.11.4
>=dev-libs/nspr-4.6.4
- dev-util/pkgconfig"
+ dev-util/pkgconfig
+ sys-apps/sed"
RDEPEND=">=dev-libs/nss-3.11.4
>=dev-libs/nspr-4.6.4
@@ -33,14 +34,13 @@ DOCFILES="NOTICE README"
need_apache2
src_prepare() {
- # add gentoo naming
+ # setup proper exec name
sed -i -e 's/certutil/nsscertutil/' gencert.in || die "sed failed"
eautoreconf
}
src_configure() {
- econf $(use_enable ecc) \
- --with-apxs=${APXS} || die "econf failed"
+ econf $(use_enable ecc) --with-apxs=${APXS} || die "econf failed"
}
src_compile() {
@@ -48,8 +48,8 @@ src_compile() {
}
src_install() {
+ # override broken build system
mv .libs/libmodnss.so .libs/"${PN}".so || die "cannot move lib"
-
dosbin gencert nss_pcache
dohtml docs/mod_nss.html
newbin migrate.pl nss_migrate
@@ -61,5 +61,5 @@ pkg_postinst() {
apache-module_pkg_postinst
elog "If you need to generate a SSL certificate,"
- elog "please use gencert script from bind-tools"
+ elog "please use gencert tool from net-dns/bind-tools"
}