summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2005-02-05 21:44:47 +0000
committerDaniel Drake <dsd@gentoo.org>2005-02-05 21:44:47 +0000
commit58f6d60a303845a556d499464a7ad4d7bf9c93fc (patch)
tree0f794c6e4206a2bd1af071f60784b74f5e74635b /www-apps/b2evolution/b2evolution-0.9.0.11.ebuild
parentHomepage moved, bug 80903. (diff)
downloadgentoo-2-58f6d60a303845a556d499464a7ad4d7bf9c93fc.tar.gz
gentoo-2-58f6d60a303845a556d499464a7ad4d7bf9c93fc.tar.bz2
gentoo-2-58f6d60a303845a556d499464a7ad4d7bf9c93fc.zip
Initial commit. Includes security fix from http://secunia.com/advisories/13718/
(Portage version: 2.0.51-r15)
Diffstat (limited to 'www-apps/b2evolution/b2evolution-0.9.0.11.ebuild')
-rw-r--r--www-apps/b2evolution/b2evolution-0.9.0.11.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/b2evolution/b2evolution-0.9.0.11.ebuild b/www-apps/b2evolution/b2evolution-0.9.0.11.ebuild
new file mode 100644
index 000000000000..9df80932c2cc
--- /dev/null
+++ b/www-apps/b2evolution/b2evolution-0.9.0.11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/b2evolution/b2evolution-0.9.0.11.ebuild,v 1.1 2005/02/05 21:44:47 dsd Exp $
+
+inherit webapp eutils
+
+MY_EXT="d-2004-09-22"
+
+DESCRIPTION="Multilingual multiuser multi-blog engine"
+HOMEPAGE="http://www.b2evolution.net"
+SRC_URI="mirror://sourceforge/evocms/${P}${MY_EXT}.zip"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=">=dev-php/mod_php-4.1
+ >=dev-db/mysql-3.23.23"
+
+DEPEND="${DEPEND} ${RDEPEND}
+ >=net-www/webapp-config-1.10-r5
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # http://secunia.com/advisories/13718/
+ sed -i "s:post_urltitle = '\$title'\";:post_urltitle = \".\$DB->quote(\$title);:" \
+ blogs/b2evocore/_class_itemlist.php
+}
+
+src_install() {
+ webapp_src_preinst
+
+ einfo "Installing main files"
+ cp -r blogs/* ${D}${MY_HTDOCSDIR}
+ einfo "Done"
+
+ dodoc doc/license.txt doc/install_new.html doc/upgradefrom_b2evo.html doc/upgradefrom_b2.html \
+ doc/upgradefrom_gl.html doc/upgradefrom_miniblog.html doc/upgradefrom_mt.html
+
+ # Identify the configuration files that this app uses
+ # User can want to make changes to these!
+ webapp_serverowned ${MY_HTDOCSDIR}/conf/_config.php
+ webapp_serverowned ${MY_HTDOCSDIR}
+
+ # post-install instructions
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ # now strut stuff
+ webapp_src_install
+}