summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-08-30 05:06:53 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-08-30 05:06:53 +0000
commit711e16c6ef863b3b7047d0e46eadf84ee51ee339 (patch)
tree4275e69e9a102043441cb2bcf72df86508a7a83f /www-apps/blohg
parentWe have a few more licenses in the tree from the FSF, that provide additional... (diff)
downloadgentoo-2-711e16c6ef863b3b7047d0e46eadf84ee51ee339.tar.gz
gentoo-2-711e16c6ef863b3b7047d0e46eadf84ee51ee339.tar.bz2
gentoo-2-711e16c6ef863b3b7047d0e46eadf84ee51ee339.zip
Version bump.
(Portage version: 2.2.0_alpha51_p7/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/blohg')
-rw-r--r--www-apps/blohg/ChangeLog7
-rw-r--r--www-apps/blohg/blohg-0.7.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/www-apps/blohg/ChangeLog b/www-apps/blohg/ChangeLog
index 5691459d674a..f9fa885b7cdd 100644
--- a/www-apps/blohg/ChangeLog
+++ b/www-apps/blohg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/blohg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/ChangeLog,v 1.8 2011/07/10 18:48:49 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/ChangeLog,v 1.9 2011/08/30 05:06:53 rafaelmartins Exp $
+
+*blohg-0.7 (30 Aug 2011)
+
+ 30 Aug 2011; Rafael G. Martins <rafaelmartins@gentoo.org> +blohg-0.7.ebuild:
+ Version bump.
*blohg-0.6.1 (10 Jul 2011)
diff --git a/www-apps/blohg/blohg-0.7.ebuild b/www-apps/blohg/blohg-0.7.ebuild
new file mode 100644
index 000000000000..ac8ceb655106
--- /dev/null
+++ b/www-apps/blohg/blohg-0.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/blohg/blohg-0.7.ebuild,v 1.1 2011/08/30 05:06:53 rafaelmartins Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils
+
+DESCRIPTION="A Mercurial-based blogging engine."
+HOMEPAGE="http://blohg.org/ http://pypi.python.org/pypi/blohg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=dev-python/docutils-0.7
+ >=dev-python/flask-0.7
+ >=dev-python/flask-babel-0.6
+ >=dev-python/flask-script-0.3
+ >=dev-python/jinja-2.5.2
+ >=dev-vcs/mercurial-1.6
+ dev-python/pyyaml
+ dev-python/setuptools
+ dev-python/pygments
+ doc? ( dev-python/sphinx )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo 'building documentation'
+ emake -C docs html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ einfo 'installing documentation'
+ dohtml -r docs/_build/html/*
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo "If you're upgrading from <=blohg-0.5.1, please read the upgrade notes:"
+ einfo "http://docs.blohg.org/upgrade/#from-0-5-1-to-0-6"
+}