summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-24 07:17:13 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-24 07:17:13 +0000
commit409bcdc319d9ae1090ed8687ba832ff035286eb9 (patch)
treef933bb2655452be5d65ec15df0bcf58ebcfc6b01 /www-apps/horde
parentmake built_with_use() more flexible (diff)
downloadgentoo-2-409bcdc319d9ae1090ed8687ba832ff035286eb9.tar.gz
gentoo-2-409bcdc319d9ae1090ed8687ba832ff035286eb9.tar.bz2
gentoo-2-409bcdc319d9ae1090ed8687ba832ff035286eb9.zip
only force USE=session if php-5.x or better #75108
Diffstat (limited to 'www-apps/horde')
-rw-r--r--www-apps/horde/horde-2.2.7.ebuild11
-rw-r--r--www-apps/horde/horde-3.0_rc3.ebuild10
2 files changed, 17 insertions, 4 deletions
diff --git a/www-apps/horde/horde-2.2.7.ebuild b/www-apps/horde/horde-2.2.7.ebuild
index afc15599a1af..b15f06a38e34 100644
--- a/www-apps/horde/horde-2.2.7.ebuild
+++ b/www-apps/horde/horde-2.2.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horde/horde-2.2.7.ebuild,v 1.2 2004/12/17 04:49:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horde/horde-2.2.7.ebuild,v 1.3 2004/12/24 07:17:13 vapier Exp $
-HORDE_PHP_FEATURES="nls session"
+#HORDE_PHP_FEATURES="nls session"
inherit horde
DESCRIPTION="Horde Application Framework"
@@ -16,6 +16,13 @@ RDEPEND=">=dev-php/mod_php-4.1.0
>=dev-libs/libxml2-2.4.21
>=www-apps/horde-pear-1.3"
+pkg_setup() {
+ has_version '>=dev-php/mod_php-5' \
+ && HORDE_PHP_FEATURES="nls session" \
+ || HORDE_PHP_FEATURES="nls"
+ horde_pkg_setup
+}
+
src_install() {
horde_src_install
chmod 0000 test.php
diff --git a/www-apps/horde/horde-3.0_rc3.ebuild b/www-apps/horde/horde-3.0_rc3.ebuild
index 942ae8933cb5..eeaec3feeb30 100644
--- a/www-apps/horde/horde-3.0_rc3.ebuild
+++ b/www-apps/horde/horde-3.0_rc3.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/horde/horde-3.0_rc3.ebuild,v 1.1 2004/12/17 05:24:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horde/horde-3.0_rc3.ebuild,v 1.2 2004/12/24 07:17:13 vapier Exp $
-HORDE_PHP_FEATURES="nls session"
inherit horde
DESCRIPTION="Horde Application Framework"
@@ -16,6 +15,13 @@ RDEPEND=">=dev-php/mod_php-4.1.0
>=dev-libs/libxml2-2.4.21
>=www-apps/horde-pear-1.3"
+pkg_setup() {
+ has_version '>=dev-php/mod_php-5' \
+ && HORDE_PHP_FEATURES="nls session" \
+ || HORDE_PHP_FEATURES="nls"
+ horde_pkg_setup
+}
+
pkg_postinst() {
horde_pkg_postinst
echo