summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-14 14:47:21 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-14 14:47:21 +0000
commitff73299901b2dd0814995bdc7636ae4b6c98d9cf (patch)
tree694cf75b1d50ee6c3ce3d588d195a121585e64ab /www-apps/jekyll-paginate
parentStable on alpha, bug 514906 (diff)
downloadgentoo-2-ff73299901b2dd0814995bdc7636ae4b6c98d9cf.tar.gz
gentoo-2-ff73299901b2dd0814995bdc7636ae4b6c98d9cf.tar.bz2
gentoo-2-ff73299901b2dd0814995bdc7636ae4b6c98d9cf.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'www-apps/jekyll-paginate')
-rw-r--r--www-apps/jekyll-paginate/ChangeLog7
-rw-r--r--www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/www-apps/jekyll-paginate/ChangeLog b/www-apps/jekyll-paginate/ChangeLog
index 5158c30709d9..af95c3beb176 100644
--- a/www-apps/jekyll-paginate/ChangeLog
+++ b/www-apps/jekyll-paginate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/jekyll-paginate
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/jekyll-paginate/ChangeLog,v 1.1 2014/08/15 14:52:22 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/jekyll-paginate/ChangeLog,v 1.2 2014/10/14 14:47:21 mrueg Exp $
+
+*jekyll-paginate-1.1.0 (14 Oct 2014)
+
+ 14 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +jekyll-paginate-1.1.0.ebuild:
+ Version bump.
*jekyll-paginate-1.0.0 (15 Aug 2014)
diff --git a/www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild b/www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild
new file mode 100644
index 000000000000..c92676c86f60
--- /dev/null
+++ b/www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/jekyll-paginate/jekyll-paginate-1.1.0.ebuild,v 1.1 2014/10/14 14:47:21 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Default pagination generator for Jekyll"
+HOMEPAGE="https://github.com/jekyll/jekyll-paginate"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=www-apps/jekyll-2 )"
+
+all_ruby_prepare() {
+ rm Rakefile || die
+ sed -i -e "s/truthy/true/" -e "s/falsey/false/" spec/pager_spec.rb || die
+ # Remove unkown options until Rspec3 is in tree
+ sed -i -e "/expectations.include_chain_clauses_in_custom_matcher_descriptions/d"\
+ -e "/verify_partial_doubles/d" -e "/disable_monkey_patching!/d" spec/spec_helper.rb || die
+}