summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-10-13 00:15:54 +0000
committerTim Harder <radhermit@gentoo.org>2010-10-13 00:15:54 +0000
commit1a31a665957573b4fd3a47e45bb2dbdc5da4f4b4 (patch)
tree68ec8a8782c3e34c0c2642296ec889d1261f9585 /www-apps/moinmoin
parentdrop cups useflag/dep making printing always enabled (diff)
downloadgentoo-2-1a31a665957573b4fd3a47e45bb2dbdc5da4f4b4.tar.gz
gentoo-2-1a31a665957573b4fd3a47e45bb2dbdc5da4f4b4.tar.bz2
gentoo-2-1a31a665957573b4fd3a47e45bb2dbdc5da4f4b4.zip
Version bump to latest security release for bug #339295 and security bugs #305663 and #334697. Bump to EAPI=3, use PYTHON_DEPEND, and update dead links.
(Portage version: 2.2_rc90/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/moinmoin')
-rw-r--r--www-apps/moinmoin/ChangeLog12
-rw-r--r--www-apps/moinmoin/files/postinstall-en.txt2
-rw-r--r--www-apps/moinmoin/moinmoin-1.8.8.ebuild75
3 files changed, 86 insertions, 3 deletions
diff --git a/www-apps/moinmoin/ChangeLog b/www-apps/moinmoin/ChangeLog
index b15f7a554a8f..39fa260c6dd1 100644
--- a/www-apps/moinmoin/ChangeLog
+++ b/www-apps/moinmoin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/moinmoin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/ChangeLog,v 1.64 2009/06/26 08:59:49 a3li Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/ChangeLog,v 1.65 2010/10/13 00:15:54 radhermit Exp $
+
+*moinmoin-1.8.8 (13 Oct 2010)
+
+ 13 Oct 2010; Tim Harder <radhermit@gentoo.org> +moinmoin-1.8.8.ebuild,
+ files/postinstall-en.txt:
+ Version bump to latest security release for bug #339295 and security bugs
+ #305663 and #334697. Bump to EAPI=3, use PYTHON_DEPEND, and update dead
+ links.
26 Jun 2009; Alex Legler <a3li@gentoo.org> -moinmoin-1.8.1.ebuild:
Removing vulnerable version, security bug 268565.
diff --git a/www-apps/moinmoin/files/postinstall-en.txt b/www-apps/moinmoin/files/postinstall-en.txt
index 568aaf0f5373..b4f5381a5514 100644
--- a/www-apps/moinmoin/files/postinstall-en.txt
+++ b/www-apps/moinmoin/files/postinstall-en.txt
@@ -1,5 +1,5 @@
Now please read the installation manual at
-http://moinmoin.wikiwikiweb.de/HelpOnInstalling
+http://master18.moinmo.in/HelpOnInstalling
MoinMoin can work with a variety of webservers. Simple Apache instructions
are given below:
diff --git a/www-apps/moinmoin/moinmoin-1.8.8.ebuild b/www-apps/moinmoin/moinmoin-1.8.8.ebuild
new file mode 100644
index 000000000000..d57ffd2abc2c
--- /dev/null
+++ b/www-apps/moinmoin/moinmoin-1.8.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/moinmoin/moinmoin-1.8.8.ebuild,v 1.1 2010/10/13 00:15:54 radhermit Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+MY_PN="moin"
+PYTHON_MODNAME="MoinMoin"
+
+inherit webapp distutils python
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="Python WikiClone"
+SRC_URI="http://static.moinmo.in/files/${MY_PN}-${PV}.tar.gz"
+HOMEPAGE="http://moinmo.in/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="rss"
+
+DEPEND=""
+RDEPEND=">=dev-python/docutils-0.4
+ rss? ( >=dev-python/pyxml-0.8.4 )"
+
+need_httpd_cgi
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+src_install() {
+ webapp_src_preinst
+ distutils_src_install
+
+ dodoc README docs/CHANGES* docs/README.migration
+ dohtml docs/INSTALL.html
+ rm -rf README docs/
+
+ cd "${D}"/usr/share/moin
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r htdocs/* server/moin.cgi
+ fperms +x "${MY_HTDOCSDIR}/moin.cgi"
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}
+ doins -r data underlay config/wikiconfig.py
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altconfigs
+ doins -r config
+
+ insinto "${MY_HOSTROOTDIR}"/${PF}/altserver
+ doins -r server
+
+ # data needs to be server owned per moin devs
+ cd "${D}/${MY_HOSTROOTDIR}"/${PF}
+ for file in $(find data underlay); do
+ webapp_serverowned "${MY_HOSTROOTDIR}/${PF}/${file}"
+ done
+
+ webapp_configfile "${MY_HOSTROOTDIR}"/${PF}/wikiconfig.py
+ webapp_hook_script "${FILESDIR}"/reconfig-3
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from an older version, please read"
+ ewarn "README.migration in /usr/share/doc/${PF}"
+ ewarn
+
+ distutils_pkg_postinst
+ webapp_pkg_postinst
+}