summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-03 20:45:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-03 20:45:44 +0000
commitaf09f309b1c7b1e81917dbf4bebd7e22a9f539e7 (patch)
tree3bfa0f262a7b8e95ce2398b9f4d3085f7b30d11b /www-apps/viewvc
parentAdded patch to fix screen refreshing, backported from upstream by Andreas K. ... (diff)
downloadgentoo-2-af09f309b1c7b1e81917dbf4bebd7e22a9f539e7.tar.gz
gentoo-2-af09f309b1c7b1e81917dbf4bebd7e22a9f539e7.tar.bz2
gentoo-2-af09f309b1c7b1e81917dbf4bebd7e22a9f539e7.zip
Delete older ebuilds.
Diffstat (limited to 'www-apps/viewvc')
-rw-r--r--www-apps/viewvc/viewvc-1.1.3.ebuild109
-rw-r--r--www-apps/viewvc/viewvc-1.1.4.ebuild110
2 files changed, 0 insertions, 219 deletions
diff --git a/www-apps/viewvc/viewvc-1.1.3.ebuild b/www-apps/viewvc/viewvc-1.1.3.ebuild
deleted file mode 100644
index 03b99dd3ad20..000000000000
--- a/www-apps/viewvc/viewvc-1.1.3.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.1.3.ebuild,v 1.7 2010/03/05 07:34:38 ulm Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit confutils eutils python webapp
-
-WEBAPP_MANUAL_SLOT="yes"
-
-DESCRIPTION="ViewVC, a web interface to CVS and Subversion"
-HOMEPAGE="http://viewvc.org/"
-SRC_URI="http://viewvc.tigris.org/files/documents/3330/47194/${P}.tar.gz"
-
-LICENSE="BSD-2"
-KEYWORDS="amd64 ppc sparc x86"
-IUSE="cvs cvsgraph mod_python mysql pygments +subversion"
-SLOT="0"
-
-DEPEND=""
-RDEPEND="
- cvs? (
- >=dev-lang/python-1.5.2
- dev-vcs/rcs
- )
-
- subversion? (
- >=dev-lang/python-2.0
- >=dev-util/subversion-1.3.1[python]
- )
-
- mod_python? ( www-apache/mod_python )
- !mod_python? ( virtual/httpd-cgi )
-
- cvsgraph? ( >=dev-util/cvsgraph-1.5.0 )
- mysql? ( >=dev-python/mysql-python-0.9.0 )
- pygments? ( dev-python/pygments )
-"
-RESTRICT_PYTHON_ABIS="3.*"
-
-pkg_setup() {
- webapp_pkg_setup
-
- confutils_require_any cvs subversion
-}
-
-src_prepare() {
- find bin/ -type f -print0 | xargs -0 sed -i \
- -e "s|\(^LIBRARY_DIR\)\(.*\$\)|\1 = \"$(python_get_sitedir -f)/${PN}\"|g" \
- -e "s|\(^CONF_PATHNAME\)\(.*\$\)|\1 = \"../conf/viewvc.conf\"|g"
-
- sed -i -e "s|\(self\.options\.template_dir\)\(.*\$\)|\1 = \"${MY_APPDIR}/templates\"|" \
- lib/config.py
-
- sed -i -e "s|^template_dir.*|#&|" conf/viewvc.conf.dist
- mv conf/viewvc.conf{.dist,}
- mv conf/cvsgraph.conf{.dist,}
- mv conf/mimetypes.conf{.dist,}
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc CHANGES COMMITTERS INSTALL README
-
- installation() {
- insinto "$(python_get_sitedir)/${PN}"
- doins -r lib/*
- }
- python_execute_function installation
-
- insinto "${MY_APPDIR}"
- doins -r templates/
-
- if use mysql; then
- exeinto "${MY_HOSTROOTDIR}"/bin
- doexe bin/{*dbadmin,make-database,loginfo-handler}
- fi
-
- insinto "${MY_HOSTROOTDIR}"/conf
- doins conf/{viewvc,cvsgraph,mimetypes}.conf
-
- if use mod_python; then
- insinto "${MY_HTDOCSDIR}"
- doins bin/mod_python/viewvc.py
- doins bin/mod_python/handler.py
- doins bin/mod_python/.htaccess
- use mysql && doins bin/mod_python/query.py
- else
- exeinto "${MY_CGIBINDIR}"
- doexe bin/cgi/viewvc.cgi
- use mysql && doexe bin/cgi/query.cgi
- fi
-
- webapp_configfile "${MY_HOSTROOTDIR}"/conf/{viewvc,cvsgraph}.conf
-
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
- python_mod_optimize viewvc
- elog "Now read INSTALL in /usr/share/doc/${PF} to configure ${PN}"
-}
-
-pkg_postrm() {
- python_mod_cleanup viewvc
-}
diff --git a/www-apps/viewvc/viewvc-1.1.4.ebuild b/www-apps/viewvc/viewvc-1.1.4.ebuild
deleted file mode 100644
index 5fd777f67660..000000000000
--- a/www-apps/viewvc/viewvc-1.1.4.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/viewvc/viewvc-1.1.4.ebuild,v 1.3 2010/03/29 21:53:51 maekke Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit confutils eutils python webapp
-
-WEBAPP_MANUAL_SLOT="yes"
-
-DESCRIPTION="ViewVC, a web interface to CVS and Subversion"
-HOMEPAGE="http://viewvc.org/"
-SRC_URI="http://viewvc.tigris.org/files/documents/3330/47426/${P}.tar.gz"
-
-LICENSE="BSD-2"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-IUSE="cvs cvsgraph mod_python mysql pygments +subversion"
-SLOT="0"
-
-DEPEND=""
-RDEPEND="
- cvs? (
- >=dev-lang/python-1.5.2
- dev-vcs/rcs
- )
-
- subversion? (
- >=dev-lang/python-2.0
- >=dev-util/subversion-1.3.1[python]
- )
-
- mod_python? ( www-apache/mod_python )
- !mod_python? ( virtual/httpd-cgi )
-
- cvsgraph? ( >=dev-util/cvsgraph-1.5.0 )
- mysql? ( >=dev-python/mysql-python-0.9.0 )
- pygments? ( dev-python/pygments )
-"
-RESTRICT_PYTHON_ABIS="3.*"
-
-pkg_setup() {
- webapp_pkg_setup
-
- confutils_require_any cvs subversion
-}
-
-src_prepare() {
- find bin/ -type f -print0 | xargs -0 sed -i \
- -e "s|\(^LIBRARY_DIR\)\(.*\$\)|\1 = \"$(python_get_sitedir -f)/${PN}\"|g" \
- -e "s|\(^CONF_PATHNAME\)\(.*\$\)|\1 = \"../conf/viewvc.conf\"|g"
-
- sed -i -e "s|\(self\.options\.template_dir\)\(.*\$\)|\1 = \"${MY_APPDIR}/templates\"|" \
- lib/config.py
-
- sed -i -e "s|^template_dir.*|#&|" conf/viewvc.conf.dist
- mv conf/viewvc.conf{.dist,}
- mv conf/cvsgraph.conf{.dist,}
- mv conf/mimetypes.conf{.dist,}
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc CHANGES COMMITTERS INSTALL README
-
- installation() {
- insinto "$(python_get_sitedir)/${PN}"
- doins -r lib/*
- }
- python_execute_function installation
-
- insinto "${MY_APPDIR}"
- doins -r templates/
- doins -r templates-contrib/
-
- if use mysql; then
- exeinto "${MY_HOSTROOTDIR}"/bin
- doexe bin/{*dbadmin,make-database,loginfo-handler}
- fi
-
- insinto "${MY_HOSTROOTDIR}"/conf
- doins conf/{viewvc,cvsgraph,mimetypes}.conf
-
- if use mod_python; then
- insinto "${MY_HTDOCSDIR}"
- doins bin/mod_python/viewvc.py
- doins bin/mod_python/handler.py
- doins bin/mod_python/.htaccess
- use mysql && doins bin/mod_python/query.py
- else
- exeinto "${MY_CGIBINDIR}"
- doexe bin/cgi/viewvc.cgi
- use mysql && doexe bin/cgi/query.cgi
- fi
-
- webapp_configfile "${MY_HOSTROOTDIR}"/conf/{viewvc,cvsgraph}.conf
-
- webapp_src_install
-}
-
-pkg_postinst() {
- webapp_pkg_postinst
- python_mod_optimize viewvc
- elog "Now read INSTALL in /usr/share/doc/${PF} to configure ${PN}"
-}
-
-pkg_postrm() {
- python_mod_cleanup viewvc
-}