summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-06-20 15:35:35 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-06-20 15:35:35 +0000
commit3422ce883a9d3104b3c081be1728f1e1fa86cfec (patch)
tree490697f744a2e6835928bab2eb58aa2bfa74a4cb /www-apps
parentamd64 stable, bug #227657; first commit! (diff)
downloadgentoo-2-3422ce883a9d3104b3c081be1728f1e1fa86cfec.tar.gz
gentoo-2-3422ce883a9d3104b3c081be1728f1e1fa86cfec.tar.bz2
gentoo-2-3422ce883a9d3104b3c081be1728f1e1fa86cfec.zip
Bumped gallery to 2.2.5 (sec issue #226059).
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gallery/ChangeLog7
-rw-r--r--www-apps/gallery/gallery-2.2.5.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index 85835d694098..54f4c7bcf8f6 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/gallery
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.136 2008/02/22 15:50:50 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.137 2008/06/20 15:35:35 wrobel Exp $
+
+*gallery-2.2.5 (20 Jun 2008)
+
+ 20 Jun 2008; wrobel@gentoo.org +gallery-2.2.5.ebuild:
+ Bumped gallery to 2.2.5 (sec issue #226059).
22 Feb 2008; Benedikt Böhm <hollow@gentoo.org> gallery-1.5.3.ebuild,
gallery-1.5.7.ebuild, gallery-2.2.4.ebuild:
diff --git a/www-apps/gallery/gallery-2.2.5.ebuild b/www-apps/gallery/gallery-2.2.5.ebuild
new file mode 100644
index 000000000000..c2266f190adc
--- /dev/null
+++ b/www-apps/gallery/gallery-2.2.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.2.5.ebuild,v 1.1 2008/06/20 15:35:35 wrobel Exp $
+
+inherit webapp eutils depend.php confutils
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ffmpeg gd imagemagick mysql netpbm postgres raw unzip zip"
+
+RDEPEND="media-libs/jpeg
+ raw? ( >=media-gfx/dcraw-8.03 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051216 )
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )"
+
+S="${WORKDIR}"/${PN}2
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any gd imagemagick netpbm
+ confutils_require_any mysql postgres
+
+ local php_flags="pcre session"
+ use mysql && php_flags="${php_flags} mysql"
+ use postgres && php_flags="${php_flags} postgres"
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags} || \
+ ( use gd && ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ) ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following USE flags enabled:"
+ eerror
+ eerror "${php_flags}"
+ eerror
+ use gd && eerror "as well as with either gd or gd-external USE flag enabled."
+ die "Re-install ${PHP_PKG}."
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dohtml README.html
+ rm README.html LICENSE MANIFEST
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en2.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading to 2.2 will make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}