summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-07-13 21:37:48 +0000
committerPeter Volkov <pva@gentoo.org>2008-07-13 21:37:48 +0000
commita11e845e2986ef5b411dce783e168ac315c10dce (patch)
tree030039859e662148486b08fcb2b9ada0b1eae2d9 /www-apps
parentRemove x11-base/xorg-server dependancy, as the X dependancies are brought in ... (diff)
downloadgentoo-2-a11e845e2986ef5b411dce783e168ac315c10dce.tar.gz
gentoo-2-a11e845e2986ef5b411dce783e168ac315c10dce.tar.bz2
gentoo-2-a11e845e2986ef5b411dce783e168ac315c10dce.zip
Version bump, bug #229105 thank Philippe Chaintreuil. Fixes security issue #222649, thank Robert Buchholz for report.
(Portage version: 2.2_rc1/cvs/Linux 2.6.22-ovz005 i686)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mantisbt/ChangeLog8
-rw-r--r--www-apps/mantisbt/mantisbt-1.1.2.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index 49332a7e4ca9..3c1344f57f8e 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.56 2008/01/23 20:56:48 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.57 2008/07/13 21:37:48 pva Exp $
+
+*mantisbt-1.1.2 (13 Jul 2008)
+
+ 13 Jul 2008; Peter Volkov <pva@gentoo.org> +mantisbt-1.1.2.ebuild:
+ Version bump, bug #229105 thank Philippe Chaintreuil. Fixes security issue
+ #222649, thank Robert Buchholz for report.
23 Jan 2008; <pva@gentoo.org> -mantisbt-1.0.8.ebuild,
-mantisbt-1.1.0.ebuild:
diff --git a/www-apps/mantisbt/mantisbt-1.1.2.ebuild b/www-apps/mantisbt/mantisbt-1.1.2.ebuild
new file mode 100644
index 000000000000..1325f40cb516
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.1.2.ebuild,v 1.1 2008/07/13 21:37:48 pva Exp $
+
+inherit eutils webapp depend.php
+
+MY_P=mantis-${PV}
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/httpd-php
+ virtual/httpd-cgi
+ dev-php/adodb"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ webapp_pkg_setup
+ has_php
+ require_php_with_use pcre
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ rm -r "${S}"/core/adodb/ # We use external adodb
+}
+
+src_install() {
+ webapp_src_preinst
+ rm doc/{LICENSE,INSTALL}
+ dodoc doc/* packages/mantis-httpd.conf
+
+ rm -rf doc packages
+ mv config_inc.php.sample config_inc.php
+ cp -R . "${D}"/${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/config_inc.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-1.0.0.txt
+ webapp_src_install
+}