summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-02-02 11:17:46 +0000
committerBen de Groot <yngwin@gentoo.org>2013-02-02 11:17:46 +0000
commitc8142be386f2a7dbd8ff4e81430c95cf2d007fc1 (patch)
tree9142af73018c825d3dcd4ed6a48052505b259537 /www-apps
parentoops (diff)
downloadgentoo-2-c8142be386f2a7dbd8ff4e81430c95cf2d007fc1.tar.gz
gentoo-2-c8142be386f2a7dbd8ff4e81430c95cf2d007fc1.tar.bz2
gentoo-2-c8142be386f2a7dbd8ff4e81430c95cf2d007fc1.zip
Version bump and major overhaul of the ebuild
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nikola/ChangeLog7
-rw-r--r--www-apps/nikola/nikola-5.1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/www-apps/nikola/ChangeLog b/www-apps/nikola/ChangeLog
index f49ffb15223e..61d1ad9bfd07 100644
--- a/www-apps/nikola/ChangeLog
+++ b/www-apps/nikola/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/nikola
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/ChangeLog,v 1.7 2013/02/02 11:16:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/ChangeLog,v 1.8 2013/02/02 11:17:46 yngwin Exp $
+
+*nikola-5.1 (02 Feb 2013)
+
+ 02 Feb 2013; Ben de Groot <yngwin@gentoo.org> +nikola-5.1.ebuild:
+ Version bump and major overhaul of the ebuild
*nikola-4.0.3 (02 Oct 2012)
diff --git a/www-apps/nikola/nikola-5.1.ebuild b/www-apps/nikola/nikola-5.1.ebuild
new file mode 100644
index 000000000000..96e3908ad325
--- /dev/null
+++ b/www-apps/nikola/nikola-5.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/nikola/nikola-5.1.ebuild,v 1.3 2013/02/02 11:17:46 yngwin Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} ) # 3_2 should be possible now, but untested
+inherit distutils-r1
+
+DESCRIPTION="A static website and blog generator"
+HOMEPAGE="http://nikola.ralsina.com.ar/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ralsina/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://nikola-generator.googlecode.com/files/${P}.zip"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="jinja markdown"
+
+DEPEND="dev-python/docutils" # needs rst2man to build manpage
+RDEPEND="${DEPEND}
+ =dev-python/configparser-3.2.0*
+ >=dev-python/doit-0.20.0
+ dev-python/imaging
+ dev-python/lxml
+ >=dev-python/mako-0.6
+ >=dev-python/mock-1.0.0
+ dev-python/pygments
+ dev-python/PyRSS2Gen
+ dev-python/requests
+ dev-python/unidecode
+ dev-python/yapsy
+ jinja? ( dev-python/jinja )
+ markdown? ( dev-python/markdown )"
+
+src_install() {
+ distutils-r1_src_install
+
+ # hackish way to remove docs that ended up in the wrong place
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc README.md docs/*.txt
+}
+
+pkg_postinst() {
+ if has_version '<www-apps/nikola-5.0'; then
+ elog 'Nikola has changed quite a lot since the previous major version.'
+ elog 'Please make sure to read the updated documentation.'
+ fi
+}