summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-05-27 19:20:28 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-05-27 19:20:28 +0000
commite8fa6a3677a5d573d694473f12d3c608ac18c633 (patch)
treeaf4a5e3f9da3e7dedff276f7f5f42f7089f43211 /www-apps
parentCleanup vulnerable versions. (diff)
downloadgentoo-2-e8fa6a3677a5d573d694473f12d3c608ac18c633.tar.gz
gentoo-2-e8fa6a3677a5d573d694473f12d3c608ac18c633.tar.bz2
gentoo-2-e8fa6a3677a5d573d694473f12d3c608ac18c633.zip
Version bump to 3.0.6
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/liquid_feedback_frontend/ChangeLog10
-rw-r--r--www-apps/liquid_feedback_frontend/files/postinstall-en.txt2
-rw-r--r--www-apps/liquid_feedback_frontend/liquid_feedback_frontend-3.0.6.ebuild47
3 files changed, 56 insertions, 3 deletions
diff --git a/www-apps/liquid_feedback_frontend/ChangeLog b/www-apps/liquid_feedback_frontend/ChangeLog
index e465c4c3fdcc..ede6eeba26f2 100644
--- a/www-apps/liquid_feedback_frontend/ChangeLog
+++ b/www-apps/liquid_feedback_frontend/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/liquid_feedback_frontend
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_frontend/ChangeLog,v 1.5 2014/11/28 08:06:42 tupone Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_frontend/ChangeLog,v 1.6 2015/05/27 19:20:28 tupone Exp $
+
+*liquid_feedback_frontend-3.0.6 (27 May 2015)
+
+ 27 May 2015; Alfredo Tupone <tupone@gentoo.org>
+ +liquid_feedback_frontend-3.0.6.ebuild, files/postinstall-en.txt:
+ Version bump to 3.0.6
*liquid_feedback_frontend-2.2.7 (28 Nov 2014)
diff --git a/www-apps/liquid_feedback_frontend/files/postinstall-en.txt b/www-apps/liquid_feedback_frontend/files/postinstall-en.txt
index 688f693c48cb..80758792d817 100644
--- a/www-apps/liquid_feedback_frontend/files/postinstall-en.txt
+++ b/www-apps/liquid_feedback_frontend/files/postinstall-en.txt
@@ -24,7 +24,7 @@ INSERT INTO contingent (polling, time_frame, text_entry_limit, initiative_limit)
INSERT INTO contingent (polling, time_frame, text_entry_limit, initiative_limit) VALUES (true, '1 day', 800, 120);
INSERT INTO policy (index, name, admission_time, discussion_time, verification_time, voting_time, issue_quorum_num, issue_quorum_den, initiative_quorum_num, initiative_quorum_den) VALUES (1, 'Default policy', '8 days', '15 days', '8 days', '15 days', 10, 100, 10, 100);
-cd /var/liquid_feedback_frontend
+cd /var/lib/liquid_feedback_frontend
/usr/lib/webmcp/framework/bin/webmcp_shell myconfig
Lua 5.1.5 Copyright (C) 1994-2012 Lua.org, PUC-Rio
> member = Member:by_id(1)
diff --git a/www-apps/liquid_feedback_frontend/liquid_feedback_frontend-3.0.6.ebuild b/www-apps/liquid_feedback_frontend/liquid_feedback_frontend-3.0.6.ebuild
new file mode 100644
index 000000000000..19ce61cb3efc
--- /dev/null
+++ b/www-apps/liquid_feedback_frontend/liquid_feedback_frontend-3.0.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/liquid_feedback_frontend/liquid_feedback_frontend-3.0.6.ebuild,v 1.1 2015/05/27 19:20:28 tupone Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+PN_F=${PN}
+PV_F=v${PV}
+MY_P=${PN}-v${PV}
+
+DESCRIPTION="Internet platforms for proposition development and decision making"
+HOMEPAGE="http://www.public-software-group.org/liquid_feedback"
+SRC_URI="http://www.public-software-group.org/pub/projects/liquid_feedback/frontend/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="HPND CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=www-apps/liquid_feedback_core-3.0.4"
+DEPEND="www-apps/rocketwiki-lqfb
+ www-servers/apache
+ >=www-apps/webmcp-1.2.6
+ ${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodoc "${FILESDIR}"/lqfb.example.com.conf
+ dodoc "${FILESDIR}"/postinstall-en.txt
+
+ insinto /var/lib/${PN}
+ doins -r app db env model static tmp
+ insinto /var/lib/${PN}/locale
+ doins locale/*.lua
+
+ insinto /etc/${PN}
+ doins "${FILESDIR}"/myconfig.lua config/*
+ dosym /etc/${PN} /var/lib/${PN}/config
+
+ insinto /usr/share/${PN}
+ doins "${FILESDIR}"/lqfb-apache.conf
+
+ fowners apache:apache /var/lib/${PN}/tmp
+}