summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-11-04 13:43:37 +0000
committerSamuli Suominen <drac@gentoo.org>2007-11-04 13:43:37 +0000
commit65e540fc632d86a522bde7029cc5db9a249a2e1a (patch)
tree9255eb379c4ddc2ea8c9d0e7d38701cff411ea55 /www-client/downman
parentNew cmake-utils.eclass providing functions for the cmake build system with al... (diff)
downloadgentoo-2-65e540fc632d86a522bde7029cc5db9a249a2e1a.tar.gz
gentoo-2-65e540fc632d86a522bde7029cc5db9a249a2e1a.tar.bz2
gentoo-2-65e540fc632d86a522bde7029cc5db9a249a2e1a.zip
Revision bump, saving it from treecleaners wrt #126572. Since old versions failed to build with modern GCC, commit this straight to stable.
(Portage version: 2.1.3.17, RepoMan options: --force)
Diffstat (limited to 'www-client/downman')
-rw-r--r--www-client/downman/ChangeLog10
-rw-r--r--www-client/downman/downman-0.0.4.ebuild23
-rw-r--r--www-client/downman/downman-0.0.5-r1.ebuild32
-rw-r--r--www-client/downman/downman-0.0.5.ebuild30
-rw-r--r--www-client/downman/files/0.0.5-gcc34.patch44
-rw-r--r--www-client/downman/files/digest-downman-0.0.43
-rw-r--r--www-client/downman/files/digest-downman-0.0.5-r1 (renamed from www-client/downman/files/digest-downman-0.0.5)0
-rw-r--r--www-client/downman/files/downman-0.0.5-gcc-4.patch108
-rw-r--r--www-client/downman/files/downman-0.0.5-strlen.patch22
9 files changed, 171 insertions, 101 deletions
diff --git a/www-client/downman/ChangeLog b/www-client/downman/ChangeLog
index 2286773161df..1dc6e781e47f 100644
--- a/www-client/downman/ChangeLog
+++ b/www-client/downman/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/downman
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/downman/ChangeLog,v 1.4 2007/05/11 18:28:33 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/downman/ChangeLog,v 1.5 2007/11/04 13:43:36 drac Exp $
+
+*downman-0.0.5-r1 (04 Nov 2007)
+
+ 04 Nov 2007; Samuli Suominen <drac@gentoo.org>
+ +files/downman-0.0.5-gcc-4.patch, +files/downman-0.0.5-strlen.patch,
+ +downman-0.0.5-r1.ebuild:
+ Revision bump, saving it from treecleaners wrt #126572. Since old versions
+ failed to build with modern GCC, commit this straight to stable.
11 May 2007; Thilo Bangert <bangert@gentoo.org> +metadata.xml:
add metadata.xml
diff --git a/www-client/downman/downman-0.0.4.ebuild b/www-client/downman/downman-0.0.4.ebuild
deleted file mode 100644
index 971a0ef60986..000000000000
--- a/www-client/downman/downman-0.0.4.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/downman/downman-0.0.4.ebuild,v 1.1 2005/03/17 17:52:13 seemant Exp $
-
-inherit gnome2
-
-DESCRIPTION="Download Manager (aka downman) is a suite of programs to download files"
-HOMEPAGE="http://downman.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ppc ~sparc ~alpha amd64"
-IUSE=""
-
-DEPEND=">=x11-libs/gtk+-2.0
- >=dev-libs/glib-2.0
- >=gnome-base/libgnome-2.0
- >=gnome-base/libgnomeui-2.0
- >=gnome-base/libglade-2.0
- >=dev-libs/libxml2-2.0"
-
-DOCS="ABOUT-NLS AUTHORS ChangeLog COPYING README INSTALL NEWS"
diff --git a/www-client/downman/downman-0.0.5-r1.ebuild b/www-client/downman/downman-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..1bc37c24871e
--- /dev/null
+++ b/www-client/downman/downman-0.0.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/downman/downman-0.0.5-r1.ebuild,v 1.1 2007/11/04 13:43:36 drac Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Suite of programs to download files."
+HOMEPAGE="http://downman.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ppc ~sparc alpha amd64"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=dev-libs/libxml2-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc-4.patch
+ epatch "${FILESDIR}"/${P}-strlen.patch
+ epatch "${FILESDIR}"/${P}-desktop-entry.patch
+}
diff --git a/www-client/downman/downman-0.0.5.ebuild b/www-client/downman/downman-0.0.5.ebuild
deleted file mode 100644
index eac109b71072..000000000000
--- a/www-client/downman/downman-0.0.5.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/downman/downman-0.0.5.ebuild,v 1.1 2005/03/17 17:52:13 seemant Exp $
-
-inherit eutils gnome2
-
-DESCRIPTION="Download Manager (aka downman) is a suite of programs to download files"
-HOMEPAGE="http://downman.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ppc ~sparc alpha amd64"
-IUSE=""
-
-DEPEND=">=x11-libs/gtk+-2.0
- >=dev-libs/glib-2.0
- >=gnome-base/libgnome-2.0
- >=gnome-base/libgnomeui-2.0
- >=gnome-base/libglade-2.0
- >=dev-libs/libxml2-2.0"
-
-DOCS="ABOUT-NLS AUTHORS ChangeLog COPYING README INSTALL NEWS"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch ${FILESDIR}/${PV}-gcc34.patch
-}
diff --git a/www-client/downman/files/0.0.5-gcc34.patch b/www-client/downman/files/0.0.5-gcc34.patch
deleted file mode 100644
index 951162573a7e..000000000000
--- a/www-client/downman/files/0.0.5-gcc34.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -uprN clients.orig/gnome/gdownman/gdownman.c clients/gnome/gdownman/gdownman.c
---- clients.orig/gnome/gdownman/gdownman.c 2005-02-20 13:28:00.682539288 +0100
-+++ clients/gnome/gdownman/gdownman.c 2005-02-20 13:32:41.778806160 +0100
-@@ -781,6 +781,7 @@ gdownman_select_matched (GtkWidget *call
- break;
-
- default:
-+ ;
- }
-
- gtk_widget_destroy(dialog);
-diff -uprN clients.orig/gnome/gdownman/new-project.c clients/gnome/gdownman/new-project.c
---- clients.orig/gnome/gdownman/new-project.c 2005-02-20 13:28:00.684538984 +0100
-+++ clients/gnome/gdownman/new-project.c 2005-02-20 13:35:32.724818416 +0100
-@@ -201,6 +201,7 @@ new_project_response_cb (GtkDialog *dial
- break;
-
- default:
-+ ;
- }
-
- gtk_widget_destroy (GTK_WIDGET (dialog));
-diff -uprN clients.orig/gnome/gdownman/new-url.c clients/gnome/gdownman/new-url.c
---- clients.orig/gnome/gdownman/new-url.c 2005-02-20 13:28:00.682539288 +0100
-+++ clients/gnome/gdownman/new-url.c 2005-02-20 13:34:19.128006832 +0100
-@@ -227,6 +227,7 @@ new_url_response_cb (GtkDialog *dialog,
- break;
-
- default:
-+ ;
- }
-
- gtk_widget_destroy (GTK_WIDGET (dialog));
-diff -uprN clients.orig/gnome/monitor/dmgmonitor.c clients/gnome/monitor/dmgmonitor.c
---- clients.orig/gnome/monitor/dmgmonitor.c 2005-02-20 13:28:00.685538832 +0100
-+++ clients/gnome/monitor/dmgmonitor.c 2005-02-20 13:28:08.049419352 +0100
-@@ -277,6 +277,7 @@ void dmgmonitor_download_new(GtkWidget *
- break;
-
- default:
-+ ;
- }
-
- gtk_widget_destroy(dialog);
diff --git a/www-client/downman/files/digest-downman-0.0.4 b/www-client/downman/files/digest-downman-0.0.4
deleted file mode 100644
index 507dc72af4e6..000000000000
--- a/www-client/downman/files/digest-downman-0.0.4
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 4c60ea7bc1375199a8dcbb937124680b downman-0.0.4.tar.gz 175517
-RMD160 6dd5cc77aa72e5ffda308cb9c31702f497ca8fe5 downman-0.0.4.tar.gz 175517
-SHA256 6119bb321cfc684ec464fe96fd508d048426e86f31a3d4adc2fdbf35806890c4 downman-0.0.4.tar.gz 175517
diff --git a/www-client/downman/files/digest-downman-0.0.5 b/www-client/downman/files/digest-downman-0.0.5-r1
index 2ce3e17a061f..2ce3e17a061f 100644
--- a/www-client/downman/files/digest-downman-0.0.5
+++ b/www-client/downman/files/digest-downman-0.0.5-r1
diff --git a/www-client/downman/files/downman-0.0.5-gcc-4.patch b/www-client/downman/files/downman-0.0.5-gcc-4.patch
new file mode 100644
index 000000000000..3085898558c2
--- /dev/null
+++ b/www-client/downman/files/downman-0.0.5-gcc-4.patch
@@ -0,0 +1,108 @@
+diff -ur downman-0.0.5.orig/clients/gnome/gdownman/gdownman.c downman-0.0.5/clients/gnome/gdownman/gdownman.c
+--- downman-0.0.5.orig/clients/gnome/gdownman/gdownman.c 2003-10-05 19:12:38.000000000 +0300
++++ downman-0.0.5/clients/gnome/gdownman/gdownman.c 2007-11-04 15:32:10.000000000 +0200
+@@ -781,6 +781,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ gtk_widget_destroy(dialog);
+diff -ur downman-0.0.5.orig/clients/gnome/gdownman/gtkcellrendererprogressbar.c downman-0.0.5/clients/gnome/gdownman/gtkcellrendererprogressbar.c
+--- downman-0.0.5.orig/clients/gnome/gdownman/gtkcellrendererprogressbar.c 2003-08-05 22:37:42.000000000 +0300
++++ downman-0.0.5/clients/gnome/gdownman/gtkcellrendererprogressbar.c 2007-11-04 15:32:20.000000000 +0200
+@@ -19,7 +19,7 @@
+ */
+
+ #include <stdlib.h>
+-#include "gtkcellrendererprogressbar.h"
++#include <gtk/gtkcellrendererprogress.h>
+
+ static void gtk_cell_renderer_progress_init (GtkCellRendererProgress *celltext);
+ static void gtk_cell_renderer_progress_class_init (GtkCellRendererProgressClass *class);
+@@ -53,7 +53,7 @@
+ PROP_VALUE
+ };
+
+-struct _GtkCellRendererProgressPriv {
++struct _GtkCellRendererProgressPrivate {
+ double value;
+ };
+
+@@ -89,9 +89,9 @@
+ static void
+ gtk_cell_renderer_progress_init (GtkCellRendererProgress *cellprogress)
+ {
+- GtkCellRendererProgressPriv *priv;
++ GtkCellRendererProgressPrivate *priv;
+
+- cellprogress->priv = (GtkCellRendererProgressPriv*)g_new0(GtkCellRendererProgressPriv, 1);
++ cellprogress->priv = (GtkCellRendererProgressPrivate*)g_new0(GtkCellRendererProgressPrivate, 1);
+
+ cellprogress->priv->value = 0;
+ }
+diff -ur downman-0.0.5.orig/clients/gnome/gdownman/gtkcellrendererprogressbar.h downman-0.0.5/clients/gnome/gdownman/gtkcellrendererprogressbar.h
+--- downman-0.0.5.orig/clients/gnome/gdownman/gtkcellrendererprogressbar.h 2003-08-05 22:37:51.000000000 +0300
++++ downman-0.0.5/clients/gnome/gdownman/gtkcellrendererprogressbar.h 2007-11-04 15:32:20.000000000 +0200
+@@ -22,7 +22,9 @@
+ #define __CELL_RENDERER_H__
+
+ #include <gtk/gtkcellrenderer.h>
++#include <gtk/gtkcellrendererprogress.h>
+
++/*
+ G_BEGIN_DECLS
+
+ #define GTK_TYPE_CELL_RENDERER_PROGRESS (gtk_cell_renderer_get_type ())
+@@ -45,5 +47,6 @@
+ GtkCellRenderer* gtk_cell_renderer_progress_new(void);
+
+ G_END_DECLS
++*/
+
+ #endif
+diff -ur downman-0.0.5.orig/clients/gnome/gdownman/new-project.c downman-0.0.5/clients/gnome/gdownman/new-project.c
+--- downman-0.0.5.orig/clients/gnome/gdownman/new-project.c 2003-10-05 19:07:29.000000000 +0300
++++ downman-0.0.5/clients/gnome/gdownman/new-project.c 2007-11-04 15:32:10.000000000 +0200
+@@ -201,6 +201,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ gtk_widget_destroy (GTK_WIDGET (dialog));
+diff -ur downman-0.0.5.orig/clients/gnome/gdownman/new-url.c downman-0.0.5/clients/gnome/gdownman/new-url.c
+--- downman-0.0.5.orig/clients/gnome/gdownman/new-url.c 2003-07-23 21:59:02.000000000 +0300
++++ downman-0.0.5/clients/gnome/gdownman/new-url.c 2007-11-04 15:32:10.000000000 +0200
+@@ -227,6 +227,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ gtk_widget_destroy (GTK_WIDGET (dialog));
+diff -ur downman-0.0.5.orig/clients/gnome/gdownman/project.c downman-0.0.5/clients/gnome/gdownman/project.c
+--- downman-0.0.5.orig/clients/gnome/gdownman/project.c 2003-09-27 18:45:47.000000000 +0300
++++ downman-0.0.5/clients/gnome/gdownman/project.c 2007-11-04 15:32:20.000000000 +0200
+@@ -5,7 +5,6 @@
+ #include <utillib.h>
+
+ #include "gdownman-marshal.h"
+-#include "gtkcellrendererprogressbar.h"
+
+ #include "project-settings.h"
+ #include "project.h"
+diff -ur downman-0.0.5.orig/clients/gnome/monitor/dmgmonitor.c downman-0.0.5/clients/gnome/monitor/dmgmonitor.c
+--- downman-0.0.5.orig/clients/gnome/monitor/dmgmonitor.c 2003-10-05 19:01:15.000000000 +0300
++++ downman-0.0.5/clients/gnome/monitor/dmgmonitor.c 2007-11-04 15:32:10.000000000 +0200
+@@ -277,6 +277,7 @@
+ break;
+
+ default:
++ ;
+ }
+
+ gtk_widget_destroy(dialog);
diff --git a/www-client/downman/files/downman-0.0.5-strlen.patch b/www-client/downman/files/downman-0.0.5-strlen.patch
new file mode 100644
index 000000000000..32516e75ae74
--- /dev/null
+++ b/www-client/downman/files/downman-0.0.5-strlen.patch
@@ -0,0 +1,22 @@
+diff -Naur downman-0.0.5-orig/daemon/debug.c downman-0.0.5/daemon/debug.c
+--- downman-0.0.5-orig/daemon/debug.c 2003-02-17 17:26:43.000000000 -0500
++++ downman-0.0.5/daemon/debug.c 2007-11-04 07:34:25.000000000 -0500
+@@ -5,6 +5,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <string.h>
+
+ #include <glib.h>
+
+diff -Naur downman-0.0.5-orig/daemon/transfer.c downman-0.0.5/daemon/transfer.c
+--- downman-0.0.5-orig/daemon/transfer.c 2003-10-04 08:03:19.000000000 -0400
++++ downman-0.0.5/daemon/transfer.c 2007-11-04 07:34:29.000000000 -0500
+@@ -3,6 +3,7 @@
+ #include <glib.h>
+ #include <libgnomevfs/gnome-vfs-ops.h>
+ #include <libgnomevfs/gnome-vfs-uri.h>
++#include <string.h>
+
+ #include <utillib.h>
+