summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2008-07-28 20:40:25 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2008-07-28 20:40:25 +0000
commit7cf10127a2267183dda02a941550d6d334e77e0e (patch)
tree64467177ef84f4f15f9c0545d2d7f7016f5d5c45 /www-client/epiphany
parentadd GLEP 56 USE flag desc from use.local.desc (diff)
downloadgentoo-2-7cf10127a2267183dda02a941550d6d334e77e0e.tar.gz
gentoo-2-7cf10127a2267183dda02a941550d6d334e77e0e.tar.bz2
gentoo-2-7cf10127a2267183dda02a941550d6d334e77e0e.zip
Fix build against =www-client/mozilla-firefox-2.0* (bug #230834)
(Portage version: 2.2_rc3/cvs/Linux 2.6.26 i686)
Diffstat (limited to 'www-client/epiphany')
-rw-r--r--www-client/epiphany/ChangeLog7
-rw-r--r--www-client/epiphany/epiphany-2.22.3.ebuild9
-rw-r--r--www-client/epiphany/files/epiphany-2.22.3-firefox2.0-header-fix.patch11
3 files changed, 25 insertions, 2 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 9283e104ce25..0e81b21dbed8 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.163 2008/07/27 18:52:21 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.164 2008/07/28 20:40:24 ford_prefect Exp $
+
+ 28 Jul 2008; Arun Raghavan <ford_prefect@gentoo.org>
+ +files/epiphany-2.22.3-firefox2.0-header-fix.patch,
+ epiphany-2.22.3.ebuild:
+ Fix build against =www-client/mozilla-firefox-2.0* (bug #230834)
26 Jul 2008; Olivier Crête <tester@gentoo.org> epiphany-2.22.3.ebuild:
Stable on amd64, bug #229709
diff --git a/www-client/epiphany/epiphany-2.22.3.ebuild b/www-client/epiphany/epiphany-2.22.3.ebuild
index 453248f5f7c1..b1425b6246b5 100644
--- a/www-client/epiphany/epiphany-2.22.3.ebuild
+++ b/www-client/epiphany/epiphany-2.22.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.22.3.ebuild,v 1.2 2008/07/27 18:52:21 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.22.3.ebuild,v 1.3 2008/07/28 20:40:24 ford_prefect Exp $
inherit gnome2 eutils multilib
@@ -68,6 +68,13 @@ pkg_setup() {
fi
}
+src_unpack() {
+ gnome2_src_unpack
+
+ # build fix with firefox 2.0 (bug #230834)
+ epatch "${FILESDIR}/${P}-firefox2.0-header-fix.patch"
+}
+
src_compile() {
addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat.tmp
diff --git a/www-client/epiphany/files/epiphany-2.22.3-firefox2.0-header-fix.patch b/www-client/epiphany/files/epiphany-2.22.3-firefox2.0-header-fix.patch
new file mode 100644
index 000000000000..206f0003dd08
--- /dev/null
+++ b/www-client/epiphany/files/epiphany-2.22.3-firefox2.0-header-fix.patch
@@ -0,0 +1,11 @@
+diff -Naur epiphany-2.22.3-old/embed/mozilla/MozRegisterComponents.cpp epiphany-2.22.3/embed/mozilla/MozRegisterComponents.cpp
+--- epiphany-2.22.3-old/embed/mozilla/MozRegisterComponents.cpp 2008-07-05 17:45:42.000000000 +0200
++++ epiphany-2.22.3/embed/mozilla/MozRegisterComponents.cpp 2008-07-05 17:44:58.000000000 +0200
+@@ -31,6 +31,7 @@
+ #include <nsCOMPtr.h>
+ #include <nsCURILoader.h>
+ #include <nsDocShellCID.h>
++#include <nsIBadCertListener.h>
+ #include <nsICategoryManager.h>
+ #include <nsIComponentManager.h>
+ #include <nsIComponentRegistrar.h>