summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-02-04 18:35:30 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-02-04 18:35:30 +0000
commitc9fa272a97d69ed56244319db7e94bba5a08d0c4 (patch)
treea3f2fd3d18823f3afff43ee58a6b1a3970a47aa2 /www-client/firefox-bin
parentPort tbd-bin to the new mozlinguas.eclass (diff)
downloadgentoo-2-c9fa272a97d69ed56244319db7e94bba5a08d0c4.tar.gz
gentoo-2-c9fa272a97d69ed56244319db7e94bba5a08d0c4.tar.bz2
gentoo-2-c9fa272a97d69ed56244319db7e94bba5a08d0c4.zip
Port to the new mozlinguas.eclass
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'www-client/firefox-bin')
-rw-r--r--www-client/firefox-bin/ChangeLog5
-rw-r--r--www-client/firefox-bin/firefox-bin-10.0.ebuild102
2 files changed, 32 insertions, 75 deletions
diff --git a/www-client/firefox-bin/ChangeLog b/www-client/firefox-bin/ChangeLog
index c3dd2ab7e155..d4a391adc8bc 100644
--- a/www-client/firefox-bin/ChangeLog
+++ b/www-client/firefox-bin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-client/firefox-bin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/ChangeLog,v 1.82 2012/01/31 18:09:40 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/ChangeLog,v 1.83 2012/02/04 18:35:30 nirbheek Exp $
+
+ 04 Feb 2012; Nirbheek Chauhan <nirbheek@gentoo.org> firefox-bin-10.0.ebuild:
+ Port to the new mozlinguas.eclass
*firefox-bin-10.0 (31 Jan 2012)
diff --git a/www-client/firefox-bin/firefox-bin-10.0.ebuild b/www-client/firefox-bin/firefox-bin-10.0.ebuild
index 5a398b708ffe..d35171ad996b 100644
--- a/www-client/firefox-bin/firefox-bin-10.0.ebuild
+++ b/www-client/firefox-bin/firefox-bin-10.0.ebuild
@@ -1,27 +1,33 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/firefox-bin-10.0.ebuild,v 1.1 2012/01/31 18:09:40 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox-bin/firefox-bin-10.0.ebuild,v 1.2 2012/02/04 18:35:30 nirbheek Exp $
EAPI="3"
-inherit eutils multilib mozextension pax-utils fdo-mime gnome2-utils nsplugins
-
# Can be updated using scripts/get_langs.sh from mozilla overlay
-LANGS=(af ak ar ast be bg bn-BD bn-IN br bs ca cs cy da de el en en-GB en-US
-en-ZA eo es-AR es-CL es-ES es-MX et eu fa fi fr fy-NL ga-IE gd gl gu-IN he hi-IN
-hr hu hy-AM id is it ja kk kn ko ku lg lt lv mai mk ml mr nb-NO nl nn-NO nso or
-pa-IN pl pt-BR pt-PT rm ro ru si sk sl son sq sr sv-SE ta ta-LK te th tr uk vi
-zh-CN zh-TW zu)
+MOZ_LANGS=(af ak ar as ast be bg bn-BD bn-IN br bs ca cs csb cy da de el en
+en-GB en-US en-ZA eo es-AR es-CL es-ES es-MX et eu fa fi fr fy-NL ga-IE gd gl
+gu-IN he hi-IN hr hu hy-AM id is it ja kk kn ko ku lg lt lv mai mk ml mr nb-NO
+nl nn-NO nso or pa-IN pl pt-BR pt-PT rm ro ru si sk sl son sq sr sv-SE ta ta-LK
+te th tr uk vi zh-CN zh-TW zu)
+
+# Convert the ebuild version to the upstream mozilla version, used by mozlinguas
+MOZ_PV="${PV/_beta/b}" # Handle beta for SRC_URI
+MOZ_PV="${MOZ_PV/_rc/rc}" # Handle rc for SRC_URI
+MOZ_PN="${PN/-bin}"
+MOZ_P="${MOZ_PN}-${MOZ_PV}"
-MY_PV="${PV/_rc/rc}"
-MY_PN="${PN/-bin}"
-MY_P="${MY_PN}-${MY_PV}"
+# Upstream ftp release URI that's used by mozlinguas.eclass
+# We don't use the http mirror because it deletes old tarballs.
+MOZ_FTP_URI="ftp://ftp.mozilla.org/pub/mozilla.org/${MOZ_PN}/releases/"
+
+inherit eutils multilib pax-utils fdo-mime gnome2-utils mozlinguas
DESCRIPTION="Firefox Web Browser"
-FTP_URI="ftp://ftp.mozilla.org/pub/mozilla.org/${MY_PN}/releases"
-SRC_URI="
- amd64? ( ${FTP_URI}/${MY_PV}/linux-x86_64/en-US/${MY_P}.tar.bz2 -> ${PN}_x86_64-${PV}.tar.bz2 )
- x86? ( ${FTP_URI}/${MY_PV}/linux-i686/en-US/${MY_P}.tar.bz2 -> ${PN}_i686-${PV}.tar.bz2 )"
+MOZ_FTP_URI="ftp://ftp.mozilla.org/pub/mozilla.org/${MOZ_PN}/releases"
+SRC_URI="${SRC_URI}
+ amd64? ( ${MOZ_FTP_URI}/${MOZ_PV}/linux-x86_64/en-US/${MOZ_P}.tar.bz2 -> ${PN}_x86_64-${PV}.tar.bz2 )
+ x86? ( ${MOZ_FTP_URI}/${MOZ_PV}/linux-i686/en-US/${MOZ_P}.tar.bz2 -> ${PN}_i686-${PV}.tar.bz2 )"
HOMEPAGE="http://www.mozilla.com/firefox"
RESTRICT="strip mirror"
@@ -30,22 +36,6 @@ SLOT="0"
LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
IUSE="startup-notification"
-for X in "${LANGS[@]}" ; do
- # en and en_US are handled internally
- if [[ ${X} != en ]] && [[ ${X} != en-US ]]; then
- SRC_URI="${SRC_URI}
- linguas_${X/-/_}? ( ${FTP_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P/-bin/}-${X}.xpi )"
- fi
- IUSE="${IUSE} linguas_${X/-/_}"
- # Install all the specific locale xpis if there's no generic locale xpi
- # Example: there's no pt.xpi, so install all pt-*.xpi
- if ! has ${X%%-*} "${LANGS[@]}"; then
- SRC_URI="${SRC_URI}
- linguas_${X%%-*}? ( ${FTP_URI}/${MY_PV}/linux-i686/xpi/${X}.xpi -> ${P/-bin/}-${X}.xpi )"
- IUSE="${IUSE} linguas_${X%%-*}"
- fi
-done
-
DEPEND="app-arch/unzip"
RDEPEND="dev-libs/dbus-glib
x11-libs/libXrender
@@ -56,51 +46,17 @@ RDEPEND="dev-libs/dbus-glib
>=media-libs/alsa-lib-1.0.16
"
-S="${WORKDIR}/${MY_PN}"
-
-# TODO: Move all the linguas crap to an eclass
-linguas() {
- # Generate the list of language packs called "linguas"
- # This list is used to install the xpi language packs
- local LINGUA
- for LINGUA in ${LINGUAS}; do
- if has ${LINGUA} en en_US; then
- # For mozilla products, en and en_US are handled internally
- continue
- # If this language is supported by ${P},
- elif has ${LINGUA} "${LANGS[@]//-/_}"; then
- # Add the language to linguas, if it isn't already there
- has ${LINGUA//_/-} "${linguas[@]}" || linguas+=(${LINGUA//_/-})
- continue
- # For each short LINGUA that isn't in LANGS,
- # add *all* long LANGS to the linguas list
- elif ! has ${LINGUA%%-*} "${LANGS[@]}"; then
- for LANG in "${LANGS[@]}"; do
- if [[ ${LANG} == ${LINGUA}-* ]]; then
- has ${LANG} "${linguas[@]}" || linguas+=(${LANG})
- continue 2
- fi
- done
- fi
- ewarn "Sorry, but ${P} does not support the ${LINGUA} locale"
- done
-}
+S="${WORKDIR}/${MOZ_PN}"
src_unpack() {
unpack ${A}
- linguas
- for X in "${linguas[@]}"; do
- # FIXME: Add support for unpacking xpis to portage
- [[ ${X} != "en" ]] && xpi_unpack "${P/-bin/}-${X}.xpi"
- done
- if [[ "${linguas[*]}" != "" && "${linguas[*]}" != "en" ]]; then
- einfo "Selected language packs (first will be default): ${linguas[*]}"
- fi
+ # Unpack language packs
+ mozlinguas_src_unpack
}
src_install() {
- declare MOZILLA_FIVE_HOME=/opt/${MY_PN}
+ declare MOZILLA_FIVE_HOME=/opt/${MOZ_PN}
# Install icon and .desktop for menu entry
newicon "${S}"/chrome/icons/default/default48.png ${PN}-icon.png
@@ -119,10 +75,8 @@ src_install() {
insinto ${MOZILLA_FIVE_HOME}/defaults/pref/
doins "${FILESDIR}"/${PN}-prefs.js || die
- linguas
- for X in "${linguas[@]}"; do
- [[ ${X} != "en" ]] && xpi_install "${WORKDIR}"/"${P/-bin/}-${X}"
- done
+ # Install language packs
+ mozlinguas_src_install
local LANG=${linguas%% *}
if [[ -n ${LANG} && ${LANG} != "en" ]]; then
@@ -139,7 +93,7 @@ src_install() {
unset LD_PRELOAD
LD_LIBRARY_PATH="/opt/firefox/"
GTK_PATH=/usr/lib/gtk-2.0/
- exec /opt/${MY_PN}/${MY_PN} "\$@"
+ exec /opt/${MOZ_PN}/${MOZ_PN} "\$@"
EOF
fperms 0755 /usr/bin/${PN}