summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-06-30 13:05:47 +0000
committerTim Harder <radhermit@gentoo.org>2012-06-30 13:05:47 +0000
commitdd825e85eefe7b6c6458ca51263a98d7b6f62880 (patch)
treeffd093da1453ecb72ca7bf0b6f52e0ccbf011739 /www-client/luakit/luakit-9999.ebuild
parentVersion bump with connman support, remove old. (diff)
downloadgentoo-2-dd825e85eefe7b6c6458ca51263a98d7b6f62880.tar.gz
gentoo-2-dd825e85eefe7b6c6458ca51263a98d7b6f62880.tar.bz2
gentoo-2-dd825e85eefe7b6c6458ca51263a98d7b6f62880.zip
Version bump (bug #410729) and update live ebuild. Update to EAPI 4, respect CFLAGS, respect CC, and use vcs-snapshot eclass to unpack release tarballs.
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'www-client/luakit/luakit-9999.ebuild')
-rw-r--r--www-client/luakit/luakit-9999.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/www-client/luakit/luakit-9999.ebuild b/www-client/luakit/luakit-9999.ebuild
index d839cfc882c7..d8be17368ec6 100644
--- a/www-client/luakit/luakit-9999.ebuild
+++ b/www-client/luakit/luakit-9999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/luakit-9999.ebuild,v 1.19 2012/05/03 06:01:02 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/luakit/luakit-9999.ebuild,v 1.20 2012/06/30 13:05:47 radhermit Exp $
-EAPI=3
+EAPI=4
+inherit toolchain-funcs
IUSE="luajit vim-syntax"
if [[ ${PV} == *9999* ]]; then
@@ -14,7 +15,7 @@ if [[ ${PV} == *9999* ]]; then
KEYWORDS=""
SRC_URI=""
else
- inherit base
+ inherit vcs-snapshot
MY_PV="${PV/_p/-r}"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/mason-larobina/${PN}/tarball/${MY_PV} -> ${P}.tar.gz"
@@ -49,13 +50,8 @@ RDEPEND="
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
"
-src_unpack() {
- if [[ ${PV} == *9999* ]]; then
- git-2_src_unpack
- else
- base_src_unpack
- mv mason-larobina-luakit-* "${S}"
- fi
+src_prepare() {
+ sed -i -e "/^CFLAGS/s/-ggdb//" config.mk || die
}
src_compile() {
@@ -66,19 +62,18 @@ src_compile() {
myconf+=" VERSION=${PV}"
fi
- emake ${myconf} || die "emake failed"
+ tc-export CC
+ emake ${myconf}
}
src_install() {
- emake PREFIX="/usr" DESTDIR="${D}" DOCDIR="${D}/usr/share/doc/${PF}" install ||
- die "Installation failed"
+ emake PREFIX="/usr" DESTDIR="${D}" DOCDIR="${D}/usr/share/doc/${PF}" install
if use vim-syntax; then
local t
for t in $(ls "${S}"/extras/vim/); do
insinto /usr/share/vim/vimfiles/"${t}"
- doins "${S}"/extras/vim/"${t}"/luakit.vim ||
- die "vim-${t} doins failed"
+ doins "${S}"/extras/vim/"${t}"/luakit.vim
done
fi
}