summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-11-28 17:26:14 +0000
committerJeroen Roovers <jer@gentoo.org>2012-11-28 17:26:14 +0000
commit4abba3aba1ae9da2d371ddab6c58437b8162dca9 (patch)
tree259997de2636a63cf7084f170ff8da13e22b2c86 /www-client/opera
parentUse virtual/udev instead of sys-fs/udev wrt #444398 (diff)
downloadgentoo-2-4abba3aba1ae9da2d371ddab6c58437b8162dca9.tar.gz
gentoo-2-4abba3aba1ae9da2d371ddab6c58437b8162dca9.tar.bz2
gentoo-2-4abba3aba1ae9da2d371ddab6c58437b8162dca9.zip
Fix the difference between snapshot and release builds in the version string.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'www-client/opera')
-rw-r--r--www-client/opera/ChangeLog8
-rw-r--r--www-client/opera/opera-12.12_pre1662.ebuild (renamed from www-client/opera/opera-12.12.1662.ebuild)41
2 files changed, 38 insertions, 11 deletions
diff --git a/www-client/opera/ChangeLog b/www-client/opera/ChangeLog
index 42e13eedc152..4374a7924882 100644
--- a/www-client/opera/ChangeLog
+++ b/www-client/opera/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/opera
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.775 2012/11/26 18:06:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/ChangeLog,v 1.776 2012/11/28 17:26:14 jer Exp $
+
+*opera-12.12_pre1662 (28 Nov 2012)
+
+ 28 Nov 2012; Jeroen Roovers <jer@gentoo.org> +opera-12.12_pre1662.ebuild,
+ -opera-12.12.1662.ebuild:
+ Fix the difference between snapshot and release builds in the version string.
*opera-12.12.1662 (26 Nov 2012)
diff --git a/www-client/opera/opera-12.12.1662.ebuild b/www-client/opera/opera-12.12_pre1662.ebuild
index 24914900d825..1254bdffebef 100644
--- a/www-client/opera/opera-12.12.1662.ebuild
+++ b/www-client/opera/opera-12.12_pre1662.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-12.12.1662.ebuild,v 1.1 2012/11/26 18:06:51 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/opera/opera-12.12_pre1662.ebuild,v 1.1 2012/11/28 17:26:14 jer Exp $
EAPI=4
inherit eutils fdo-mime gnome2-utils multilib pax-utils versionator
@@ -16,21 +16,42 @@ IUSE="elibc_FreeBSD gtk kde +gstreamer multilib"
O_V="$(get_version_component_range 1-2)" # Version, i.e. 11.00
O_B="$(get_version_component_range 3)" # Build number, i.e. 1156
-O_D="mantismech_${O_V}-${O_B}"
-O_P="${PN}-${O_V}-${O_B}"
-O_U="http://snapshot.opera.com/unix/"
+# == Variables that often change ==
+# All other variables should be accounted for by _pre/_p
-SRC_URI="
- amd64? ( ${O_U}${O_D}/${O_P}.x86_64.linux.tar.xz )
- x86? ( ${O_U}${O_D}/${O_P}.i386.linux.tar.xz )
- x86-fbsd? ( ${O_U}${O_D}/${O_P}.i386.freebsd.tar.xz )
-"
+O_K="mantismech" # The key to the snapshot URL
O_LINGUAS="
af ar az be bg bn cs da de el en-GB es-ES es-LA et fa fi fr fr-CA fy gd he
hi hr hu id it ja ka kk ko lt lv me mk ms nb nl nn pa pl pt pt-BR ro ru sk
sr sv sw ta te th tl tr uk ur uz vi zh-CN zh-TW zu
-"
+" # Supported linguas
+
+# == End of variables that often change ==
+
+if [[ "pre${O_B/pre/}" = "${O_B}" ]]; then # snapshot: _pre
+ O_B="${O_B/pre}" # remove _pre
+ O_D="${O_K}_${O_V}-${O_B}" # directory string
+ O_P="${PN}-${O_V}-${O_B}" # package string
+ O_U="http://snapshot.opera.com/unix/" # base URI
+
+ SRC_URI="
+ amd64? ( ${O_U}${O_D}/${O_P}.x86_64.linux.tar.xz )
+ x86? ( ${O_U}${O_D}/${O_P}.i386.linux.tar.xz )
+ x86-fbsd? ( ${O_U}${O_D}/${O_P}.i386.freebsd.tar.xz )
+ "
+else # release: _p
+ O_B="${O_B/p}" # remove _p
+ O_D="${O_V/./}" # directory string
+ O_P="${PN}-${O_V}-${O_B}" # package string
+ O_U="mirror://opera/" # base URI
+
+ SRC_URI="
+ amd64? ( ${O_U}linux/${O_D}/${O_P}.x86_64.linux.tar.xz )
+ x86? ( ${O_U}linux/${O_D}/${O_P}.i386.linux.tar.xz )
+ x86-fbsd? ( ${O_U}unix/${O_D}/${O_P}.i386.freebsd.tar.xz )
+ "
+fi
for O_LINGUA in ${O_LINGUAS}; do
IUSE+=" linguas_${O_LINGUA/-/_}"