summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-10-29 08:28:10 +0000
committerHans de Graaff <graaff@gentoo.org>2014-10-29 08:28:10 +0000
commit457fa514cc993ba58c0e72c8f5057454b27d6ede (patch)
tree2e1bf12b39ea3135bd4fe3aef1ff268fe7128488 /www-client/phantomjs
parentfix build of ocamlopt binaries/libs (diff)
downloadgentoo-2-457fa514cc993ba58c0e72c8f5057454b27d6ede.tar.gz
gentoo-2-457fa514cc993ba58c0e72c8f5057454b27d6ede.tar.bz2
gentoo-2-457fa514cc993ba58c0e72c8f5057454b27d6ede.zip
Non-maintainer version bump to address POODLE mitigation. Phantomjs now uses TLSv1 by default instead of SSLv3.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'www-client/phantomjs')
-rw-r--r--www-client/phantomjs/ChangeLog9
-rw-r--r--www-client/phantomjs/phantomjs-1.9.7.ebuild6
-rw-r--r--www-client/phantomjs/phantomjs-1.9.8.ebuild79
3 files changed, 91 insertions, 3 deletions
diff --git a/www-client/phantomjs/ChangeLog b/www-client/phantomjs/ChangeLog
index 9cc328a8e630..1e70152c6fc7 100644
--- a/www-client/phantomjs/ChangeLog
+++ b/www-client/phantomjs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/phantomjs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/phantomjs/ChangeLog,v 1.14 2014/07/28 05:19:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/phantomjs/ChangeLog,v 1.15 2014/10/29 08:28:10 graaff Exp $
+
+*phantomjs-1.9.8 (29 Oct 2014)
+
+ 29 Oct 2014; Hans de Graaff <graaff@gentoo.org> phantomjs-1.9.7.ebuild,
+ +phantomjs-1.9.8.ebuild:
+ Non-maintainer version bump to address POODLE mitigation. Phantomjs now uses
+ TLSv1 by default instead of SSLv3.
28 Jul 2014; Mike Frysinger <vapier@gentoo.org> metadata.xml:
Drop myself as maintainer.
diff --git a/www-client/phantomjs/phantomjs-1.9.7.ebuild b/www-client/phantomjs/phantomjs-1.9.7.ebuild
index 9687ac4ec684..d5c476bd31c4 100644
--- a/www-client/phantomjs/phantomjs-1.9.7.ebuild
+++ b/www-client/phantomjs/phantomjs-1.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/phantomjs/phantomjs-1.9.7.ebuild,v 1.2 2014/03/04 21:39:14 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/phantomjs/phantomjs-1.9.7.ebuild,v 1.3 2014/10/29 08:28:10 graaff Exp $
EAPI=5
@@ -18,7 +18,9 @@ IUSE="examples"
RDEPEND="dev-libs/icu:=
dev-libs/openssl
media-libs/fontconfig
- media-libs/freetype"
+ media-libs/freetype
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10"
DEPEND="${RDEPEND}
app-arch/unzip
virtual/pkgconfig"
diff --git a/www-client/phantomjs/phantomjs-1.9.8.ebuild b/www-client/phantomjs/phantomjs-1.9.8.ebuild
new file mode 100644
index 000000000000..cd3359432ccd
--- /dev/null
+++ b/www-client/phantomjs/phantomjs-1.9.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/phantomjs/phantomjs-1.9.8.ebuild,v 1.1 2014/10/29 08:28:10 graaff Exp $
+
+EAPI=5
+
+inherit toolchain-funcs pax-utils multiprocessing
+
+DESCRIPTION="A headless WebKit scriptable with a JavaScript API"
+HOMEPAGE="http://phantomjs.org/"
+SRC_URI="https://bitbucket.org/ariya/phantomjs/downloads/${P}-source.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-libs/icu:=
+ dev-libs/openssl
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e '/^# CONFIG += text_breaking_with_icu/s:#::' \
+ src/qt/src/3rdparty/webkit/Source/JavaScriptCore/JavaScriptCore.pri \
+ || die
+
+ # Respect CC, CXX, {C,CXX,LD}FLAGS in .qmake.cache
+ sed -i \
+ -e "/^SYSTEM_VARIABLES=/i \
+ CC='$(tc-getCC)'\n\
+ CXX='$(tc-getCXX)'\n\
+ CFLAGS='${CFLAGS}'\n\
+ CXXFLAGS='${CXXFLAGS}'\n\
+ LDFLAGS='${LDFLAGS}'\n\
+ QMakeVar set QMAKE_CFLAGS_RELEASE\n\
+ QMakeVar set QMAKE_CFLAGS_DEBUG\n\
+ QMakeVar set QMAKE_CXXFLAGS_RELEASE\n\
+ QMakeVar set QMAKE_CXXFLAGS_DEBUG\n\
+ QMakeVar set QMAKE_LFLAGS_RELEASE\n\
+ QMakeVar set QMAKE_LFLAGS_DEBUG\n"\
+ src/qt/configure \
+ || die
+
+ # Respect CC, CXX, LINK and *FLAGS in config.tests
+ find src/qt/config.tests/unix -name '*.test' -type f -exec \
+ sed -i -e "/bin\/qmake/ s: \"\$SRCDIR/: \
+ 'QMAKE_CC=$(tc-getCC)' 'QMAKE_CXX=$(tc-getCXX)' 'QMAKE_LINK=$(tc-getCXX)' \
+ 'QMAKE_CFLAGS+=${CFLAGS}' 'QMAKE_CXXFLAGS+=${CXXFLAGS}' 'QMAKE_LFLAGS+=${LDFLAGS}'&:" \
+ {} + || die
+}
+
+src_compile() {
+ ./build.sh \
+ --confirm \
+ --jobs $(makeopts_jobs) \
+ --qt-config "$($(tc-getPKG_CONFIG) --cflags-only-I freetype2)" \
+ || die
+}
+
+src_test() {
+ ./bin/phantomjs test/run-tests.js || die
+}
+
+src_install() {
+ pax-mark m bin/phantomjs || die
+ dobin bin/phantomjs
+ dodoc ChangeLog README.md
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ fi
+}