summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-05-31 14:12:53 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-05-31 14:12:53 +0000
commit6d7447d24da105226e1d6a411db1d1c96cddf3b5 (patch)
tree8cb1071e8b6af540705591de048aeceb0ba1bfa6 /www-client/seamonkey-bin
parentversion bump to 0.7 (diff)
downloadgentoo-2-6d7447d24da105226e1d6a411db1d1c96cddf3b5.tar.gz
gentoo-2-6d7447d24da105226e1d6a411db1d1c96cddf3b5.tar.bz2
gentoo-2-6d7447d24da105226e1d6a411db1d1c96cddf3b5.zip
Version bump, security bug #180436
(Portage version: 2.1.2.7)
Diffstat (limited to 'www-client/seamonkey-bin')
-rw-r--r--www-client/seamonkey-bin/ChangeLog8
-rw-r--r--www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.23
-rw-r--r--www-client/seamonkey-bin/seamonkey-bin-1.1.2.ebuild72
3 files changed, 82 insertions, 1 deletions
diff --git a/www-client/seamonkey-bin/ChangeLog b/www-client/seamonkey-bin/ChangeLog
index 396d3a52d3dd..68e7633320bf 100644
--- a/www-client/seamonkey-bin/ChangeLog
+++ b/www-client/seamonkey-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/seamonkey-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.11 2007/03/24 15:24:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/ChangeLog,v 1.12 2007/05/31 14:12:53 armin76 Exp $
+
+*seamonkey-bin-1.1.2 (31 May 2007)
+
+ 31 May 2007; Raúl Porcel <armin76@gentoo.org>
+ +seamonkey-bin-1.1.2.ebuild:
+ Version bump, security bug #180436
24 Mar 2007; Raúl Porcel <armin76@gentoo.org> seamonkey-bin-1.1.1.ebuild:
Some minor ebuild changes, modify the deps a bit
diff --git a/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.2 b/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.2
new file mode 100644
index 000000000000..2d6b41d1d131
--- /dev/null
+++ b/www-client/seamonkey-bin/files/digest-seamonkey-bin-1.1.2
@@ -0,0 +1,3 @@
+MD5 deccd8113b2f43c1a94c679ce102a1cf seamonkey-1.1.2.en-US.linux-i686.tar.gz 14770947
+RMD160 762731d89f99435ddffcece82ce6861b5e863d47 seamonkey-1.1.2.en-US.linux-i686.tar.gz 14770947
+SHA256 d256aff8f7b1d402036db340c18557416df97c33365f868c64bbbc4eb793b3eb seamonkey-1.1.2.en-US.linux-i686.tar.gz 14770947
diff --git a/www-client/seamonkey-bin/seamonkey-bin-1.1.2.ebuild b/www-client/seamonkey-bin/seamonkey-bin-1.1.2.ebuild
new file mode 100644
index 000000000000..049afe329dcf
--- /dev/null
+++ b/www-client/seamonkey-bin/seamonkey-bin-1.1.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey-bin/seamonkey-bin-1.1.2.ebuild,v 1.1 2007/05/31 14:12:53 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/${PV}/seamonkey-${PV}.en-US.linux-i686.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/seamonkey/"
+RESTRICT="nostrip"
+
+KEYWORDS="-* ~amd64 ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x86? (
+ >=x11-libs/gtk+-2.2
+ =virtual/libstdc++-3.3
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ app-emulation/emul-linux-x86-compat
+ )
+ >=www-client/mozilla-launcher-1.41"
+
+S=${WORKDIR}/seamonkey
+
+pkg_setup() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Install mozilla in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv ${S} ${D}${MOZILLA_FIVE_HOME}
+
+ # Install /usr/bin/seamonkey-bin
+ install_mozilla_launcher_stub seamonkey-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/seamonkey-bin.png
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/seamonkey-bin.desktop
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/seamonkey
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${ROOT}${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}