summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-07-18 17:37:32 +0000
committerJeroen Roovers <jer@gentoo.org>2012-07-18 17:37:32 +0000
commit7b212531a0627b0e624ca1ad26545db4394b85ec (patch)
treedf95396365668f488126f2b487085c002e7efbc9 /www-client/surf
parentVersion bump. Do not install VERSION. (diff)
downloadgentoo-2-7b212531a0627b0e624ca1ad26545db4394b85ec.tar.gz
gentoo-2-7b212531a0627b0e624ca1ad26545db4394b85ec.tar.bz2
gentoo-2-7b212531a0627b0e624ca1ad26545db4394b85ec.zip
Version bump.
(Portage version: 2.2.0_alpha119/cvs/Linux x86_64)
Diffstat (limited to 'www-client/surf')
-rw-r--r--www-client/surf/ChangeLog7
-rw-r--r--www-client/surf/surf-0.5.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/www-client/surf/ChangeLog b/www-client/surf/ChangeLog
index ae2f46e189e5..2b47813cec6e 100644
--- a/www-client/surf/ChangeLog
+++ b/www-client/surf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/surf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.18 2012/03/09 09:12:23 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/ChangeLog,v 1.19 2012/07/18 17:37:32 jer Exp $
+
+*surf-0.5 (18 Jul 2012)
+
+ 18 Jul 2012; Jeroen Roovers <jer@gentoo.org> +surf-0.5.ebuild:
+ Version bump.
09 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> surf-0.4.1-r1.ebuild:
x86 stable wrt bug #373573
diff --git a/www-client/surf/surf-0.5.ebuild b/www-client/surf/surf-0.5.ebuild
new file mode 100644
index 000000000000..12128474e8aa
--- /dev/null
+++ b/www-client/surf/surf-0.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surf/surf-0.5.ebuild,v 1.1 2012/07/18 17:37:32 jer Exp $
+
+EAPI=4
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="http://surf.suckless.org/"
+SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/glib
+ net-libs/libsoup
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+RDEPEND="
+ !sci-chemistry/surf
+ !savedconfig? ( net-misc/wget x11-terms/xterm )
+ x11-apps/xprop
+ x11-misc/dmenu
+ ${DEPEND}
+"
+
+pkg_setup() {
+ elog "net-misc/wget and x11-terms/xterm will be installed by default to"
+ elog "support the default download command, which can be changed through"
+ elog "the savedconfig mechanism. If you enable USE=savedconfig, you will"
+ elog "need to satisfy requirements for the alternative download command"
+ elog "yourself."
+}
+
+src_prepare() {
+ sed -i \
+ -e 's|{|(|g;s|}|)|g' \
+ -e 's|\t@|\t|g;s|echo|@&|g' \
+ -e 's|^LIBS.*|LIBS = $(GTKLIB) -lgthread-2.0|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \
+ -e 's|^CC.*|CC ?= gcc|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
+ config.mk Makefile || die "sed failed"
+ restore_config config.h
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ save_config config.h
+}
+
+pkg_postinst() {
+ ewarn "Please correct the permissions of your \$HOME/.surf/ directory"
+ ewarn "and its contents to no longer be world readable (see bug #404983)"
+}