summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-05-13 04:28:31 +0000
committerJeroen Roovers <jer@gentoo.org>2009-05-13 04:28:31 +0000
commit9de37dae274db18878c248de16117a4fe449cbcd (patch)
tree754eca247e4fd8dccee2e83afd446745769a9715 /www-client/surfraw
parentclean up p.mask for recent removals from tree (diff)
downloadgentoo-2-9de37dae274db18878c248de16117a4fe449cbcd.tar.gz
gentoo-2-9de37dae274db18878c248de16117a4fe449cbcd.tar.bz2
gentoo-2-9de37dae274db18878c248de16117a4fe449cbcd.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'www-client/surfraw')
-rw-r--r--www-client/surfraw/ChangeLog9
-rw-r--r--www-client/surfraw/surfraw-2.2.5.ebuild75
2 files changed, 82 insertions, 2 deletions
diff --git a/www-client/surfraw/ChangeLog b/www-client/surfraw/ChangeLog
index 716ffb38d077..d3de6926caba 100644
--- a/www-client/surfraw/ChangeLog
+++ b/www-client/surfraw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-client/surfraw
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/ChangeLog,v 1.36 2009/04/14 14:58:02 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/ChangeLog,v 1.37 2009/05/13 04:28:31 jer Exp $
+
+*surfraw-2.2.5 (13 May 2009)
+
+ 13 May 2009; Jeroen Roovers <jer@gentoo.org> +surfraw-2.2.5.ebuild:
+ Version bump.
14 Apr 2009; Jeroen Roovers <jer@gentoo.org> -surfraw-2.2.3.ebuild:
Remove old.
diff --git a/www-client/surfraw/surfraw-2.2.5.ebuild b/www-client/surfraw/surfraw-2.2.5.ebuild
new file mode 100644
index 000000000000..56b3bd1bd4aa
--- /dev/null
+++ b/www-client/surfraw/surfraw-2.2.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/surfraw-2.2.5.ebuild,v 1.1 2009/05/13 04:28:31 jer Exp $
+
+inherit bash-completion eutils
+
+DESCRIPTION="A fast unix command line interface to WWW"
+HOMEPAGE="http://surfraw.alioth.debian.org/"
+SRC_URI="http://${PN}.alioth.debian.org/dist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.1.5-gentoo_pkg_tools.patch
+ # Man page symlinks shouldn't link to compressed files
+ sed -i 's,\.gz,,g' links.IN
+}
+
+src_compile() {
+ econf \
+ --with-elvidir='$(datadir)'/surfraw \
+ --disable-opensearch \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog HACKING NEWS README TODO
+
+ dobashcompletion surfraw-bash-completion
+}
+
+pkg_preinst() {
+ has_version "=${CATEGORY}/${PN}-1.0.7"
+ upgrade_from_1_0_7=$?
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ einfo
+ einfo "You can get a list of installed elvi by just typing 'surfraw' or"
+ einfo "the abbreviated 'sr'."
+ einfo
+ einfo "You can try some searches, for example:"
+ einfo "$ sr ask why is jeeves gay? "
+ einfo "$ sr google -results=100 RMS, GNU, which is sinner, which is sin?"
+ einfo "$ sr rhyme -method=perfect Julian"
+ einfo
+ einfo "The system configuration file is /etc/surfraw.conf"
+ einfo
+ einfo "Users can specify preferences in '~/.surfraw.conf' e.g."
+ einfo "SURFRAW_graphical_browser=mozilla"
+ einfo "SURFRAW_text_browser=w3m"
+ einfo "SURFRAW_graphical=no"
+ einfo
+ einfo "surfraw works with any graphical and/or text WWW browser"
+ einfo
+ if [[ $upgrade_from_1_0_7 = 0 ]] ; then
+ ewarn "surfraw usage has changed slightly since version 1.0.7, elvi are now called"
+ ewarn "using the 'sr' wrapper script as described above. If you wish to return to"
+ ewarn "the old behaviour you can add /usr/share/surfraw to your \$PATH"
+ fi
+ # This file was always autogenerated, and is no longer needed.
+ if [ -f "${ROOT}"/etc/surfraw_elvi.list ]; then
+ rm -f "${ROOT}"/etc/surfraw_elvi.list
+ fi
+}