summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-05-11 00:32:25 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-05-11 00:32:25 +0000
commit04a1f25a844f14bbad9fad23eea315d3f58546a9 (patch)
tree2017c5aad3702ee17c3b220d96c2b60451e84989 /www-client
parentBump. (diff)
downloadgentoo-2-04a1f25a844f14bbad9fad23eea315d3f58546a9.tar.gz
gentoo-2-04a1f25a844f14bbad9fad23eea315d3f58546a9.tar.bz2
gentoo-2-04a1f25a844f14bbad9fad23eea315d3f58546a9.zip
remove dbus useflag. it is no longer optional. fixes #132784
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/ChangeLog8
-rw-r--r--www-client/epiphany/epiphany-2.14.1-r1.ebuild83
-rw-r--r--www-client/epiphany/files/digest-epiphany-2.14.1-r13
3 files changed, 93 insertions, 1 deletions
diff --git a/www-client/epiphany/ChangeLog b/www-client/epiphany/ChangeLog
index 6e9e19f20927..2a25eb3da5f4 100644
--- a/www-client/epiphany/ChangeLog
+++ b/www-client/epiphany/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/epiphany
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.69 2006/05/05 13:22:01 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/ChangeLog,v 1.70 2006/05/11 00:32:24 allanonjl Exp $
+
+*epiphany-2.14.1-r1 (11 May 2006)
+
+ 11 May 2006; John N. Laliberte <allanonjl@gentoo.org>
+ -epiphany-2.14.1.ebuild, +epiphany-2.14.1-r1.ebuild:
+ remove dbus useflag. it is no longer optional. fixes #132784
05 May 2006; John N. Laliberte <allanonjl@gentoo.org>
epiphany-2.14.1.ebuild:
diff --git a/www-client/epiphany/epiphany-2.14.1-r1.ebuild b/www-client/epiphany/epiphany-2.14.1-r1.ebuild
new file mode 100644
index 000000000000..7f584c7c7b2c
--- /dev/null
+++ b/www-client/epiphany/epiphany-2.14.1-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany/epiphany-2.14.1-r1.ebuild,v 1.1 2006/05/11 00:32:24 allanonjl Exp $
+
+inherit eutils gnome2 multilib autotools
+
+DESCRIPTION="GNOME webbrowser based on the mozilla rendering engine"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc firefox python"
+
+# Note that there is no libgnomeprint dep, while it is
+# specified in configure.in . This could in some rare
+# situations break portage dep resolution.
+#
+# Marinus <foser@gentoo.org> 14-9-2005
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=x11-libs/gtk+-2.8.3
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/libglade-2.3.1
+ >=gnome-base/gnome-vfs-2.9.2
+ >=gnome-base/libgnomeui-2.6
+ >=gnome-base/gnome-desktop-2.9.91
+ >=x11-libs/startup-notification-0.5
+ >=gnome-base/libgnomeprintui-2.4
+ >=gnome-base/libbonobo-2
+ >=gnome-base/orbit-2
+ >=gnome-base/gconf-2
+ >=app-text/iso-codes-0.35
+ !firefox? ( >=www-client/mozilla-1.7.9 )
+ firefox? ( >=www-client/mozilla-firefox-1.0.5 )
+ >=sys-apps/dbus-0.35
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.7.1
+ >=dev-python/gnome-python-2.6 )
+ x11-themes/gnome-icon-theme"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.29
+ app-text/gnome-doc-utils
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README TODO"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ G2CONF="--disable-scrollkeeper \
+ $(use_enable python)"
+
+ if use firefox; then
+ G2CONF="${G2CONF} --with-mozilla=firefox"
+ else
+ G2CONF="${G2CONF} --with-mozilla=mozilla"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-1.9.2-broken-firefox.patch
+ epatch ${FILESDIR}/${P}-as-needed.patch
+
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR=". ${S}/m4" WANT_AUTOCONF="2.59" \
+ eautoreconf || die "Failed to reconfigure"
+}
+
+src_compile() {
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/xpti.dat
+ addpredict /usr/$(get_libdir)/mozilla-firefox/components/compreg.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat.tmp
+ addpredict /usr/$(get_libdir)/mozilla/components/xpti.dat
+ gnome2_src_compile
+}
diff --git a/www-client/epiphany/files/digest-epiphany-2.14.1-r1 b/www-client/epiphany/files/digest-epiphany-2.14.1-r1
new file mode 100644
index 000000000000..40eb72db6724
--- /dev/null
+++ b/www-client/epiphany/files/digest-epiphany-2.14.1-r1
@@ -0,0 +1,3 @@
+MD5 69f9760646b736d953f24442e0e38f7b epiphany-2.14.1.tar.bz2 3520979
+RMD160 bb755beacab63470381daf32b9d25cf74886e80e epiphany-2.14.1.tar.bz2 3520979
+SHA256 4eb5f8f8dacc81f47c54e3a579af3059cca3a7fa59d6cc270ed5b50d0b6a37a2 epiphany-2.14.1.tar.bz2 3520979