summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2014-09-26 05:30:17 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2014-09-26 05:30:17 +0000
commit79352d7336d73cbb1656526fa68c15f6e4562409 (patch)
tree35875cf3db957394326905dd8243c1f47e90fbb7 /www-client
parentDisable RTTI, bug #521882 . (diff)
downloadgentoo-2-79352d7336d73cbb1656526fa68c15f6e4562409.tar.gz
gentoo-2-79352d7336d73cbb1656526fa68c15f6e4562409.tar.bz2
gentoo-2-79352d7336d73cbb1656526fa68c15f6e4562409.zip
Dev channel bump. Use system protobuf. Remove old.
(Portage version: 2.2.8-r1/cvs/Linux i686, signed Manifest commit with key 0x4F1A2555EA71991D!)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog8
-rw-r--r--www-client/chromium/chromium-39.0.2166.2.ebuild (renamed from www-client/chromium/chromium-39.0.2145.4.ebuild)12
2 files changed, 14 insertions, 6 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index f37857bc142a..c22a44307690 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1137 2014/09/20 02:04:39 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1138 2014/09/26 05:30:17 phajdan.jr Exp $
+
+*chromium-39.0.2166.2 (26 Sep 2014)
+
+ 26 Sep 2014; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -chromium-39.0.2145.4.ebuild, +chromium-39.0.2166.2.ebuild:
+ Dev channel bump. Use system protobuf. Remove old.
*chromium-38.0.2125.66 (20 Sep 2014)
diff --git a/www-client/chromium/chromium-39.0.2145.4.ebuild b/www-client/chromium/chromium-39.0.2166.2.ebuild
index 7f39c1e2ea0f..3442e1e5f97b 100644
--- a/www-client/chromium/chromium-39.0.2145.4.ebuild
+++ b/www-client/chromium/chromium-39.0.2166.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-39.0.2145.4.ebuild,v 1.1 2014/09/05 17:38:59 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-39.0.2166.2.ebuild,v 1.1 2014/09/26 05:30:17 phajdan.jr Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -45,6 +45,7 @@ RDEPEND=">=app-accessibility/speech-dispatcher-0.8:=
dev-libs/libxslt:=
dev-libs/nspr:=
>=dev-libs/nss-3.14.3:=
+ >=dev-libs/protobuf-2.5.0-r1:=
dev-libs/re2:=
gnome? ( >=gnome-base/gconf-2.24.0:= )
gnome-keyring? ( >=gnome-base/libgnome-keyring-3.12:= )
@@ -107,12 +108,14 @@ RDEPEND+="
# Python dependencies. The DEPEND part needs to be kept in sync
# with python_check_deps.
DEPEND+=" $(python_gen_any_dep '
+ dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
')"
python_check_deps() {
- has_version "dev-python/jinja[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/jinja[${PYTHON_USEDEP}]" && \
has_version "dev-python/ply[${PYTHON_USEDEP}]" && \
has_version "dev-python/simplejson[${PYTHON_USEDEP}]"
}
@@ -174,7 +177,7 @@ src_prepare() {
# touch out/Release/gen/sdk/toolchain/linux_x86_newlib/stamp.untar || die
# fi
- epatch "${FILESDIR}/${PN}-system-jinja-r6.patch"
+ epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch_user
@@ -238,7 +241,6 @@ src_prepare() {
'third_party/pdfium/third_party/numerics' \
'third_party/pdfium/third_party/template_util.h' \
'third_party/polymer' \
- 'third_party/protobuf' \
'third_party/qcms' \
'third_party/readability' \
'third_party/sfntly' \
@@ -297,7 +299,6 @@ src_configure() {
# TODO: use_system_libvpx (http://crbug.com/347823).
# TODO: use_system_libusb (http://crbug.com/266149).
# TODO: use_system_opus (https://code.google.com/p/webrtc/issues/detail?id=3077).
- # TODO: use_system_protobuf (bug #503084).
# TODO: use_system_ssl (http://crbug.com/58087).
# TODO: use_system_sqlite (http://crbug.com/22208).
myconf+="
@@ -314,6 +315,7 @@ src_configure() {
-Duse_system_libxslt=1
-Duse_system_minizip=1
-Duse_system_nspr=1
+ -Duse_system_protobuf=1
-Duse_system_re2=1
-Duse_system_snappy=1
-Duse_system_speex=1