summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2015-04-02 07:04:17 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2015-04-02 07:04:17 +0000
commit9a6cd7e86b6ea34b3de9f326a40c8f38c7c5264c (patch)
tree99fd4968b9a76aa7ed00fcb5513b5827d570751f /www-client
parentVersion BUmp (diff)
downloadgentoo-2-9a6cd7e86b6ea34b3de9f326a40c8f38c7c5264c.tar.gz
gentoo-2-9a6cd7e86b6ea34b3de9f326a40c8f38c7c5264c.tar.bz2
gentoo-2-9a6cd7e86b6ea34b3de9f326a40c8f38c7c5264c.zip
Dev channel bump. Fix compile without gconf, bug #544528 by Andrew Waters. Remove old.
(Portage version: 2.2.14/cvs/Linux i686, signed Manifest commit with key 0x4F1A2555EA71991D!)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/chromium/ChangeLog10
-rw-r--r--www-client/chromium/chromium-43.0.2351.3.ebuild (renamed from www-client/chromium/chromium-43.0.2334.0.ebuild)5
-rw-r--r--www-client/chromium/files/chromium-gnome-r0.patch40
3 files changed, 52 insertions, 3 deletions
diff --git a/www-client/chromium/ChangeLog b/www-client/chromium/ChangeLog
index 75ddcaec2a64..09a2b8cf79eb 100644
--- a/www-client/chromium/ChangeLog
+++ b/www-client/chromium/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-client/chromium
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1214 2015/03/27 22:47:16 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/ChangeLog,v 1.1215 2015/04/02 07:04:17 phajdan.jr Exp $
+
+*chromium-43.0.2351.3 (02 Apr 2015)
+
+ 02 Apr 2015; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ -chromium-43.0.2334.0.ebuild, +chromium-43.0.2351.3.ebuild,
+ +files/chromium-gnome-r0.patch:
+ Dev channel bump. Fix compile without gconf, bug #544528 by Andrew Waters.
+ Remove old.
*chromium-42.0.2311.60 (27 Mar 2015)
diff --git a/www-client/chromium/chromium-43.0.2334.0.ebuild b/www-client/chromium/chromium-43.0.2351.3.ebuild
index 273e2a21f309..e4d1ef3b020b 100644
--- a/www-client/chromium/chromium-43.0.2334.0.ebuild
+++ b/www-client/chromium/chromium-43.0.2351.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-43.0.2334.0.ebuild,v 1.1 2015/03/18 19:47:38 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-43.0.2351.3.ebuild,v 1.1 2015/04/02 07:04:17 phajdan.jr Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -194,6 +194,7 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch "${FILESDIR}/${PN}-libsecret-r0.patch"
+ epatch "${FILESDIR}/${PN}-gnome-r0.patch"
if use widevine; then
local WIDEVINE_VERSION="$(< "${ROOT}/usr/$(get_libdir)/chromium-browser/widevine.version")"
@@ -237,7 +238,7 @@ src_prepare() {
'third_party/cros_system_api' \
'third_party/cython/python_flags.py' \
'third_party/dom_distiller_js' \
- 'third_party/dom_distiller_js/package/proto_gen/third_party/dom_distiller_js' \
+ 'third_party/dom_distiller_js/dist/proto_gen/third_party/dom_distiller_js' \
'third_party/ffmpeg' \
'third_party/fips181' \
'third_party/flot' \
diff --git a/www-client/chromium/files/chromium-gnome-r0.patch b/www-client/chromium/files/chromium-gnome-r0.patch
new file mode 100644
index 000000000000..7a8c0a9a57bb
--- /dev/null
+++ b/www-client/chromium/files/chromium-gnome-r0.patch
@@ -0,0 +1,40 @@
+Index: ui/accessibility/platform/atk_util_auralinux.cc
+diff --git a/ui/accessibility/platform/atk_util_auralinux.cc b/ui/accessibility/platform/atk_util_auralinux.cc
+index a15df08137d874609305f90a6bca6e5c15e5c213..7fcaf219351289fe7eba1f670d7a6743a8b40ddc 100644
+--- a/ui/accessibility/platform/atk_util_auralinux.cc
++++ b/ui/accessibility/platform/atk_util_auralinux.cc
+@@ -3,7 +3,9 @@
+ // found in the LICENSE file.
+
+ #include <atk/atk.h>
++#if defined(USE_GCONF)
+ #include <gconf/gconf-client.h>
++#endif
+ #include <glib-2.0/gmodule.h>
+
+ #include "base/files/file_path.h"
+@@ -14,6 +16,8 @@
+
+ namespace {
+
++#if defined(USE_GCONF)
++
+ const char kGnomeAccessibilityEnabledKey[] =
+ "/desktop/gnome/interface/accessibility";
+
+@@ -39,6 +43,15 @@ bool ShouldEnableAccessibility() {
+ return value;
+ }
+
++#else // !defined(USE_GCONF)
++
++bool ShouldEnableAccessibility() {
++ // TODO(k.czech): implement this for non-GNOME desktops.
++ return false;
++}
++
++#endif // defined(USE_GCONF)
++
+ } // namespace
+
+ G_BEGIN_DECLS