summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2014-06-09 13:43:20 +0000
committerSebastian Pipping <sping@gentoo.org>2014-06-09 13:43:20 +0000
commit9c3794ba5637f1648fafcbddaec508e1b21bfa29 (patch)
tree24d00734a38784c220f1f93454f58d4fb24d63e7 /www-client
parentUse real spaces by Dimitri Semitsoglou-Tsiapos (bug #512804). (diff)
downloadgentoo-2-9c3794ba5637f1648fafcbddaec508e1b21bfa29.tar.gz
gentoo-2-9c3794ba5637f1648fafcbddaec508e1b21bfa29.tar.bz2
gentoo-2-9c3794ba5637f1648fafcbddaec508e1b21bfa29.zip
www-client/httrack: 3.48.13
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'www-client')
-rw-r--r--www-client/httrack/ChangeLog8
-rw-r--r--www-client/httrack/files/httrack-3.48.13-minizip.patch74
-rw-r--r--www-client/httrack/httrack-3.48.13.ebuild37
3 files changed, 118 insertions, 1 deletions
diff --git a/www-client/httrack/ChangeLog b/www-client/httrack/ChangeLog
index 9493fd0eb357..62a9ff1d578b 100644
--- a/www-client/httrack/ChangeLog
+++ b/www-client/httrack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/httrack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/httrack/ChangeLog,v 1.64 2014/05/29 16:08:18 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/httrack/ChangeLog,v 1.65 2014/06/09 13:43:20 sping Exp $
+
+*httrack-3.48.13 (09 Jun 2014)
+
+ 09 Jun 2014; Sebastian Pipping <sping@gentoo.org> +httrack-3.48.13.ebuild,
+ +files/httrack-3.48.13-minizip.patch:
+ Bump to 3.48.13
*httrack-3.48.9 (29 May 2014)
diff --git a/www-client/httrack/files/httrack-3.48.13-minizip.patch b/www-client/httrack/files/httrack-3.48.13-minizip.patch
new file mode 100644
index 000000000000..af1610c60dae
--- /dev/null
+++ b/www-client/httrack/files/httrack-3.48.13-minizip.patch
@@ -0,0 +1,74 @@
+From 51bbb53d5805bfa5a4530b8706e2b7f77555016d Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 9 Jun 2014 15:34:43 +0200
+Subject: [PATCH] Fix minizip fork compilation
+
+---
+ src/minizip/ioapi.h | 4 ++++
+ src/minizip/iowin32.h | 3 +++
+ src/minizip/unzip.h | 4 ++++
+ src/minizip/zip.h | 4 ++++
+ 4 files changed, 15 insertions(+)
+
+diff --git a/src/minizip/ioapi.h b/src/minizip/ioapi.h
+index e4462b8..75cc097 100644
+--- a/src/minizip/ioapi.h
++++ b/src/minizip/ioapi.h
+@@ -21,6 +21,10 @@
+ #ifndef _ZLIBIOAPI64_H
+ #define _ZLIBIOAPI64_H
+
++
++#define OF(x) x
++
++
+ #if (!defined(_WIN32)) && (!defined(WIN32)) && (!defined(__APPLE__))
+
+ // Linux needs this to support file operation on files larger then 4+GB
+diff --git a/src/minizip/iowin32.h b/src/minizip/iowin32.h
+index 0ca0969..71244d6 100644
+--- a/src/minizip/iowin32.h
++++ b/src/minizip/iowin32.h
+@@ -14,6 +14,9 @@
+ #include <windows.h>
+
+
++#define OF(x) x
++
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+diff --git a/src/minizip/unzip.h b/src/minizip/unzip.h
+index 2104e39..0b54c40 100644
+--- a/src/minizip/unzip.h
++++ b/src/minizip/unzip.h
+@@ -43,6 +43,10 @@
+ #ifndef _unz64_H
+ #define _unz64_H
+
++
++#define OF(x) x
++
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+diff --git a/src/minizip/zip.h b/src/minizip/zip.h
+index 16dea6b..906ba53 100644
+--- a/src/minizip/zip.h
++++ b/src/minizip/zip.h
+@@ -40,6 +40,10 @@
+ #ifndef _zip12_H
+ #define _zip12_H
+
++
++#define OF(x) x
++
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+--
+1.9.3
+
diff --git a/www-client/httrack/httrack-3.48.13.ebuild b/www-client/httrack/httrack-3.48.13.ebuild
new file mode 100644
index 000000000000..55109766cb4c
--- /dev/null
+++ b/www-client/httrack/httrack-3.48.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/httrack/httrack-3.48.13.ebuild,v 1.1 2014/06/09 13:43:20 sping Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="http://www.httrack.com/"
+SRC_URI="http://mirror.httrack.com/historical/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
+ dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README greetings.txt history.txt )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-minizip.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}