summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-09-08 21:20:23 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-09-08 21:20:23 +0000
commite7f4a40706eeedf5c98c0642bece9057023d5caf (patch)
tree4eeaf51596fad481bf5ff68086263fab00330445 /www-plugins/gnash
parent0.6.11 version bump, and remove old. (diff)
downloadgentoo-2-e7f4a40706eeedf5c98c0642bece9057023d5caf.tar.gz
gentoo-2-e7f4a40706eeedf5c98c0642bece9057023d5caf.tar.bz2
gentoo-2-e7f4a40706eeedf5c98c0642bece9057023d5caf.zip
Fix kde4 headers detection, moc and uic checks, Import patch from Linux Alt to fix klash support, many thanks to Chi-Thanh Christopher Nguyen <chithanh@cs.tu-berlin.de>
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins/gnash')
-rw-r--r--www-plugins/gnash/ChangeLog9
-rw-r--r--www-plugins/gnash/files/gnash-0.8.5-klash.patch96
-rw-r--r--www-plugins/gnash/files/gnash-0.8.5-moc-qt4.patch13
-rw-r--r--www-plugins/gnash/gnash-0.8.5.ebuild19
4 files changed, 131 insertions, 6 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index f8a56f19ddad..299ae8f81144 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.5 2009/09/06 14:55:35 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.6 2009/09/08 21:20:23 mrpouet Exp $
+
+ 08 Sep 2009; Romain Perier <mrpouet@gentoo.org>
+ gnash-0.8.5.ebuild, +files/gnash-0.8.5-klash.patch,
+ +files/gnash-0.8.5-moc-qt4.patch:
+ Fix kde4 headers detection, moc and uic checks, Import patch from Linux
+ Alt to fix klash support, many thanks to Chi-Thanh Christopher Nguyen
+ <chithanh@cs.tu-berlin.de>.
06 Sep 2009; Romain Perier (mrpouet) <mrpouet@gentoo.org>
gnash-0.8.5.ebuild, metadata.xml:
diff --git a/www-plugins/gnash/files/gnash-0.8.5-klash.patch b/www-plugins/gnash/files/gnash-0.8.5-klash.patch
new file mode 100644
index 000000000000..e906439db088
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.5-klash.patch
@@ -0,0 +1,96 @@
+--- gnash-0.8.5/macros/kde4.m4.alt-kde4 2009-02-28 15:27:53 +0300
++++ gnash-0.8.5/macros/kde4.m4 2009-07-15 16:02:13 +0400
+@@ -24,7 +24,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ with_kde4_incl=${withval})
+ dnl make sure the path is a useable one
+ if test x"${with_kde4_incl}" != x ; then
+- if test ! -f ${with_kde4_incl}/kapp.h ; then
++ if test ! -f ${with_kde4_incl}/kapplication.h ; then
+ AC_MSG_ERROR([${with_kde4_incl} directory doesn't contain any KDE 4.x headers])
+ fi
+ fi
+@@ -38,7 +38,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ with_kde4_lib=${withval})
+ dnl make sure the path is a useable one
+ if test x"${with_kde4_lib}" != x ; then
+- if test ! -f ${with_kde4_lib}/libkdeui.la; then
++ if test ! -f ${with_kde4_lib}/libkdeui.so; then
+ AC_MSG_ERROR([${with_kde4_lib} directory doesn't contain any KDE 4.x libraries!])
+ fi
+ fi
+@@ -134,7 +134,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ dnl Look for the libraries
+ AC_CACHE_VAL(ac_cv_path_kde4_lib, [
+ if test x"${with_kde4_lib}" != x ; then
+- if test -f ${with_kde4_lib}/libkdeui.la; then
++ if test -f ${with_kde4_lib}/libkdeui.so; then
+ ac_cv_path_kde4_lib="-L`(cd ${with_kde4_lib}; pwd)`"
+ else
+ AC_MSG_ERROR([${with_kde4_lib} directory doesn't contain KDE 4.x libraries.])
+@@ -144,7 +144,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ AC_MSG_CHECKING([for kdeui library])
+ kde4_topdir=
+ for i in ${kde4_prefix}/lib64 ${kde4_prefix}/lib $libslist ; do
+- if test -f $i/libkdeui.${shlibext} -o -f $i/libkdeui.la; then
++ if test -f $i/libkdeui.${shlibext} -o -f $i/libkdeui.so; then
+ kde4_topdir=$i
+ AC_MSG_RESULT(${kde4_topdir}/libkdeui)
+ if test ! x"$i" = x"/usr/lib" -a ! x"$i" = x"/usr/lib64"; then
+@@ -160,26 +160,13 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ dnl Look for the kdecore library, which is required
+ if test x"${ac_cv_path_kde4_lib}" != x; then
+ AC_MSG_CHECKING([for kdecore library])
+- if test -f ${kde4_topdir}/libkdecore.la; then
++ if test -f ${kde4_topdir}/libkdecore.so; then
+ ac_cv_path_kde4_lib="${ac_cv_path_kde4_lib} -lkdecore"
+ AC_MSG_RESULT(${kde4_topdir}/libkdecore)
+ else
+ AC_MSG_RESULT(no)
+ fi
+ fi
+- dnl Look for the kdeprint library, which is required
+- AC_MSG_CHECKING([for kdeprint library])
+- if test x"${libkdeprint}" = x; then
+- if test -f ${kde4_topdir}/libkdeprint.la -o -f ${kde4_topdir}/libkdeprint.${shlibext}; then
+- ac_cv_path_kde4_lib="${ac_cv_path_kde4_lib} -lkdeprint"
+- AC_MSG_RESULT(${kde4_topdir}/libkdeprint)
+- else
+- AC_MSG_RESULT(no)
+- fi
+- else
+- AC_MSG_RESULT(${libkdeprint})
+- ac_cv_path_kde4_lib="${ac_cv_path_kde4_lib} ${libkdeprint}"
+- fi
+ ]) dnl end of cache ac_cv_path_kde4_lib
+ fi dnl end of build_kde4
+
+@@ -216,7 +203,7 @@ AC_DEFUN([GNASH_PATH_KDE4],
+ fi dnl end of build_kparts4
+
+ if test x"${ac_cv_path_kde4_incl}" != x ; then
+- if test x"${ac_cv_path_kde3_incl}" != x"-I/usr/include"; then
++ if test x"${ac_cv_path_kde4_incl}" != x"-I/usr/include"; then
+ KDE4_CFLAGS="${ac_cv_path_kde4_incl}"
+ else
+ KDE4_CFLAGS=""
+--- gnash-0.8.5/plugin/klash4/Makefile.am.alt-kde4 2009-06-15 11:53:31 +0400
++++ gnash-0.8.5/plugin/klash4/Makefile.am 2009-07-15 16:02:58 +0400
+@@ -42,6 +39,7 @@ libklashpart_la_LDFLAGS = -avoid-version
+ else
+ libklashpart_la_LDFLAGS = -module -avoid-version -L$(plugindir) $(KDE4_LIBS) $(QT4_LIBS)
+ endif
++libklashpart_la_LIBADD = $(KDE4_LIBS) $(QT4_LIBS) $(X11_LIBS) -lkparts
+
+ dist_kde_services_DATA = klash_part.desktop
+ dist_kde_rc_DATA = klashpartui.rc
+--- gnash-0.8.5/plugin/klash4/pluginsinfo.alt-kde4 2008-12-28 13:13:38 +0300
++++ gnash-0.8.5/plugin/klash4/pluginsinfo 2009-07-15 16:02:13 +0400
+@@ -1,7 +1,7 @@
+ number=1
+
+ [0]
+-description=Shockwave Flash 7.0
++description=Shockwave Flash 10.1 r999
+ file=libklashpart.so
+ mime=application/x-shockwave-flash:swf:Shockwave Flash;application/futuresplash:spl:FutureSplash Player
+ name=Shockwave Flash
diff --git a/www-plugins/gnash/files/gnash-0.8.5-moc-qt4.patch b/www-plugins/gnash/files/gnash-0.8.5-moc-qt4.patch
new file mode 100644
index 000000000000..bc8e062cf7b4
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.5-moc-qt4.patch
@@ -0,0 +1,13 @@
+--- a/macros/qt4.m4 2009-03-02 16:29:42.000000000 +0100
++++ b/macros/qt4.m4 2009-09-08 14:53:31.355928666 +0200
+@@ -165,8 +165,8 @@
+ has_qt4="no"
+ fi
+
+- AC_PATH_PROG(MOC4, moc-qt4, ,[${QTDIR}/bin /usr/lib/qt4/bin /usr/share/qt4/bin/ ${pathlist}])
+- AC_PATH_PROG(UIC4, uic-qt4, ,[${QTDIR}/bin /usr/lib/qt4/bin /usr/share/qt4/bin/ ${pathlist}])
++ AC_PATH_PROGS(MOC4, [moc-qt4 moc], ,[/usr/bin ${QTDIR}/bin /usr/lib/qt4/bin /usr/share/qt4/bin/ ${pathlist}])
++ AC_PATH_PROGS(UIC4, [uic-qt4 uic], ,[/usr/bin ${QTDIR}/bin /usr/lib/qt4/bin /usr/share/qt4/bin/ ${pathlist}])
+
+
+ AC_SUBST([QT4_CFLAGS])
diff --git a/www-plugins/gnash/gnash-0.8.5.ebuild b/www-plugins/gnash/gnash-0.8.5.ebuild
index 02da49d6c750..2b73d87ea1f7 100644
--- a/www-plugins/gnash/gnash-0.8.5.ebuild
+++ b/www-plugins/gnash/gnash-0.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.2 2009/09/06 14:55:35 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.5.ebuild,v 1.3 2009/09/08 21:20:23 mrpouet Exp $
EAPI="2"
KDE_REQUIRED="optional"
@@ -98,6 +98,16 @@ src_prepare() {
# Defines $(XPIDL) correctly using sdkdir variable from libxul.pc
epatch "${FILESDIR}"/${P}-xpidl-sdkdir.patch
+ # Resurect patch from bug #230287
+ epatch "${FILESDIR}"/${PN}-0.8.3-boost-dynamic-link.patch
+
+ # Adapted from Alt Linux to fix klash support properly
+ epatch "${FILESDIR}"/${P}-klash.patch
+
+ # Make gnash find moc and uic properly, upstream bug #25758,
+ # gentoo bug #283905
+ epatch "${FILESDIR}"/${P}-moc-qt4.patch
+
# Conflict headers with npapi.h from mozilla-sdk embedded stuffs and libxul-unstable header
# in case where xpcom (implicitly added with gtk) is enabled, we use the system header
if use gtk; then
@@ -115,12 +125,10 @@ src_configure() {
# Set kde and konqueror plugin directories.
if use kde; then
myconf="${myconf}
- --with-qt4-incl=/usr/include/qt4
- --with-qt4-lib=/usr/$(get_libdir)/qt4
--with-kde4-incl=${KDEDIR}/include
--with-kde4-configdir=${KDEDIR}/share/config
--with-kde4-prefix=${KDEDIR}
- --with-kde4-lib=${KDEDIR}/$(get_libdir)/kde4
+ --with-kde4-lib=${KDEDIR}/$(get_libdir)
--with-kde-appsdatadir=${KDEDIR}/share/apps/klash
--with-kde4-servicesdir=${KDEDIR}/share/services"
fi
@@ -177,8 +185,9 @@ src_install() {
# Install kde konqueror plugin.
if use kde; then
- cd "${S}/plugin/klash4"
+ pushd "${S}/plugin/klash4" >& /dev/null
emake DESTDIR="${D}" install-plugin || die "install kde plugins failed"
+ popd >& /dev/null
fi
# Create a symlink in /usr/$(get_libdir)/nsbrowser/plugins to the nsplugin install directory.
use nsplugin && inst_plugin /opt/netscape/plugins/libgnashplugin.so \