summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-08-16 12:56:26 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-08-16 12:56:26 +0000
commitbdb0f2acb05f7fa1942d1144eabb023390fb4150 (patch)
treec644798ff1285e12bde99ca196d9ffb3d3f76cf9 /www-plugins
parentversion bump and clean up (diff)
downloadgentoo-2-bdb0f2acb05f7fa1942d1144eabb023390fb4150.tar.gz
gentoo-2-bdb0f2acb05f7fa1942d1144eabb023390fb4150.tar.bz2
gentoo-2-bdb0f2acb05f7fa1942d1144eabb023390fb4150.zip
Add tslib dependency that was previously automagic. warn user against multiple boost versions, bug #366407.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/gnash/ChangeLog7
-rw-r--r--www-plugins/gnash/gnash-0.8.9.ebuild11
2 files changed, 16 insertions, 2 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index 50cf34a7df9a..7ea3d8a34637 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.65 2011/07/19 17:31:38 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.66 2011/08/16 12:56:26 chithanh Exp $
+
+ 16 Aug 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ gnash-0.8.9.ebuild:
+ Add tslib dependency that was previously automagic. warn user against
+ multiple boost versions, bug #366407.
19 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #266794
diff --git a/www-plugins/gnash/gnash-0.8.9.ebuild b/www-plugins/gnash/gnash-0.8.9.ebuild
index 117c9394095a..790fe496d332 100644
--- a/www-plugins/gnash/gnash-0.8.9.ebuild
+++ b/www-plugins/gnash/gnash-0.8.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.9.ebuild,v 1.7 2011/07/02 21:09:02 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.9.ebuild,v 1.8 2011/08/16 12:56:26 chithanh Exp $
EAPI=3
CMAKE_REQUIRED="never"
@@ -45,6 +45,9 @@ RDEPEND=">=dev-libs/boost-1.41.0
>=app-text/docbook2X-0.8.8
app-text/docbook-sgml-utils
)
+ fbcon? (
+ x11-libs/tslib
+ )
ffmpeg? (
virtual/ffmpeg[vaapi?]
)
@@ -88,6 +91,12 @@ DEPEND="${RDEPEND}
RESTRICT="test"
pkg_setup() {
+ if has_version ">=dev-libs/boost-1.46" && has_version "<dev-libs/boost-1.46"; then
+ ewarn "If you have multiple versions of boost installed, gnash may attempt to"
+ ewarn "compile against the older version and link against newer version, which can"
+ ewarn "cause the build to fail. Unmerge of the old version of boost is recommended."
+ fi
+
if use !ffmpeg && use !gstreamer; then
ewarn "You are trying to build Gnash without choosing a media handler."
ewarn "Sound and video playback will not work."