summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2012-12-29 04:39:39 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2012-12-29 04:39:39 +0000
commit07b144250a88af080500c59c946f85ebe84fa99a (patch)
tree98e07956035d8fc158e1161bb5ca5f38efcc629a /www-servers/gunicorn
parentRequire a recent libmicrohttpd version #449082 by Ben Kohler. (diff)
downloadgentoo-2-07b144250a88af080500c59c946f85ebe84fa99a.tar.gz
gentoo-2-07b144250a88af080500c59c946f85ebe84fa99a.tar.bz2
gentoo-2-07b144250a88af080500c59c946f85ebe84fa99a.zip
Version bump.
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/ChangeLog8
-rw-r--r--www-servers/gunicorn/gunicorn-0.17.0.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
index dea91c996e3e..16d50fef78ac 100644
--- a/www-servers/gunicorn/ChangeLog
+++ b/www-servers/gunicorn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/gunicorn
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.25 2012/11/27 13:04:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.26 2012/12/29 04:39:39 rafaelmartins Exp $
+
+*gunicorn-0.17.0 (29 Dec 2012)
+
+ 29 Dec 2012; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +gunicorn-0.17.0.ebuild:
+ Version bump.
27 Nov 2012; Agostino Sarubbo <ago@gentoo.org> gunicorn-0.15.0.ebuild:
Stable for x86, wrt bug #422243
diff --git a/www-servers/gunicorn/gunicorn-0.17.0.ebuild b/www-servers/gunicorn/gunicorn-0.17.0.ebuild
new file mode 100644
index 000000000000..7cb462d78025
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-0.17.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.17.0.ebuild,v 1.1 2012/12/29 04:39:39 rafaelmartins Exp $
+
+EAPI="5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.5 3.1 *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest )"
+
+DOCS="README.rst"
+
+src_prepare() {
+ # these tests requires an already installed version of gunicorn
+ rm tests/test_003-config.py
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ sphinx-build -b html source build || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml -r docs/build/
+}