summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-11-10 05:56:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-11-10 05:56:33 +0000
commit58d930c87d37ca79873aa03a92a1d5157b891429 (patch)
tree2699b956bd994632cedc0b4b7d7724b73ee073d2 /www-servers/gunicorn
parentmore deps for openstack (diff)
downloadgentoo-2-58d930c87d37ca79873aa03a92a1d5157b891429.tar.gz
gentoo-2-58d930c87d37ca79873aa03a92a1d5157b891429.tar.bz2
gentoo-2-58d930c87d37ca79873aa03a92a1d5157b891429.zip
Bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/ChangeLog7
-rw-r--r--www-servers/gunicorn/gunicorn-19.1.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/www-servers/gunicorn/ChangeLog b/www-servers/gunicorn/ChangeLog
index c5dddf4ec4f4..a1de0a01e372 100644
--- a/www-servers/gunicorn/ChangeLog
+++ b/www-servers/gunicorn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/gunicorn
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.36 2014/07/22 04:26:43 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/ChangeLog,v 1.37 2014/11/10 05:56:33 patrick Exp $
+
+*gunicorn-19.1.1 (10 Nov 2014)
+
+ 10 Nov 2014; Patrick Lauer <patrick@gentoo.org> +gunicorn-19.1.1.ebuild:
+ Bump
*gunicorn-19.0.0 (22 Jul 2014)
diff --git a/www-servers/gunicorn/gunicorn-19.1.1.ebuild b/www-servers/gunicorn/gunicorn-19.1.1.ebuild
new file mode 100644
index 000000000000..7efbbf70217f
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-19.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-19.1.1.ebuild,v 1.1 2014/11/10 05:56:33 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_3,3_4} pypy pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc examples test"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/setproctitle"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS="README.rst"
+
+python_prepare() {
+ # these tests requires an already installed version of gunicorn
+ rm tests/test_003-config.py
+
+ sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
+
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples
+ fi
+}