summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-07-01 16:28:33 +0000
committerPacho Ramos <pacho@gentoo.org>2014-07-01 16:28:33 +0000
commit5cd7eedb1f92d4fc22cb17075c23e5f85fc6081e (patch)
tree10266377185d2b652bbbfea9da01f9605283fec8 /www-servers/hiawatha
parentAutomated update. (diff)
downloadgentoo-2-5cd7eedb1f92d4fc22cb17075c23e5f85fc6081e.tar.gz
gentoo-2-5cd7eedb1f92d4fc22cb17075c23e5f85fc6081e.tar.bz2
gentoo-2-5cd7eedb1f92d4fc22cb17075c23e5f85fc6081e.zip
Add unit file (#515568 by Tim Mohlmann)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'www-servers/hiawatha')
-rw-r--r--www-servers/hiawatha/ChangeLog8
-rw-r--r--www-servers/hiawatha/files/hiawatha.service9
-rw-r--r--www-servers/hiawatha/hiawatha-9.6-r1.ebuild92
3 files changed, 108 insertions, 1 deletions
diff --git a/www-servers/hiawatha/ChangeLog b/www-servers/hiawatha/ChangeLog
index cb9a9ee53c58..68ff82b88468 100644
--- a/www-servers/hiawatha/ChangeLog
+++ b/www-servers/hiawatha/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/hiawatha
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/hiawatha/ChangeLog,v 1.4 2014/06/21 10:26:59 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/hiawatha/ChangeLog,v 1.5 2014/07/01 16:28:33 pacho Exp $
+
+*hiawatha-9.6-r1 (01 Jul 2014)
+
+ 01 Jul 2014; Pacho Ramos <pacho@gentoo.org> +files/hiawatha.service,
+ +hiawatha-9.6-r1.ebuild:
+ Add unit file (#515568 by Tim Mohlmann)
*hiawatha-9.6 (21 Jun 2014)
diff --git a/www-servers/hiawatha/files/hiawatha.service b/www-servers/hiawatha/files/hiawatha.service
new file mode 100644
index 000000000000..35e740b7e390
--- /dev/null
+++ b/www-servers/hiawatha/files/hiawatha.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Hiawatha webserver
+After=network.target
+
+[Service]
+ExecStart=/usr/sbin/hiawatha -d
+
+[Install]
+WantedBy=multi-user.target
diff --git a/www-servers/hiawatha/hiawatha-9.6-r1.ebuild b/www-servers/hiawatha/hiawatha-9.6-r1.ebuild
new file mode 100644
index 000000000000..652f34f78c57
--- /dev/null
+++ b/www-servers/hiawatha/hiawatha-9.6-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/hiawatha/hiawatha-9.6-r1.ebuild,v 1.1 2014/07/01 16:28:33 pacho Exp $
+
+# ssl USE flag currently broken
+# https://github.com/hsleisink/hiawatha/issues/15
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.4"
+CMAKE_BUILD_TYPE="RelWithDebInfo"
+
+inherit cmake-utils systemd user
+
+DESCRIPTION="Advanced and secure webserver"
+HOMEPAGE="http://www.hiawatha-webserver.org"
+SRC_URI="http://www.hiawatha-webserver.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +cache ipv6 monitor +rewrite rproxy tomahawk +xslt"
+
+RDEPEND="
+ >=net-libs/polarssl-1.3
+ xslt? ( dev-libs/libxslt
+ dev-libs/libxml2 )"
+DEPEND="${RDEPEND}"
+PDEPEND="monitor? ( www-apps/hiawatha-monitor )"
+
+# set this in make.conf if you want to use a different user/group
+HIAWATHA_USER=${HIAWATHA_USER:-hiawatha}
+HIAWATHA_GROUP=${HIAWATHA_GROUP:-hiawatha}
+
+pkg_setup() {
+ enewgroup ${HIAWATHA_GROUP}
+ enewuser ${HIAWATHA_USER} -1 -1 /var/www/hiawatha ${HIAWATHA_GROUP}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-9.5-cflags.patch
+
+ rm -r polarssl || die
+
+ grep '#ServerId =' config/hiawatha.conf.in 1>/dev/null || die
+ sed -i \
+ -e "s/#ServerId =.*$/ServerId = ${HIAWATHA_USER}/" \
+ config/hiawatha.conf.in || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DIR:STRING=/etc/hiawatha
+ $(cmake-utils_use_enable cache CACHE)
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_enable ipv6 IPV6)
+ $(cmake-utils_use_enable kernel_linux LOADCHECK)
+ $(cmake-utils_use_enable monitor MONITOR)
+ $(cmake-utils_use_enable rproxy RPROXY)
+ -DENABLE_SSL=YES
+ $(cmake-utils_use_enable tomahawk TOMAHAWK)
+ $(cmake-utils_use_enable rewrite TOOLKIT)
+ $(cmake-utils_use_enable xslt XSLT)
+ -DLOG_DIR:STRING=/var/log/hiawatha
+ -DPID_DIR:STRING=/var/run
+ -DUSE_SHARED_POLARSSL_LIBRARY=ON
+ -DUSE_SYSTEM_POLARSSL=ON
+ -DWEBROOT_DIR:STRING=/var/www/hiawatha
+ -DWORK_DIR:STRING=/var/lib/hiawatha
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ rm -rf "${ED%%/}"/var/www/hiawatha/*
+
+ newinitd "${FILESDIR}"/hiawatha.initd hiawatha
+ systemd_dounit "${FILESDIR}"/hiawatha.service
+
+ local i
+ for i in /var/{lib,log}/hiawatha ; do
+ keepdir ${i}
+ fowners ${HIAWATHA_USER}:${HIAWATHA_GROUP} ${i}
+ fperms 0750 ${i}
+ done
+
+ keepdir /var/www/hiawatha
+ fowners ${HIAWATHA_USER}:${HIAWATHA_GROUP} /var/www/hiawatha
+}