summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-11-30 14:40:44 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-11-30 14:40:44 +0000
commitb463ee31b9aa06195aef770923d33b3aeaeb2c8b (patch)
tree0f26385e126631f5462e16974756629fbe1b1456 /www-servers/nginx
parentRemove dhcpcd from mask (diff)
downloadgentoo-2-b463ee31b9aa06195aef770923d33b3aeaeb2c8b.tar.gz
gentoo-2-b463ee31b9aa06195aef770923d33b3aeaeb2c8b.tar.bz2
gentoo-2-b463ee31b9aa06195aef770923d33b3aeaeb2c8b.zip
* bump
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog8
-rw-r--r--www-servers/nginx/files/digest-nginx-0.4.143
-rw-r--r--www-servers/nginx/nginx-0.4.14.ebuild79
3 files changed, 89 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 1279fdcbd596..5c9b4fbf41a4 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.119 2006/11/15 20:23:29 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.120 2006/11/30 14:40:44 voxus Exp $
+
+*nginx-0.4.14 (30 Nov 2006)
+
+ 30 Nov 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.4.13.ebuild, +nginx-0.4.14.ebuild:
+ Version bump.
*nginx-0.4.13 (15 Nov 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.4.14 b/www-servers/nginx/files/digest-nginx-0.4.14
new file mode 100644
index 000000000000..8db0b9b8e1e4
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.4.14
@@ -0,0 +1,3 @@
+MD5 2a681881f8f899609fb0771d07266236 nginx-0.4.14.tar.gz 440675
+RMD160 b46047cb5b39f7d8ac777f97f5e299231592f280 nginx-0.4.14.tar.gz 440675
+SHA256 de916da2e01835cafe6fc90457ca14bcd065814b0f920d783aeb57efbbe4539e nginx-0.4.14.tar.gz 440675
diff --git a/www-servers/nginx/nginx-0.4.14.ebuild b/www-servers/nginx/nginx-0.4.14.ebuild
new file mode 100644
index 000000000000..b92fbf424c00
--- /dev/null
+++ b/www-servers/nginx/nginx-0.4.14.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.4.14.ebuild,v 1.1 2006/11/30 14:40:44 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}