summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-01-03 20:58:11 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-01-03 20:58:11 +0000
commitcf626bd47878a7be9a66b6f42ee80c8b36026e49 (patch)
tree09c17759c660a20a90e7edb501c4b6b60a5efe54 /www-servers/nginx
parentTransfer Prefix keywords (diff)
downloadgentoo-2-cf626bd47878a7be9a66b6f42ee80c8b36026e49.tar.gz
gentoo-2-cf626bd47878a7be9a66b6f42ee80c8b36026e49.tar.bz2
gentoo-2-cf626bd47878a7be9a66b6f42ee80c8b36026e49.zip
Clean up an obsolete revision.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog5
-rw-r--r--www-servers/nginx/nginx-0.7.64-r2.ebuild117
2 files changed, 4 insertions, 118 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index f82371f49197..0898da004f97 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.240 2010/01/03 20:56:46 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.241 2010/01/03 20:58:11 djc Exp $
+
+ 03 Jan 2010; Dirkjan Ochtman <djc@gentoo.org> -nginx-0.7.64-r2.ebuild:
+ Remove superseded 0.7.64-r2.
*nginx-0.8.31 (03 Jan 2010)
diff --git a/www-servers/nginx/nginx-0.7.64-r2.ebuild b/www-servers/nginx/nginx-0.7.64-r2.ebuild
deleted file mode 100644
index d14448c71ae3..000000000000
--- a/www-servers/nginx/nginx-0.7.64-r2.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.7.64-r2.ebuild,v 1.1 2010/01/03 19:51:40 djc Exp $
-
-inherit eutils ssl-cert toolchain-funcs perl-module
-
-DESCRIPTION="Robust, small and high performance http and reverse proxy server"
-
-HOMEPAGE="http://nginx.net/"
-SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-IUSE="addition debug fastcgi flv imap pcre perl pop random-index smtp ssl static-gzip status sub webdav zlib"
-
-DEPEND="dev-lang/perl
- dev-libs/openssl
- pcre? ( >=dev-libs/libpcre-4.2 )
- zlib? ( sys-libs/zlib )
- perl? ( >=dev-lang/perl-5.8 )"
-
-pkg_setup() {
- ebegin "Creating nginx user and group"
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
- eend ${?}
-}
-
-src_unpack() {
- unpack ${A}
- sed -i 's/ make/ \\$(MAKE)/' "${S}"/auto/lib/perl/make || die
-}
-
-src_compile() {
- local myconf
-
- # threads support is broken atm.
- #
- # if use threads; then
- # einfo
- # ewarn "threads support is experimental at the moment"
- # ewarn "do not use it on production systems - you've been warned"
- # einfo
- # myconf="${myconf} --with-threads"
- # fi
-
- use addition && myconf="${myconf} --with-http_addition_module"
- use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
- use fastcgi && myconf="${myconf} --with-http_realip_module"
- use flv && myconf="${myconf} --with-http_flv_module"
- use zlib || myconf="${myconf} --without-http_gzip_module"
- use pcre || {
- myconf="${myconf} --without-pcre --without-http_rewrite_module"
- }
- use debug && myconf="${myconf} --with-debug"
- use ssl && myconf="${myconf} --with-http_ssl_module"
- use perl && myconf="${myconf} --with-http_perl_module"
- use status && myconf="${myconf} --with-http_stub_status_module"
- use webdav && myconf="${myconf} --with-http_dav_module"
- use sub && myconf="${myconf} --with-http_sub_module"
- use static-gzip && myconf="${myconf} --with-http_gzip_static_module"
- use random-index && myconf="${myconf} --with-http_random_index_module"
-
- if use smtp || use pop || use imap; then
- myconf="${myconf} --with-mail"
- use ssl && myconf="${myconf} --with-mail_ssl_module"
- fi
- use imap || myconf="${myconf} --without-mail_imap_module"
- use pop || myconf="${myconf} --without-mail_pop3_module"
- use smtp || myconf="${myconf} --without-mail_smtp_module"
-
- tc-export CC
- ./configure \
- --prefix=/usr \
- --with-cc-opt="-I${ROOT}/usr/include" \
- --with-ld-opt="-L${ROOT}/usr/lib" \
- --conf-path=/etc/${PN}/${PN}.conf \
- --http-log-path=/var/log/${PN}/access_log \
- --error-log-path=/var/log/${PN}/error_log \
- --pid-path=/var/run/${PN}.pid \
- --http-client-body-temp-path=/var/tmp/${PN}/client \
- --http-proxy-temp-path=/var/tmp/${PN}/proxy \
- --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
- ${myconf} || die "configure failed"
-
- emake LINK="${CC} ${LDFLAGS}" OTHERLDFLAGS="${LDFLAGS}" || die "failed to compile"
-}
-
-src_install() {
- keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
-
- dosbin objs/nginx
- newinitd "${FILESDIR}"/nginx.init-r2 nginx || die
-
- cp "${FILESDIR}"/nginx.conf-r4 conf/nginx.conf
-
- dodir /etc/${PN}
- insinto /etc/${PN}
- doins conf/*
-
- dodoc CHANGES{,.ru} README
-
- use perl && {
- cd "${S}"/objs/src/http/modules/perl/
- einstall DESTDIR="${D}" INSTALLDIRS=vendor || die "failed to install perl stuff"
- fixlocalpod
- }
-}
-
-pkg_postinst() {
- use ssl && {
- if [ ! -f "${ROOT}"/etc/ssl/${PN}/${PN}.key ]; then
- install_cert /etc/ssl/${PN}/${PN}
- chown ${PN}:${PN} "${ROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
- fi
- }
-}