summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-16 08:15:47 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-16 08:15:47 +0000
commit75359054cbf7fe99e4f418df92c3743caa949631 (patch)
treeb0369c8d90fe5bd3ffecc3b459c3580896de9bc6 /www-servers/pathod/pathod-0.9.ebuild
parentInitial import. (diff)
downloadgentoo-2-75359054cbf7fe99e4f418df92c3743caa949631.tar.gz
gentoo-2-75359054cbf7fe99e4f418df92c3743caa949631.tar.bz2
gentoo-2-75359054cbf7fe99e4f418df92c3743caa949631.zip
Initial import.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-servers/pathod/pathod-0.9.ebuild')
-rw-r--r--www-servers/pathod/pathod-0.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/www-servers/pathod/pathod-0.9.ebuild b/www-servers/pathod/pathod-0.9.ebuild
new file mode 100644
index 000000000000..43d0c25db10a
--- /dev/null
+++ b/www-servers/pathod/pathod-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pathod/pathod-0.9.ebuild,v 1.1 2013/05/16 08:15:47 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of pathological tools for testing and torturing HTTP clients and servers"
+HOMEPAGE="https://github.com/cortesi/pathod/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/netlib-0.9[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.1.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RESTRICT="test"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}