summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-26 05:58:10 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-26 05:58:10 +0000
commit61130ce839dc4c464b1c803a7349a8447f818e8f (patch)
tree3d4b59cfce05cc7cd15761aea7935c17d3b5737e /www-servers/thin
parentUse tarballs instead of pulling from git (diff)
downloadgentoo-2-61130ce839dc4c464b1c803a7349a8447f818e8f.tar.gz
gentoo-2-61130ce839dc4c464b1c803a7349a8447f818e8f.tar.bz2
gentoo-2-61130ce839dc4c464b1c803a7349a8447f818e8f.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'www-servers/thin')
-rw-r--r--www-servers/thin/ChangeLog9
-rw-r--r--www-servers/thin/thin-1.5.1.ebuild81
2 files changed, 88 insertions, 2 deletions
diff --git a/www-servers/thin/ChangeLog b/www-servers/thin/ChangeLog
index 223d1e988274..e125bf36b5cc 100644
--- a/www-servers/thin/ChangeLog
+++ b/www-servers/thin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/thin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/ChangeLog,v 1.20 2012/06/12 05:49:12 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/ChangeLog,v 1.21 2013/04/26 05:58:10 graaff Exp $
+
+*thin-1.5.1 (26 Apr 2013)
+
+ 26 Apr 2013; Hans de Graaff <graaff@gentoo.org> +thin-1.5.1.ebuild:
+ Version bump.
12 Jun 2012; Hans de Graaff <graaff@gentoo.org> thin-1.3.1.ebuild:
Add ruby19.
diff --git a/www-servers/thin/thin-1.5.1.ebuild b/www-servers/thin/thin-1.5.1.ebuild
new file mode 100644
index 000000000000..795f67a64570
--- /dev/null
+++ b/www-servers/thin/thin-1.5.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/thin-1.5.1.ebuild,v 1.1 2013/04/26 05:58:10 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast and very simple Ruby web server"
+HOMEPAGE="http://code.macournoyer.com/thin/"
+SRC_URI="https://github.com/macournoyer/thin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${DEPEND}
+ dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+# The runtime dependencies are used at build-time as well since the
+# Rakefile loads thin!
+mydeps=">=dev-ruby/daemons-1.0.9
+ >=dev-ruby/rack-1.0.0
+ >=dev-ruby/eventmachine-0.12.6
+ virtual/ruby-ssl"
+
+ruby_add_rdepend "${mydeps}"
+ruby_add_bdepend "${mydeps}
+ dev-ruby/rake-compiler
+ test? ( dev-ruby/rspec:0 )"
+
+all_ruby_prepare() {
+ # Fix Ragel-based parser generation (uses a *very* old syntax that
+ # is not supported in Gentoo)
+ sed -i -e 's: | rlgen-cd::' Rakefile || die
+
+ # Fix specs' dependencies so that the extension is not rebuilt
+ # when running tests
+ sed -i -e '/:spec =>/s:^:#:' tasks/spec.rake || die
+
+ # Fix rspec version to allow newer 1.x versions
+ sed -i -e '/gem "rspec"/ s/1.2.9/1.0/' tasks/spec.rake spec/spec_helper.rb || die
+
+ # Avoid CLEAN since it may not be available and we don't need it.
+ sed -i -e '/CLEAN/ s:^:#:' tasks/*.rake || die
+
+ # Disable a test that is known for freezing the testsuite,
+ # reported upstream. In thin 1.5.1 this just fails.
+ sed -i \
+ -e '/should force kill process in pid file/,/^ end/ s:^:#:' \
+ spec/daemonizing_spec.rb || die
+
+ # nasty but too complex to fix up for now :(
+ use test || rm tasks/spec.rake
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "rake compile failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ keepdir /etc/thin
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ einfo
+ elog "Thin is now shipped with init scripts."
+ elog "The default script (/etc/init.d/thin) will start all servers that have"
+ elog "configuration files in /etc/thin/. You can symlink the init script to"
+ elog "files of the format 'thin.SERVER' to be able to start individual servers."
+ elog "See /etc/conf.d/thin for more configuration options."
+ einfo
+}