summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-16 10:07:25 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-16 10:07:25 +0000
commite97c9d3d0a5f963425db00a61521913082388b44 (patch)
tree30e9d419c342daa9c2aac8f825ceb8ca48651c32 /www-servers/thin
parentVersion bump. (diff)
downloadgentoo-2-e97c9d3d0a5f963425db00a61521913082388b44.tar.gz
gentoo-2-e97c9d3d0a5f963425db00a61521913082388b44.tar.bz2
gentoo-2-e97c9d3d0a5f963425db00a61521913082388b44.zip
Cleanup.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'www-servers/thin')
-rw-r--r--www-servers/thin/ChangeLog6
-rw-r--r--www-servers/thin/thin-1.2.11.ebuild78
-rw-r--r--www-servers/thin/thin-1.3.1.ebuild81
-rw-r--r--www-servers/thin/thin-1.5.1.ebuild81
4 files changed, 5 insertions, 241 deletions
diff --git a/www-servers/thin/ChangeLog b/www-servers/thin/ChangeLog
index 8540aedff6ce..d951863a0046 100644
--- a/www-servers/thin/ChangeLog
+++ b/www-servers/thin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/thin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/ChangeLog,v 1.22 2013/06/27 18:29:01 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/ChangeLog,v 1.23 2013/07/16 10:07:25 graaff Exp $
+
+ 16 Jul 2013; Hans de Graaff <graaff@gentoo.org> -thin-1.2.11.ebuild,
+ -thin-1.3.1.ebuild, -thin-1.5.1.ebuild:
+ Cleanup.
*thin-1.5.1-r1 (27 Jun 2013)
diff --git a/www-servers/thin/thin-1.2.11.ebuild b/www-servers/thin/thin-1.2.11.ebuild
deleted file mode 100644
index 89d123cf2952..000000000000
--- a/www-servers/thin/thin-1.2.11.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/thin-1.2.11.ebuild,v 1.1 2011/06/12 17:13:51 a3li Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A fast and very simple Ruby web server"
-HOMEPAGE="http://code.macournoyer.com/thin/"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="${DEPEND}
- dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-# The runtime dependencies are used at build-time as well since the
-# Rakefile loads thin!
-mydeps=">=dev-ruby/daemons-1.0.9
- >=dev-ruby/rack-1.0.0
- >=dev-ruby/eventmachine-0.12.6
- virtual/ruby-ssl"
-
-ruby_add_rdepend "${mydeps}"
-ruby_add_bdepend "${mydeps}
- dev-ruby/rake-compiler
- test? ( dev-ruby/rspec:0 )"
-
-all_ruby_prepare() {
- # Fix Ragel-based parser generation (uses a *very* old syntax that
- # is not supported in Gentoo)
- sed -i -e 's: | rlgen-cd::' Rakefile || die
-
- # Fix specs' dependencies so that the extension is not rebuilt
- # when running tests
- sed -i -e '/:spec =>/s:^:#:' tasks/spec.rake || die
-
- # Fix rspec version to allow newer 1.x versions
- sed -i -e '/gem "rspec"/ s/1.2.9/1.0/' tasks/spec.rake || die
-
- # Disable a test that is known for freezing the testsuite,
- # reported upstream.
- sed -i \
- -e '/should force kill process in pid file/,/^ end/ s:^:#:' \
- spec/daemonizing_spec.rb || die
- rm spec/server/robustness_spec.rb || die
-
- # nasty but too complex to fix up for now :(
- use test || rm tasks/spec.rake
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake compile || die "rake compile failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- keepdir /etc/thin
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-
- einfo
- elog "Thin is now shipped with init scripts."
- elog "The default script (/etc/init.d/thin) will start all servers that have"
- elog "configuration files in /etc/thin/. You can symlink the init script to"
- elog "files of the format 'thin.SERVER' to be able to start individual servers."
- elog "See /etc/conf.d/thin for more configuration options."
- einfo
-}
diff --git a/www-servers/thin/thin-1.3.1.ebuild b/www-servers/thin/thin-1.3.1.ebuild
deleted file mode 100644
index 7a860d0b5b80..000000000000
--- a/www-servers/thin/thin-1.3.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/thin-1.3.1.ebuild,v 1.2 2012/06/12 05:49:12 graaff Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A fast and very simple Ruby web server"
-HOMEPAGE="http://code.macournoyer.com/thin/"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="${DEPEND}
- dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-# The runtime dependencies are used at build-time as well since the
-# Rakefile loads thin!
-mydeps=">=dev-ruby/daemons-1.0.9
- >=dev-ruby/rack-1.0.0
- >=dev-ruby/eventmachine-0.12.6
- virtual/ruby-ssl"
-
-ruby_add_rdepend "${mydeps}"
-ruby_add_bdepend "${mydeps}
- dev-ruby/rake-compiler
- test? ( dev-ruby/rspec:0 )"
-
-all_ruby_prepare() {
- # Fix Ragel-based parser generation (uses a *very* old syntax that
- # is not supported in Gentoo)
- sed -i -e 's: | rlgen-cd::' Rakefile || die
-
- # Fix specs' dependencies so that the extension is not rebuilt
- # when running tests
- sed -i -e '/:spec =>/s:^:#:' tasks/spec.rake || die
-
- # Fix rspec version to allow newer 1.x versions
- sed -i -e '/gem "rspec"/ s/1.2.9/1.0/' tasks/spec.rake spec/spec_helper.rb || die
-
- # Disable a test that is known for freezing the testsuite,
- # reported upstream.
- sed -i \
- -e '/should force kill process in pid file/,/^ end/ s:^:#:' \
- spec/daemonizing_spec.rb || die
-
- # Pipelining specs don't work. Avoid them for now since this is not
- # a regression. https://github.com/macournoyer/thin/issues/40
- rm spec/server/pipelining_spec.rb || die
-
- # nasty but too complex to fix up for now :(
- use test || rm tasks/spec.rake
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake compile || die "rake compile failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- keepdir /etc/thin
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-
- einfo
- elog "Thin is now shipped with init scripts."
- elog "The default script (/etc/init.d/thin) will start all servers that have"
- elog "configuration files in /etc/thin/. You can symlink the init script to"
- elog "files of the format 'thin.SERVER' to be able to start individual servers."
- elog "See /etc/conf.d/thin for more configuration options."
- einfo
-}
diff --git a/www-servers/thin/thin-1.5.1.ebuild b/www-servers/thin/thin-1.5.1.ebuild
deleted file mode 100644
index 795f67a64570..000000000000
--- a/www-servers/thin/thin-1.5.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/thin/thin-1.5.1.ebuild,v 1.1 2013/04/26 05:58:10 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A fast and very simple Ruby web server"
-HOMEPAGE="http://code.macournoyer.com/thin/"
-SRC_URI="https://github.com/macournoyer/thin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-DEPEND="${DEPEND}
- dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-# The runtime dependencies are used at build-time as well since the
-# Rakefile loads thin!
-mydeps=">=dev-ruby/daemons-1.0.9
- >=dev-ruby/rack-1.0.0
- >=dev-ruby/eventmachine-0.12.6
- virtual/ruby-ssl"
-
-ruby_add_rdepend "${mydeps}"
-ruby_add_bdepend "${mydeps}
- dev-ruby/rake-compiler
- test? ( dev-ruby/rspec:0 )"
-
-all_ruby_prepare() {
- # Fix Ragel-based parser generation (uses a *very* old syntax that
- # is not supported in Gentoo)
- sed -i -e 's: | rlgen-cd::' Rakefile || die
-
- # Fix specs' dependencies so that the extension is not rebuilt
- # when running tests
- sed -i -e '/:spec =>/s:^:#:' tasks/spec.rake || die
-
- # Fix rspec version to allow newer 1.x versions
- sed -i -e '/gem "rspec"/ s/1.2.9/1.0/' tasks/spec.rake spec/spec_helper.rb || die
-
- # Avoid CLEAN since it may not be available and we don't need it.
- sed -i -e '/CLEAN/ s:^:#:' tasks/*.rake || die
-
- # Disable a test that is known for freezing the testsuite,
- # reported upstream. In thin 1.5.1 this just fails.
- sed -i \
- -e '/should force kill process in pid file/,/^ end/ s:^:#:' \
- spec/daemonizing_spec.rb || die
-
- # nasty but too complex to fix up for now :(
- use test || rm tasks/spec.rake
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake compile || die "rake compile failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- keepdir /etc/thin
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- newconfd "${FILESDIR}"/${PN}.confd ${PN}
-
- einfo
- elog "Thin is now shipped with init scripts."
- elog "The default script (/etc/init.d/thin) will start all servers that have"
- elog "configuration files in /etc/thin/. You can symlink the init script to"
- elog "files of the format 'thin.SERVER' to be able to start individual servers."
- elog "See /etc/conf.d/thin for more configuration options."
- einfo
-}