summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-11-22 20:54:53 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-11-22 20:54:53 +0000
commit222f41dd69d676592b2fa6c28a1b0e303e4e7ed2 (patch)
treeb0131de23bf761d2b37e43cc8a559f09e1f3b62a /www-servers/varnish
parentFix failed gpg signing of manifest (diff)
downloadgentoo-2-222f41dd69d676592b2fa6c28a1b0e303e4e7ed2.tar.gz
gentoo-2-222f41dd69d676592b2fa6c28a1b0e303e4e7ed2.tar.bz2
gentoo-2-222f41dd69d676592b2fa6c28a1b0e303e4e7ed2.zip
Fix build on uclibc, bug #444294
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/ChangeLog7
-rw-r--r--www-servers/varnish/files/varnish-3.0.3-pthread-uclibc.patch35
-rw-r--r--www-servers/varnish/varnish-3.0.3.ebuild7
3 files changed, 45 insertions, 4 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index ab9f276915bb..389c13ea6cf3 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/varnish
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.52 2012/08/23 20:59:46 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.53 2012/11/22 20:54:53 blueness Exp $
+
+ 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org>
+ +files/varnish-3.0.3-pthread-uclibc.patch, varnish-3.0.3.ebuild:
+ Fix build on uclibc, bug #444294
*varnish-3.0.3 (23 Aug 2012)
@@ -234,4 +238,3 @@
19 Oct 2006; Thilo Bangert <bangert@gentoo.org> +files/varnishd.confd,
+files/varnishd.initd, +metadata.xml, +varnish-1.0.1.ebuild:
varnish - Varnish is an HTTP accelerator. aka a better squid
-
diff --git a/www-servers/varnish/files/varnish-3.0.3-pthread-uclibc.patch b/www-servers/varnish/files/varnish-3.0.3-pthread-uclibc.patch
new file mode 100644
index 000000000000..93f3da3f878e
--- /dev/null
+++ b/www-servers/varnish/files/varnish-3.0.3-pthread-uclibc.patch
@@ -0,0 +1,35 @@
+Refine header check in bin/varnishd/mgt/mgt.h, mgt_main.c for uClibc
+
+Because of the difference in how uClibc and glibc stack their header
+files, stdio.h indirectly brings in PTHREAD_CANCELED from pthread.h
+on a uClibc system, whereas it does not on a glibc system. This happens
+in mgt.h and mgt_main.c. This patch refines the check in those files
+to take this fact into consideration.
+
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/444294
+---
+
+diff --git a/bin/varnishd/mgt.h b/bin/varnishd/mgt.h
+index 905fbcc..5d3ab09 100644
+--- a/bin/varnishd/mgt.h
++++ b/bin/varnishd/mgt.h
+@@ -126,6 +126,6 @@ extern unsigned mgt_vcc_unsafe_path;
+ syslog(pri, fmt, __VA_ARGS__); \
+ } while (0)
+
+-#if defined(PTHREAD_CANCELED) || defined(PTHREAD_MUTEX_DEFAULT)
++#if (defined(PTHREAD_CANCELED) && !defined(__UCLIBC__)) || defined(PTHREAD_MUTEX_DEFAULT)
+ #error "Keep pthreads out of in manager process"
+ #endif
+diff --git a/bin/varnishd/varnishd.c b/bin/varnishd/varnishd.c
+index 1b7f1e3..dce42d9 100644
+--- a/bin/varnishd/varnishd.c
++++ b/bin/varnishd/varnishd.c
+@@ -656,6 +656,6 @@ main(int argc, char * const *argv)
+ exit(exit_status);
+ }
+
+-#if defined(PTHREAD_CANCELED) || defined(PTHREAD_MUTEX_DEFAULT)
++#if (defined(PTHREAD_CANCELED) && !defined(__UCLIBC__)) || defined(PTHREAD_MUTEX_DEFAULT)
+ #error "Keep pthreads out of in manager process"
+ #endif
diff --git a/www-servers/varnish/varnish-3.0.3.ebuild b/www-servers/varnish/varnish-3.0.3.ebuild
index c2e8ac5de738..59861be943fb 100644
--- a/www-servers/varnish/varnish-3.0.3.ebuild
+++ b/www-servers/varnish/varnish-3.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-3.0.3.ebuild,v 1.1 2012/08/23 20:59:46 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-3.0.3.ebuild,v 1.2 2012/11/22 20:54:53 blueness Exp $
EAPI="4"
@@ -29,7 +29,10 @@ RESTRICT="test" #315725
DOCS=( README doc/changes.rst )
-PATCHES=( "${FILESDIR}"/${PN}-3.0.3-automagic.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.3-automagic.patch
+ "${FILESDIR}"/${PN}-3.0.3-pthread-uclibc.patch
+)
src_prepare() {
autotools-utils_src_prepare