summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-16 15:58:37 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-16 15:58:37 +0000
commitd6f7ce42faa1294445b93974939a1c750f73eb9a (patch)
tree09b60981c87182d95b9c3677bd7a877f165a6155 /www-servers/webfs/webfs-1.20.ebuild
parentfixes... (diff)
downloadgentoo-2-d6f7ce42faa1294445b93974939a1c750f73eb9a.tar.gz
gentoo-2-d6f7ce42faa1294445b93974939a1c750f73eb9a.tar.bz2
gentoo-2-d6f7ce42faa1294445b93974939a1c750f73eb9a.zip
Version bump; added threads support via USE=threads. Also added init/conf scripts thanks to Adam Chodorowski in bug 59427.
(Portage version: 2.0.51.16)
Diffstat (limited to 'www-servers/webfs/webfs-1.20.ebuild')
-rw-r--r--www-servers/webfs/webfs-1.20.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/www-servers/webfs/webfs-1.20.ebuild b/www-servers/webfs/webfs-1.20.ebuild
index 0a6d746254b0..c7904ca1bce4 100644
--- a/www-servers/webfs/webfs-1.20.ebuild
+++ b/www-servers/webfs/webfs-1.20.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/webfs-1.20.ebuild,v 1.4 2005/01/23 21:05:58 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/webfs/webfs-1.20.ebuild,v 1.5 2005/02/16 15:58:36 ka0ttic Exp $
-IUSE="ssl"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Lightweight HTTP server for static content"
-SRC_URI="http://bytesex.org/misc/webfs_${PV}.tar.gz"
+SRC_URI="http://dl.bytesex.org/releases/${PN}/${PN}_${PV}.tar.gz"
HOMEPAGE="http://bytesex.org/webfs.html"
-KEYWORDS="x86 sparc alpha ppc ~amd64"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 sparc alpha ppc ~amd64"
+IUSE="ssl"
DEPEND="virtual/libc
ssl? ( dev-libs/openssl )"
@@ -20,16 +18,12 @@ RDEPEND="${DEPEND}
app-misc/mime-types"
src_compile() {
-
- local myconf=""
-
- use ssl \
- || myconf="${myconf} USE_SSL=no"
-
- emake prefix=/usr ${myconf}
+ local myconf
+ use ssl || myconf="${myconf} USE_SSL=no"
+ emake prefix=/usr ${myconf} || die "emake failed"
}
src_install() {
- einstall mandir=${D}/usr/share/man
+ einstall mandir=${D}/usr/share/man || die "make install failed"
dodoc README COPYING
}