summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-24 16:33:40 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-24 16:33:40 +0000
commit0756be6c9033b86d19ae387c315e85d2f3ef07b6 (patch)
tree5b59848b73bbe6e4cdd4808eff6a12c6ac6463ba /www-servers
parentVersion bump. (diff)
downloadgentoo-2-0756be6c9033b86d19ae387c315e85d2f3ef07b6.tar.gz
gentoo-2-0756be6c9033b86d19ae387c315e85d2f3ef07b6.tar.bz2
gentoo-2-0756be6c9033b86d19ae387c315e85d2f3ef07b6.zip
Fix dependencies. Update HOMEPAGE.
(Portage version: 2.2.0_alpha28_p6/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/gunicorn-0.12.1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/www-servers/gunicorn/gunicorn-0.12.1.ebuild b/www-servers/gunicorn/gunicorn-0.12.1.ebuild
index 82d39c060a3c..f4c6ee95ee1e 100644
--- a/www-servers/gunicorn/gunicorn-0.12.1.ebuild
+++ b/www-servers/gunicorn/gunicorn-0.12.1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.12.1.ebuild,v 1.1 2011/03/23 22:50:10 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/gunicorn/gunicorn-0.12.1.ebuild,v 1.2 2011/03/24 16:33:40 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
inherit distutils
DESCRIPTION="A WSGI HTTP Server for UNIX, fast clients and nothing else"
-HOMEPAGE="http://gunicorn.org"
+HOMEPAGE="http://gunicorn.org http://pypi.python.org/pypi/gunicorn"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -20,7 +22,6 @@ RDEPEND="dev-python/setproctitle"
DEPEND="dev-python/setuptools
test? ( dev-python/nose )"
-RESTRICT_PYTHON_ABIS="3.*"
DOCS="README.rst"
src_install() {
@@ -33,8 +34,7 @@ src_install() {
src_test() {
# distutils_src_test doesn't works if gunicorn isn't installed yet
testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" \
- setup.py test || die 'test failed.'
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py test
}
python_execute_function testing
}