summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-11-22 02:26:57 +0000
committerTim Harder <radhermit@gentoo.org>2014-11-22 02:26:57 +0000
commit3e60b5625a088314dcd2d94988504f29b6cc10b5 (patch)
treec40b65ddc384987a9b9f336750e2fe88afe0974f /www-servers
parentgames-board/gambit: 1.0.3 (bug #529616) (diff)
downloadgentoo-2-3e60b5625a088314dcd2d94988504f29b6cc10b5.tar.gz
gentoo-2-3e60b5625a088314dcd2d94988504f29b6cc10b5.tar.bz2
gentoo-2-3e60b5625a088314dcd2d94988504f29b6cc10b5.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pathod/ChangeLog7
-rw-r--r--www-servers/pathod/pathod-0.11.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/www-servers/pathod/ChangeLog b/www-servers/pathod/ChangeLog
index 809aac163e67..f246f2a78c46 100644
--- a/www-servers/pathod/ChangeLog
+++ b/www-servers/pathod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/pathod
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pathod/ChangeLog,v 1.7 2014/10/08 01:11:01 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pathod/ChangeLog,v 1.8 2014/11/22 02:26:57 radhermit Exp $
+
+*pathod-0.11.1 (22 Nov 2014)
+
+ 22 Nov 2014; Tim Harder <radhermit@gentoo.org> +pathod-0.11.1.ebuild:
+ Version bump.
08 Oct 2014; Tim Harder <radhermit@gentoo.org> -pathod-0.9.ebuild,
-pathod-0.9.1.ebuild, -pathod-0.9.2.ebuild,
diff --git a/www-servers/pathod/pathod-0.11.1.ebuild b/www-servers/pathod/pathod-0.11.1.ebuild
new file mode 100644
index 000000000000..784ce207dd40
--- /dev/null
+++ b/www-servers/pathod/pathod-0.11.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pathod/pathod-0.11.1.ebuild,v 1.1 2014/11/22 02:26:57 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of pathological tools for testing and torturing HTTP clients and servers"
+HOMEPAGE="http://pathod.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/netlib-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( >=dev-python/nose-1.3.0[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # remove bundled netlib
+ rm -r netlib || die
+
+ # remove unnecessary pip dep
+ sed -i '/pip/d' setup.py || die
+}
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}