summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-27 07:25:10 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-27 07:25:10 +0000
commit6972c21228167a1fd2c9878a0f1f51caca4fc76a (patch)
treef0c1c6db0be6c69ea3e40e0d8ab25c74001cf549 /www-servers
parentStable for X86, wrt bug #413353 (diff)
downloadgentoo-2-6972c21228167a1fd2c9878a0f1f51caca4fc76a.tar.gz
gentoo-2-6972c21228167a1fd2c9878a0f1f51caca4fc76a.tar.bz2
gentoo-2-6972c21228167a1fd2c9878a0f1f51caca4fc76a.zip
Bump, taking over from Mr. Maintainer-Needed
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/pound/ChangeLog8
-rw-r--r--www-servers/pound/metadata.xml3
-rw-r--r--www-servers/pound/pound-2.6.ebuild56
3 files changed, 65 insertions, 2 deletions
diff --git a/www-servers/pound/ChangeLog b/www-servers/pound/ChangeLog
index bfe609a2dd98..6c70cebd13cb 100644
--- a/www-servers/pound/ChangeLog
+++ b/www-servers/pound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/pound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.48 2012/03/21 11:35:02 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/ChangeLog,v 1.49 2012/04/27 07:25:10 patrick Exp $
+
+*pound-2.6 (27 Apr 2012)
+
+ 27 Apr 2012; Patrick Lauer <patrick@gentoo.org> +pound-2.6.ebuild,
+ metadata.xml:
+ Bump, taking over from Mr. Maintainer-Needed
21 Mar 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop www-server herd as discussed in gentoo-dev ML.
diff --git a/www-servers/pound/metadata.xml b/www-servers/pound/metadata.xml
index 53e967f5e386..f6ffacd46271 100644
--- a/www-servers/pound/metadata.xml
+++ b/www-servers/pound/metadata.xml
@@ -2,7 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
</maintainer>
<longdescription lang="en">The Pound program is a reverse proxy, load balancer
and HTTPS front-end for Web server(s). Pound was developed to enable
diff --git a/www-servers/pound/pound-2.6.ebuild b/www-servers/pound/pound-2.6.ebuild
new file mode 100644
index 000000000000..fc296210206f
--- /dev/null
+++ b/www-servers/pound/pound-2.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/pound/pound-2.6.ebuild,v 1.1 2012/04/27 07:25:10 patrick Exp $
+
+EAPI=2
+inherit eutils
+
+MY_P=${P/p/P}
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+HOMEPAGE="http://www.apsis.ch/pound/"
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="dynscaler"
+
+DEPEND="dev-libs/libpcre
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable dynscaler)
+}
+
+src_install() {
+ dodir /usr/sbin
+ cp "${S}"/pound "${D}"/usr/sbin/
+ cp "${S}"/poundctl "${D}"/usr/sbin/
+
+ doman pound.8
+ doman poundctl.8
+ dodoc README FAQ
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}"/pound.init-1.9 pound
+
+ insinto /etc
+ newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
+}
+
+pkg_postinst() {
+ elog "No demo-/sample-configfile is included in the distribution -"
+ elog "read the man-page for more info."
+ elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+ echo
+ ewarn "You will have to upgrade you configuration file, if you are"
+ ewarn "upgrading from a version <= 2.0."
+ echo
+ ewarn "The 'WebDAV' config statement is no longer supported!"
+ ewarn "Please adjust your configuration, if necessary."
+ echo
+}