summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-11-11 18:40:52 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-11-11 18:40:52 +0000
commit9c36ac03a9bd9d258d96a85091e8f7cbd914129c (patch)
tree90b1be437439086e07c87e09eb3bf8eb0a2b6d40 /www-servers
parentNew snapshot of trunk, last revision before the transition from bzr to git. (diff)
downloadgentoo-2-9c36ac03a9bd9d258d96a85091e8f7cbd914129c.tar.gz
gentoo-2-9c36ac03a9bd9d258d96a85091e8f7cbd914129c.tar.bz2
gentoo-2-9c36ac03a9bd9d258d96a85091e8f7cbd914129c.zip
Use new websocket use flag (requires java7) to build websocket as it won't work on java < 7.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/ChangeLog7
-rw-r--r--www-servers/tomcat/metadata.xml1
-rw-r--r--www-servers/tomcat/tomcat-7.0.56.ebuild15
3 files changed, 16 insertions, 7 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 5747d49095a5..0a32d93a0f20 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.331 2014/11/11 18:21:05 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.332 2014/11/11 18:40:52 ercpe Exp $
+
+ 11 Nov 2014; Johann Schmitz <ercpe@gentoo.org> metadata.xml,
+ tomcat-7.0.56.ebuild:
+ Use new websocket use flag (requires java7) to build websocket as it won't
+ work on java < 7.
11 Nov 2014; Johann Schmitz <ercpe@gentoo.org>
files/tomcat-7.0.56-build.xml.patch, tomcat-7.0.56.ebuild:
diff --git a/www-servers/tomcat/metadata.xml b/www-servers/tomcat/metadata.xml
index f957b79d7d7b..6f8636c1d0e5 100644
--- a/www-servers/tomcat/metadata.xml
+++ b/www-servers/tomcat/metadata.xml
@@ -10,5 +10,6 @@
</longdescription>
<use>
<flag name='extra-webapps'>Build also the docs and examples webapp</flag>
+ <flag name="websockets">Builds websockets api and implementation (requires java 7)</flag>
</use>
</pkgmetadata>
diff --git a/www-servers/tomcat/tomcat-7.0.56.ebuild b/www-servers/tomcat/tomcat-7.0.56.ebuild
index 2a1472b6067a..343bc76f3265 100644
--- a/www-servers/tomcat/tomcat-7.0.56.ebuild
+++ b/www-servers/tomcat/tomcat-7.0.56.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.56.ebuild,v 1.2 2014/11/11 18:21:05 ercpe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.56.ebuild,v 1.3 2014/11/11 18:40:52 ercpe Exp $
EAPI=5
@@ -17,7 +17,7 @@ SRC_URI="mirror://apache/${PN}/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="7"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="extra-webapps"
+IUSE="extra-webapps websockets"
RESTRICT="test" # can we run them on a production system?
@@ -30,9 +30,11 @@ COMMON_DEP="
extra-webapps? ( dev-java/jakarta-jstl:0 )"
RDEPEND="${COMMON_DEP}
!<dev-java/tomcat-native-1.1.24
- >=virtual/jre-1.6"
+ websockets? ( >=virtual/jre-1.6 )
+ !websockets? ( >=virtual/jre-1.6 )"
DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.6
+ websockets? ( >=virtual/jdk-1.6 )
+ !websockets? ( >=virtual/jdk-1.6 )
>=dev-java/ant-core-1.8.1:0
test? (
dev-java/ant-junit:0
@@ -49,7 +51,7 @@ pkg_setup() {
java_prepare() {
find -type f -name '*.jar' -exec rm -frv {} + || die
- epatch "${FILESDIR}/${P}-2-build.xml.patch"
+ epatch "${FILESDIR}/${P}-build.xml.patch"
# For use of catalina.sh in netbeans
sed -i -e "/^# ----- Execute The Requested Command/ a\
@@ -63,12 +65,13 @@ EANT_BUILD_TARGET="deploy"
EANT_GENTOO_CLASSPATH="tomcat-servlet-api-${SAPI_SLOT},eclipse-ecj-${ECJ_SLOT}"
EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false -Djava.7.home=${JAVA_HOME}"
+EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
# revision of the instance-manager script
IM_REV="-r1"
src_compile() {
+ use websockets && EANT_EXTRA_ARGS="-Djava.7.home=${JAVA_HOME}"
EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
java-pkg-2_src_compile
}