summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2005-02-25 16:11:00 +0000
committerIan Leitch <port001@gentoo.org>2005-02-25 16:11:00 +0000
commita00bd74cb99d409d6666b6b8e180c1b1566b8d11 (patch)
tree275f855bae9a9bc623c8e3bdeca158da784964b0 /www-servers
parentstable on ia64 #75181 (diff)
downloadgentoo-2-a00bd74cb99d409d6666b6b8e180c1b1566b8d11.tar.gz
gentoo-2-a00bd74cb99d409d6666b6b8e180c1b1566b8d11.tar.bz2
gentoo-2-a00bd74cb99d409d6666b6b8e180c1b1566b8d11.zip
Updated to use built_with_use. Removed old versions 4.0.8 and 4.0.9.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/aolserver/ChangeLog6
-rw-r--r--www-servers/aolserver/aolserver-4.0.10.ebuild38
-rw-r--r--www-servers/aolserver/aolserver-4.0.8.ebuild212
-rw-r--r--www-servers/aolserver/aolserver-4.0.9.ebuild212
-rw-r--r--www-servers/aolserver/files/4.0.8/Makefile.global4
-rw-r--r--www-servers/aolserver/files/4.0.8/aolserver-4.0.8-nptl.patch12
-rwxr-xr-xwww-servers/aolserver/files/4.0.8/aolserver.init24
-rw-r--r--www-servers/aolserver/files/4.0.8/config.tcl473
-rw-r--r--www-servers/aolserver/files/digest-aolserver-4.0.81
-rw-r--r--www-servers/aolserver/files/digest-aolserver-4.0.91
10 files changed, 17 insertions, 966 deletions
diff --git a/www-servers/aolserver/ChangeLog b/www-servers/aolserver/ChangeLog
index 04a72c9e0ca5..bb27fa957b8c 100644
--- a/www-servers/aolserver/ChangeLog
+++ b/www-servers/aolserver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/aolserver
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/aolserver/ChangeLog,v 1.6 2005/01/27 20:55:47 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/aolserver/ChangeLog,v 1.7 2005/02/25 16:11:00 port001 Exp $
+
+ 25 Feb 2005; <port001@gentoo.org> aolserver-4.0.10.ebuild,
+ -aolserver-4.0.8.ebuild, -aolserver-4.0.9.ebuild:
+ Updated to use built_with_use. Removed old versions 4.0.8 and 4.0.9.
*aolserver-4.0.10 (27 Jan 2005)
diff --git a/www-servers/aolserver/aolserver-4.0.10.ebuild b/www-servers/aolserver/aolserver-4.0.10.ebuild
index 01dd6c7acedf..647c4862b09f 100644
--- a/www-servers/aolserver/aolserver-4.0.10.ebuild
+++ b/www-servers/aolserver/aolserver-4.0.10.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/aolserver/aolserver-4.0.10.ebuild,v 1.1 2005/01/27 20:55:47 port001 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/aolserver/aolserver-4.0.10.ebuild,v 1.2 2005/02/25 16:11:00 port001 Exp $
inherit eutils
+IUSE="nptl"
+
DESCRIPTION="Webserver with Tcl page scripting"
HOMEPAGE="http://www.aolserver.com/"
SRC_URI="mirror://sourceforge/aolserver/${P}-src.tar.gz"
@@ -12,8 +14,6 @@ LICENSE="MPL-1.1"
SLOT="0"
KEYWORDS="~x86"
-IUSE="nptl"
-
DEPEND=">=dev-lang/tcl-8.4.3"
ns_host="ns-localhost"
@@ -51,30 +51,16 @@ ns_inst_docs="ChangeLog
check_tcl_threads() {
- local threads_found=""
-
- for tcl_install in /var/db/pkg/dev-lang/tcl*; do
-
- # find the version of tcl installed
- # in slot 0
- if grep 0 ${tcl_install}/SLOT > /dev/null; then
- # check that tcl was compiled with threads
- # enabled
- for candidate_flag in `cat ${tcl_install}/USE`; do
- if [ ${candidate_flag} == threads ]; then
- threads_found="true"
- fi
- done
- fi
- done
-
- if [ -n "${threads_found}" ]; then
- einfo "tcl was merged with threading enabled"
- else
- eerror "tcl was not merged with threading enabled."
- eerror "please re-emerge tcl with USE=threads"
- die "threading not enabled in tcl"
+ if ! built_with_use dev-lang/tcl threads;
+ then
+ echo
+ eerror
+ eerror "dev-lang/tcl was not merged with threading enabled."
+ eerror "please re-emerge dev-lang/tcl with USE=threads"
+ eerror
+ die "threading not enabled in dev-lang/tcl"
fi
+
}
pkg_setup() {
diff --git a/www-servers/aolserver/aolserver-4.0.8.ebuild b/www-servers/aolserver/aolserver-4.0.8.ebuild
deleted file mode 100644
index 8c194ca967f4..000000000000
--- a/www-servers/aolserver/aolserver-4.0.8.ebuild
+++ /dev/null
@@ -1,212 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/aolserver/aolserver-4.0.8.ebuild,v 1.4 2005/01/05 19:49:09 port001 Exp $
-
-inherit eutils
-
-DESCRIPTION="Webserver with Tcl page scripting"
-HOMEPAGE="http://www.aolserver.com/"
-SRC_URI="mirror://sourceforge/aolserver/${P}-src.tar.gz"
-
-LICENSE="MPL-1.1"
-SLOT="0"
-KEYWORDS="~x86"
-
-IUSE="nptl"
-
-DEPEND=">=dev-lang/tcl-8.4.3"
-
-ns_host="ns-localhost"
-ns_etc=/etc/${PN}
-ns_pageroot=/var/www/${ns_host}
-ns_serverroot=/var/${PN}
-ns_lib=/usr/lib/${PN}/lib
-ns_bin=/usr/lib/${PN}/bin
-ns_mod=/usr/lib/${PN}/modules
-ns_data=/usr/share/${PN}
-ns_conf=/usr/share/${PN}/include
-ns_doc=/usr/share/doc/${P}
-ns_include=/usr/include/${PN}
-ns_pid=/var/run/${PN}
-ns_log=/var/log/${PN}
-
-ns_inst_bins="nsd/nsd
- nsthread/nsthreadtest"
-ns_inst_libs="nsd/libnsd.so
- nsthread/libnsthread.so
- nsdb/libnsdb.so
- nsext/libnsext.so"
-ns_inst_alibs="nspd/libnspd.a"
-ns_inst_mods="nslog/nslog.so
- nsperm/nsperm.so
- nsdb/nsdb.so
- nsext/nsext.so
- nscgi/nscgi.so
- nssock/nssock.so
- nscp/nscp.so"
-ns_inst_includes="nsd/*.h include/*.h"
-ns_inst_docs="ChangeLog
- README
- install-sh"
-
-check_tcl_threads() {
-
- local threads_found=""
-
- for tcl_install in /var/db/pkg/dev-lang/tcl*; do
-
- # find the version of tcl installed
- # in slot 0
- if grep 0 ${tcl_install}/SLOT > /dev/null; then
- # check that tcl was compiled with threads
- # enabled
- for candidate_flag in `cat ${tcl_install}/USE`; do
- if [ ${candidate_flag} == threads ]; then
- threads_found="true"
- fi
- done
- fi
- done
-
- if [ -n "${threads_found}" ]; then
- einfo "tcl was merged with threading enabled"
- else
- eerror "tcl was not merged with threading enabled."
- eerror "please re-emerge tcl with USE=threads"
- die "threading not enabled in tcl"
- fi
-}
-
-pkg_setup() {
-
- check_tcl_threads
-}
-
-src_unpack() {
-
- unpack ${A}
- find ${S} -type d -name CVS -prune | xargs rm -rf
-
- if use nptl; then
- epatch ${FILESDIR}/${PV}/aolserver-${PV}-nptl.patch
- fi
-}
-
-src_compile() {
-
- local myconf
- myconf="--with-tcl=/usr/lib"
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
-
- dodir ${ns_etc}
- dodir ${ns_pageroot}
- dodir ${ns_serverroot}
- dodir ${ns_lib}
- dodir ${ns_bin}
- dodir ${ns_mod}
- dodir ${ns_mod}/tcl
- dodir ${ns_data}
- dodir ${ns_conf}
- dodir ${ns_doc}
- dodir ${ns_include}
- dodir ${ns_pid}
- dodir ${ns_log}
-
- enewgroup web
- enewuser aolserver -1 /bin/bash ${ns_data} web
-
- chown -R root:web ${D}/${ns_data}
- chmod -R g+w ${D}/${ns_data}
- chown -R aolserver:web ${D}/${ns_pageroot}
- chmod -R g+w ${D}/${ns_pageroot}
- chown -R aolserver:web ${D}/${ns_serverroot}
- chmod -R g+w ${D}/${ns_serverroot}
- chown -R aolserver:web ${D}/${ns_log}
- chmod -R g+w ${D}/${ns_log}
- chown -R aolserver:web ${D}/${ns_pid}
- chmod -R g+w ${D}/${ns_pid}
- chown -R root:web ${D}/${ns_mod}
- chmod -R g+w ${D}/${ns_mod}
-
- for bin_file in ${ns_inst_bins}; do
- dobin ${S}/${bin_file}
- done
-
- insinto ${ns_lib}
- for lib_file in ${ns_inst_libs}; do
- doins ${S}/${lib_file}
- done
- for alib_file in ${ns_inst_alibs}; do
- ranlib ${S}/${alib_file}
- doins ${S}/${alib_file}
- done
-
- insinto ${ns_bin}
- for mod_file in ${ns_inst_mods}; do
- doins ${S}/${mod_file}
- done
-
- insinto ${ns_include}
- for include_file in ${ns_inst_includes}; do
- doins ${S}/${include_file}
- done
-
- for doc_file in ${ns_inst_docs}; do
- dodoc ${doc_file}
- done
-
- doman ${S}/doc/*.1 ${S}/doc/*.3 ${S}/doc/*.n
-
- insinto ${ns_mod}/tcl
- doins ${S}/tcl/*.tcl
-
- #doins doesn't recurse
- #insinto ${ns_pageroot}; doins -r ${S}/tests/*
- cp -r ${S}/tests/* ${D}/${ns_pageroot}
-
- insinto ${ns_bin}
- doins ${S}/nsd/init.tcl
-
- dodir ${ns_mod}/tcl/nsperm
- insinto ${ns_mod}/tcl/nsperm
- doins ${S}/nsperm/*.tcl
-
- dodir ${ns_etc}/modules/nsperm
- insinto ${ns_etc}/modules/nsperm
- for perm_file in passwd group hosts.allow hosts.deny perms; do
- doins nsperm/${perm_file}
- done
-
- insinto ${ns_data}
- doins sample-config.tcl
-
- insinto ${ns_conf}
- doins ${FILESDIR}/${PV}/Makefile.global
- newins ${S}/include/Makefile.global Makefile.global.orig
- doins ${S}/include/Makefile.build
- dosed "s:../include:${ns_conf}:g" /usr/share/aolserver/include/Makefile.build
- doins ${S}/include/Makefile.module
- dosed "s:../include:${ns_conf}:g" /usr/share/aolserver/include/Makefile.module
-
- insinto ${ns_etc}
- newins ${FILESDIR}/${PV}/config.tcl aolserver.tcl
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/${PV}/aolserver.init aolserver
- chmod 750 ${D}/etc/init.d/aolserver
-}
-
-pkg_postinst () {
-
- echo
- einfo "Upgrading:"
- einfo " Check /usr/share/aolserver/sample-config.tcl"
- einfo " for new configuration options that you may want"
- einfo " to use in your existing configuration."
- echo
-}
diff --git a/www-servers/aolserver/aolserver-4.0.9.ebuild b/www-servers/aolserver/aolserver-4.0.9.ebuild
deleted file mode 100644
index 3d39f64da666..000000000000
--- a/www-servers/aolserver/aolserver-4.0.9.ebuild
+++ /dev/null
@@ -1,212 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/aolserver/aolserver-4.0.9.ebuild,v 1.1 2005/01/05 19:49:09 port001 Exp $
-
-inherit eutils
-
-DESCRIPTION="Webserver with Tcl page scripting"
-HOMEPAGE="http://www.aolserver.com/"
-SRC_URI="mirror://sourceforge/aolserver/${P}-src.tar.gz"
-
-LICENSE="MPL-1.1"
-SLOT="0"
-KEYWORDS="~x86"
-
-IUSE="nptl"
-
-DEPEND=">=dev-lang/tcl-8.4.3"
-
-ns_host="ns-localhost"
-ns_etc=/etc/${PN}
-ns_pageroot=/var/www/${ns_host}
-ns_serverroot=/var/${PN}
-ns_lib=/usr/lib/${PN}/lib
-ns_bin=/usr/lib/${PN}/bin
-ns_mod=/usr/lib/${PN}/modules
-ns_data=/usr/share/${PN}
-ns_conf=/usr/share/${PN}/include
-ns_doc=/usr/share/doc/${P}
-ns_include=/usr/include/${PN}
-ns_pid=/var/run/${PN}
-ns_log=/var/log/${PN}
-
-ns_inst_bins="nsd/nsd
- nsthread/nsthreadtest"
-ns_inst_libs="nsd/libnsd.so
- nsthread/libnsthread.so
- nsdb/libnsdb.so
- nsext/libnsext.so"
-ns_inst_alibs="nspd/libnspd.a"
-ns_inst_mods="nslog/nslog.so
- nsperm/nsperm.so
- nsdb/nsdb.so
- nsext/nsext.so
- nscgi/nscgi.so
- nssock/nssock.so
- nscp/nscp.so"
-ns_inst_includes="nsd/*.h include/*.h"
-ns_inst_docs="ChangeLog
- README
- install-sh"
-
-check_tcl_threads() {
-
- local threads_found=""
-
- for tcl_install in /var/db/pkg/dev-lang/tcl*; do
-
- # find the version of tcl installed
- # in slot 0
- if grep 0 ${tcl_install}/SLOT > /dev/null; then
- # check that tcl was compiled with threads
- # enabled
- for candidate_flag in `cat ${tcl_install}/USE`; do
- if [ ${candidate_flag} == threads ]; then
- threads_found="true"
- fi
- done
- fi
- done
-
- if [ -n "${threads_found}" ]; then
- einfo "tcl was merged with threading enabled"
- else
- eerror "tcl was not merged with threading enabled."
- eerror "please re-emerge tcl with USE=threads"
- die "threading not enabled in tcl"
- fi
-}
-
-pkg_setup() {
-
- check_tcl_threads
-}
-
-src_unpack() {
-
- unpack ${A}
- find ${S} -type d -name CVS -prune | xargs rm -rf
-
- if use nptl; then
- epatch ${FILESDIR}/${PV}/aolserver-${PV}-nptl.patch
- fi
-}
-
-src_compile() {
-
- local myconf
- myconf="--with-tcl=/usr/lib"
-
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install () {
-
- dodir ${ns_etc}
- dodir ${ns_pageroot}
- dodir ${ns_serverroot}
- dodir ${ns_lib}
- dodir ${ns_bin}
- dodir ${ns_mod}
- dodir ${ns_mod}/tcl
- dodir ${ns_data}
- dodir ${ns_conf}
- dodir ${ns_doc}
- dodir ${ns_include}
- dodir ${ns_pid}
- dodir ${ns_log}
-
- enewgroup web
- enewuser aolserver -1 /bin/bash ${ns_data} web
-
- chown -R root:web ${D}/${ns_data}
- chmod -R g+w ${D}/${ns_data}
- chown -R aolserver:web ${D}/${ns_pageroot}
- chmod -R g+w ${D}/${ns_pageroot}
- chown -R aolserver:web ${D}/${ns_serverroot}
- chmod -R g+w ${D}/${ns_serverroot}
- chown -R aolserver:web ${D}/${ns_log}
- chmod -R g+w ${D}/${ns_log}
- chown -R aolserver:web ${D}/${ns_pid}
- chmod -R g+w ${D}/${ns_pid}
- chown -R root:web ${D}/${ns_mod}
- chmod -R g+w ${D}/${ns_mod}
-
- for bin_file in ${ns_inst_bins}; do
- dobin ${S}/${bin_file}
- done
-
- insinto ${ns_lib}
- for lib_file in ${ns_inst_libs}; do
- doins ${S}/${lib_file}
- done
- for alib_file in ${ns_inst_alibs}; do
- ranlib ${S}/${alib_file}
- doins ${S}/${alib_file}
- done
-
- insinto ${ns_bin}
- for mod_file in ${ns_inst_mods}; do
- doins ${S}/${mod_file}
- done
-
- insinto ${ns_include}
- for include_file in ${ns_inst_includes}; do
- doins ${S}/${include_file}
- done
-
- for doc_file in ${ns_inst_docs}; do
- dodoc ${doc_file}
- done
-
- doman ${S}/doc/*.1 ${S}/doc/*.3 ${S}/doc/*.n
-
- insinto ${ns_mod}/tcl
- doins ${S}/tcl/*.tcl
-
- #doins doesn't recurse
- #insinto ${ns_pageroot}; doins -r ${S}/tests/*
- cp -r ${S}/tests/* ${D}/${ns_pageroot}
-
- insinto ${ns_bin}
- doins ${S}/nsd/init.tcl
-
- dodir ${ns_mod}/tcl/nsperm
- insinto ${ns_mod}/tcl/nsperm
- doins ${S}/nsperm/*.tcl
-
- dodir ${ns_etc}/modules/nsperm
- insinto ${ns_etc}/modules/nsperm
- for perm_file in passwd group hosts.allow hosts.deny perms; do
- doins nsperm/${perm_file}
- done
-
- insinto ${ns_data}
- doins sample-config.tcl
-
- insinto ${ns_conf}
- doins ${FILESDIR}/${PV}/Makefile.global
- newins ${S}/include/Makefile.global Makefile.global.orig
- doins ${S}/include/Makefile.build
- dosed "s:../include:${ns_conf}:g" /usr/share/aolserver/include/Makefile.build
- doins ${S}/include/Makefile.module
- dosed "s:../include:${ns_conf}:g" /usr/share/aolserver/include/Makefile.module
-
- insinto ${ns_etc}
- newins ${FILESDIR}/${PV}/config.tcl aolserver.tcl
-
- exeinto /etc/init.d
- newexe ${FILESDIR}/${PV}/aolserver.init aolserver
- chmod 750 ${D}/etc/init.d/aolserver
-}
-
-pkg_postinst () {
-
- echo
- einfo "Upgrading:"
- einfo " Check /usr/share/aolserver/sample-config.tcl"
- einfo " for new configuration options that you may want"
- einfo " to use in your existing configuration."
- echo
-}
diff --git a/www-servers/aolserver/files/4.0.8/Makefile.global b/www-servers/aolserver/files/4.0.8/Makefile.global
deleted file mode 100644
index 033164670167..000000000000
--- a/www-servers/aolserver/files/4.0.8/Makefile.global
+++ /dev/null
@@ -1,4 +0,0 @@
-include /usr/share/aolserver/include/Makefile.global.orig
-
-LDFLAGS += -L/usr/lib/aolserver/lib
-INCDIR = /usr/include/aolserver
diff --git a/www-servers/aolserver/files/4.0.8/aolserver-4.0.8-nptl.patch b/www-servers/aolserver/files/4.0.8/aolserver-4.0.8-nptl.patch
deleted file mode 100644
index 7723995f6588..000000000000
--- a/www-servers/aolserver/files/4.0.8/aolserver-4.0.8-nptl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN aolserver-4.0.8-orig/nsd/unix.c aolserver-4.0.8/nsd/unix.c
---- aolserver-4.0.8-orig/nsd/unix.c 2004-12-17 15:17:08.368063032 +0000
-+++ aolserver-4.0.8/nsd/unix.c 2004-12-17 15:18:35.356838728 +0000
-@@ -71,7 +71,7 @@
- * As of glibc 2.3 with NPTL, this should be a no-op.
- */
-
-- pthread_kill_other_threads_np();
-+ //pthread_kill_other_threads_np();
- #endif
-
- abort();
diff --git a/www-servers/aolserver/files/4.0.8/aolserver.init b/www-servers/aolserver/files/4.0.8/aolserver.init
deleted file mode 100755
index 45cb36cd14c1..000000000000
--- a/www-servers/aolserver/files/4.0.8/aolserver.init
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/sbin/runscript
-
-instance=`basename ${1}`
-instance="${instance/*\./}"
-
-depend() {
- use net
-}
-
-start() {
- ebegin "Starting aolserver - $instance"
- env LD_LIBRARY_PATH=/usr/lib/aolserver/lib \
- start-stop-daemon --start --quiet --exec /usr/bin/nsd -- \
- -t /etc/aolserver/$instance.tcl \
- -u aolserver \
- -g web
- eend $?
-}
-
-stop () {
- ebegin "Stopping aolserver - $instance"
- start-stop-daemon --stop --quiet --pidfile /var/run/aolserver/$instance.pid
- eend $?
-}
diff --git a/www-servers/aolserver/files/4.0.8/config.tcl b/www-servers/aolserver/files/4.0.8/config.tcl
deleted file mode 100644
index 421efead96b1..000000000000
--- a/www-servers/aolserver/files/4.0.8/config.tcl
+++ /dev/null
@@ -1,473 +0,0 @@
-#
-# The contents of this file are subject to the AOLserver Public License
-# Version 1.1 (the "License"); you may not use this file except in
-# compliance with the License. You may obtain a copy of the License at
-# http://aolserver.com/.
-#
-# Software distributed under the License is distributed on an "AS IS"
-# basis, WITHOUT WARRANTY OF ANY KIND, either express or implied. See
-# the License for the specific language governing rights and limitations
-# under the License.
-#
-# The Original Code is AOLserver Code and related documentation
-# distributed by AOL.
-#
-# The Initial Developer of the Original Code is America Online,
-# Inc. Portions created by AOL are Copyright (C) 1999 America Online,
-# Inc. All Rights Reserved.
-#
-# Alternatively, the contents of this file may be used under the terms
-# of the GNU General Public License (the "GPL"), in which case the
-# provisions of GPL are applicable instead of those above. If you wish
-# to allow use of your version of this file only under the terms of the
-# GPL and not to allow others to use your version of this file under the
-# License, indicate your decision by deleting the provisions above and
-# replace them with the notice and other provisions required by the GPL.
-# If you do not delete the provisions above, a recipient may use your
-# version of this file under either the License or the GPL.
-#
-#
-# $Header: /var/cvsroot/gentoo-x86/www-servers/aolserver/files/4.0.8/config.tcl,v 1.1 2004/12/19 02:56:09 port001 Exp $
-#
-
-#
-# Set some Tcl variables that are commonly used throughout this file.
-#
-
-# The hostname and address should be set to actual values.
-set hostname localhost
-set address 127.0.0.1
-
-set servername "aolserver"
-set serverdesc "Gentoo Linux AOLserver"
-
-set httpport 8000
-set httpsport 8443
-
-set directoryfile index.adp,index.html,index.htm
-
-set homedir /usr/lib/aolserver
-set bindir ${homedir}/bin
-set logdir /var/log/aolserver
-set piddir /var/run/aolserver
-
-set serverroot /var/aolserver
-set pageroot /var/www/ns-${hostname}
-
-set debug false
-
-
-###################
-# Modules to load
-#
-ns_section "ns/server/${servername}/modules"
-
- ##################
- # Standard AOLserver modules
- ns_param nssock ${bindir}/nssock.so
- ns_param nslog ${bindir}/nslog.so
- #ns_param nscgi ${bindir}/nscgi.so
- #ns_param nsperm ${bindir}/nsperm.so
- #ns_param nscp ${bindir}/nscp.so
-
- ##################
- # The modules below are not installed by default. Some of them exist as
- # separate ebuilds.
- #ns_param nssha1 ${bindir}/nssha1.so
- #ns_param nscache ${bindir}/nscache.so
-
- # URL rewriting module
- #ns_param nsrewrite ${bindir}/nsrewrite.so
-
- # Allow SSL connections
- #ns_param nsopenssl ${bindir}/nsopenssl.so
-
- # Enable free text search
- #ns_param nsfts ${bindir}/nsfts.so
-
- # Allow PAM authentication
- #ns_param nspam ${bindir}/nspam.so
-
- # Allow LDAP authentication
- #ns_param nsldap ${bindir}/nsldap.so
-
-
-######################################################################
-#
-# AOLserver Parameters
-#
-######################################################################
-
-#
-# Global server parameters
-#
-ns_section "ns/parameters"
- ns_param home $homedir
- ns_param logroll on
- ns_param serverlog ${logdir}/error.log
- ns_param maxbackup 5
- ns_param pidfile ${piddir}/${servername}.pid
- ns_param maxkeepalive 0
- ns_param debug $debug
-
- # I18N Parameters
- # Automatic adjustment of response content-type header to include charset
- #ns_param HackContentType true
-
- # Default output charset. When none specified, no character encoding of
- # output is performed.
- ns_param OutputCharset iso8859-1
-
- # Default Charset for Url Encode/Decode. When none specified, no character
- # set encoding is performed.
- ns_param URLCharset iso8859-1
-
- # This parameter supports output encoding arbitration.
- #ns_param PreferredCharsets { utf-8 iso8859-1 }
-
-#
-# Thread library (nsthread) parameters
-#
-ns_section "ns/threads"
- # Per-thread stack size.
- ns_param stacksize [expr 512*1024]
- # Measure lock contention
- ns_param mutexmeter false
-
-#
-# MIME types.
-#
-# Note: AOLserver already has an exhaustive list of MIME types, but in
-# case something is missing you can add it here.
-ns_section "ns/mimetypes"
- ns_param default "*/*" ;# MIME type for unknown extension.
- ns_param noextension "*/*" ;# MIME type for missing extension.
- ns_param .pcd image/x-photo-cd
- ns_param .prc application/x-pilot
- ns_param .xls application/vnd.ms-excel
- ns_param .doc application/vnd.ms-word
-
- # I18N Mime-types; define content-type header values
- # to be mapped from these file-types.
- # Note that you can map file-types of adp files to control
- # the output encoding through mime-type specificaion.
- # Remember to add an adp mapping for that extension.
- ns_param .adp "text/html; charset=iso-8859-1"
- ns_param .u_adp "text/html; charset=UTF-8"
- ns_param .gb_adp "text/html; charset=GB2312"
- ns_param .sjis_html "text/html; charset=shift_jis"
- ns_param .sjis_adp "text/html; charset=shift_jis"
- ns_param .gb_html "text/html; charset=GB2312"
-
-#
-# I18N File-type to Encoding mappings
-#
-ns_section "ns/encodings"
- ns_param .utf_html "utf-8"
- ns_param .sjis_html "shiftjis"
- ns_param .gb_html "gb2312"
- ns_param .big5_html "big5"
- ns_param .euc-cn_html "euc-cn"
- # Note: you will need to include file-type to encoding mappings
- # for ANY source files that are to be used, to allow the
- # server to handle them properly. E.g., the following
- # asserts that the GB-producing .adp files are themselves
- # encoded in GB2312 (this is not simply assumed).
- ns_param .gb_adp "gb2312"
-
-
-
-######################################################################
-#
-# Server-level configuration
-#
-# There is only one server in AOLserver, but this is helpful when multiple
-# servers share the same configuration file. This file assumes that only
-# one server is in use so it is set at the top in the "server" Tcl variable.
-# Other host-specific values are set up above as Tcl variables, too.
-#
-######################################################################
-
-ns_section "ns/servers"
- ns_param $servername $serverdesc
-
-
-#
-# Server parameters
-#
-ns_section "ns/server/${servername}"
- ns_param directoryfile $directoryfile
- ns_param pageroot $pageroot
- ns_param enabletclpages true ;# Parse *.tcl files in pageroot.
-
- # Server-level I18N Parameters can be specified here, to override
- # the global ones for this server. These are:
- # HackContentType
- # OutputCharset
- # URLCharset
- # See the global parameter I18N section for a description of these.
-
- # Scaling and Tuning Options
- #
- # Note: These values aren't necessarily the defaults.
- #ns_param connsperthread 0 ;# Normally there's one conn per thread
- #ns_param flushcontent false ;# Flush all data before returning
- #ns_param maxconnections 100 ;# Max connections to put on queue
- #ns_param maxdropped 0 ;# Shut down if dropping too many conns
- #ns_param maxthreads 20 ;# Tune this to scale your server
- #ns_param minthreads 0 ;# Tune this to scale your server
- #ns_param threadtimeout 120 ;# Idle threads die at this rate
-
- # Special HTTP pages
- #ns_param NotFoundResponse "/global/file-not-found.html"
- #ns_param ServerBusyResponse "/global/busy.html"
- #ns_param ServerInternalErrorResponse "/global/error.html"
-
-
-# Fast path configuration is used to configure options used for serving
-# static content, and also provides options to automatically display
-# directory listings.
-ns_section "ns/server/${servername}/fastpath"
- # Enable cache for normal URLs.
- #ns_param cache false
- # Size of fast path cache.
- #ns_param cachemaxsize 5120000
- # Largest file size allowed in cache.
- #ns_param cachemaxentry [expr {$cachemaxsize / 10}]
- # Use mmap() for cache.
- #ns_param mmap false
- # Directory listing style. Can be "fancy" or "simple".
- #ns_param directorylisting fancy
- # Directory index/default page to look for.
- #ns_param directoryfile $directoryfile
- # Name of Tcl proc to use to display directory listings.
- #ns_param directoryproc _ns_dirlist
- # Name of ADP page to use to display directory listings.
- #ns_param directoryadp example.adp
-
-#
-# ADP (AOLserver Dynamic Page) configuration
-#
-ns_section "ns/server/${servername}/adp"
- # Extensions to parse as ADP's.
- ns_param map "/*.adp"
- ns_param map "/*.u_adp"
- ns_param map "/*.gb_adp"
- ns_param map "/*.sjis_adp"
- # Any extension can be mapped.
- #ns_param map "/*.html"
-
- # Set "Expires: now" on all ADP's.
- ns_param enableexpire false
- # Allow Tclpro debugging with "?debug".
- ns_param enabledebug false
-
- # ADP special pages
- #ns_param errorpage ${pageroot}/errorpage.adp
-
-#
-# Tcl Configuration
-#
-ns_section "ns/server/${servername}/tcl"
- # Enable server specific tcl libraries
- #ns_param library ${serverroot}/tcl
- #ns_param autoclose on
- #ns_param debug $debug
-
-######################################################################
-#
-# Module specific configuration
-#
-######################################################################
-
-#
-# Socket driver module (HTTP) -- nssock
-#
-ns_section "ns/server/${servername}/module/nssock"
- ns_param port $httpport
- ns_param hostname $hostname
- ns_param address $address
- ns_param timeout 120
-
-#
-# Access log -- nslog
-#
-ns_section "ns/server/${servername}/module/nslog"
- ns_param rolllog true
- # Roll log on SIGHUP.
- ns_param rollonsignal true
- ns_param rollday *
- ns_param rollhour 0
- ns_param rollfmt %Y-%m-%d-%H:%M
- # Max number to keep around when rolling.
- ns_param maxbackup 5
- ns_param file ${logdir}/${servername}.log
- ns_param enablehostnamelookup false
- ns_param logcombined true
- #ns_param logrefer false
- #ns_param loguseragent false
-
-#
-# Socket driver module (HTTPS) -- nsopenssl
-#
-#ns_section "ns/server/${servername}/module/nsopenssl"
-#set ciphersuite "ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP"
- # Typically where you store your certificates
- #ns_param ModuleDir ${serverroot}/etc/certs
- #ns_param RandomFile /dev/random
- #ns_param SeedBytes 1024
-
- # NSD-driven connections:
- #ns_param ServerPort $httpsport
- #ns_param ServerHostname $hostname
- #ns_param ServerAddress $address
- #ns_param ServerCertFile certfile.pem
- #ns_param ServerKeyFile keyfile.pem
- #ns_param ServerProtocols "SSLv2, SSLv3, TLSv1"
- #ns_param ServerCipherSuite $ciphersuite
- #ns_param ServerSessionCache false
- #ns_param ServerSessionCacheID 1
- #ns_param ServerSessionCacheSize 512
- #ns_param ServerSessionCacheTimeout 300
- #ns_param ServerPeerVerify true
- #ns_param ServerPeerVerifyDepth 3
- #ns_param ServerCADir ca
- #ns_param ServerCAFile ca.pem
- #ns_param ServerTrace false
-
- # For listening and accepting SSL connections via Tcl/C API:
- #ns_param SockServerCertFile certfile.pem
- #ns_param SockServerKeyFile keyfile.pem
- #ns_param SockServerProtocols "SSLv2, SSLv3, TLSv1"
- #ns_param SockServerCipherSuite $ciphersuite
- #ns_param SockServerSessionCache false
- #ns_param SockServerSessionCacheID 2
- #ns_param SockServerSessionCacheSize 512
- #ns_param SockServerSessionCacheTimeout 300
- #ns_param SockServerPeerVerify true
- #ns_param SockServerPeerVerifyDepth 3
- #ns_param SockServerCADir internal_ca
- #ns_param SockServerCAFile internal_ca.pem
- #ns_param SockServerTrace false
-
- # Outgoing SSL connections
- #ns_param SockClientCertFile certfile.pem
- #ns_param SockClientKeyFile keyfile.pem
- #ns_param SockClientProtocols "SSLv2, SSLv3, TLSv1"
- #ns_param SockClientCipherSuite $ciphersuite
- #ns_param SockClientSessionCache false
- #ns_param SockClientSessionCacheID 3
- #ns_param SockClientSessionCacheSize 512
- #ns_param SockClientSessionCacheTimeout 300
- #ns_param SockClientPeerVerify true
- #ns_param SockServerPeerVerifyDepth 3
- #ns_param SockClientCADir ca
- #ns_param SockClientCAFile ca.pem
- #ns_param SockClientTrace false
-
-
-#
-# Server control port module -- nscp
-#
-#ns_section "ns/server/${servername}/module/nscp"
- #ns_param address 127.0.0.1
- #ns_param port 9999
- #ns_param echopassword 1
- #ns_param cpcmdlogging 1
-
-#ns_section "ns/server/${servername}/module/nscp/users"
- # You can use the ns_crypt Tcl command to generate an encrypted
- # password. The ns_crypt command uses the same algorithm as the
- # Unix crypt(3) command. You could also use passwords from the
- # /etc/passwd file.
- #
- # Users should be listed in the following format:
- # <user>:<encryptedPassword>:
- #
- # The configuration example below adds the user "nsadmin" with a
- # password of "x".
- #ns_param user "nsadmin:t2GqvvaiIUbF2:"
-
-#
-# CGI interface -- nscgi
-#
-# WARNING: These directories must not live under pageroot.
-#
-ns_section "ns/server/${servername}/module/nscgi"
- #ns_param map "GET /cgi ${serverroot}/cgi" ;# CGI script file dir (GET).
- #ns_param map "POST /cgi ${serverroot}/cgi" ;# CGI script file dir (POST).
-
-
-#
-# Example: Host headers based virtual servers.
-#
-# To enable:
-#
-# 1. Load comm driver(s) globally.
-# 2. Configure drivers as in a virtual server.
-# 3. Add a "servers" section to map virtual servers to Host headers.
-#
-#ns_section ns/modules
-#ns_section nssock nssock.so
-#
-#ns_section ns/module/nssock
-#ns_param port $httpport
-#ns_param hostname $hostname
-#ns_param address $address
-#
-#ns_section ns/module/nssock/servers
-#ns_param server1 $hostname:$httpport
-#
-#ns_section /ns/servers/server1
-#ns_param pageroot /var/www/$hostname/aolserver/www
-
-#
-# Example: Multiple connection thread pools.
-#
-# To enable:
-#
-# 1. Define one or more thread pools.
-# 2. Configure pools as with the default server pool.
-# 3. Map method/URL combinations to the pools
-#
-# All unmapped method/URL's will go to the default server pool.
-#
-#ns_section ns/server/server1/pools
-#ns_section slow "Slow requests here."
-#ns_section fast "Fast requests here."
-#
-#ns_section ns/server/server1/pool/slow
-#ns_param map {POST /slowupload.adp}
-#ns_param maxconnections 100 ;# Max connections to put on queue
-#ns_param maxdropped 0 ;# Shut down if dropping too many conns
-#ns_param maxthreads 20 ;# Tune this to scale your server
-#ns_param minthreads 0 ;# Tune this to scale your server
-#ns_param threadtimeout 120 ;# Idle threads die at this rate
-#
-#ns_section ns/server/server1/pool/fast
-#ns_param map {GET /faststuff.adp}
-#ns_param maxthreads 10
-#
-
-#
-# Example: Web based stats interface.
-#
-# To enable:
-#
-# 1. Configure whether or not stats are enabled. (Optional: default = false)
-# 2. Configure URL for statistics. (Optional: default = /_stats)
-#
-# http://<host>:<port>/_stats
-#
-# 3. Configure user. (Optional: default = aolserver)
-# 4. Configure password. (Optional: default = stats)
-#
-# For added security it is recommended that configure your own
-# URL, user, and password instead of using the default values.
-#
-#ns_section ns/server/stats
-# ns_param enabled 1
-# ns_param url /aolserver/stats
-# ns_param user aolserver
-# ns_param password 23dfs!d
-#
diff --git a/www-servers/aolserver/files/digest-aolserver-4.0.8 b/www-servers/aolserver/files/digest-aolserver-4.0.8
deleted file mode 100644
index 389e2d6ab221..000000000000
--- a/www-servers/aolserver/files/digest-aolserver-4.0.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5391feb86dfb822f2b2d41a5c8854f89 aolserver-4.0.8-src.tar.gz 585615
diff --git a/www-servers/aolserver/files/digest-aolserver-4.0.9 b/www-servers/aolserver/files/digest-aolserver-4.0.9
deleted file mode 100644
index 16be30e95b6a..000000000000
--- a/www-servers/aolserver/files/digest-aolserver-4.0.9
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f502e6f475c782888871fb8b5f9ed4c1 aolserver-4.0.9-src.tar.gz 591904