summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2014-10-27 16:40:14 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2014-10-27 16:40:14 +0000
commite1a4a8fc828971c1f9ded12a4ac368478c3607a7 (patch)
tree5a9c00fceebe8708f8543b408a053c0f19056aa2 /www-servers
parentdrop lcms:0 support (bug #526822) (diff)
downloadgentoo-2-e1a4a8fc828971c1f9ded12a4ac368478c3607a7.tar.gz
gentoo-2-e1a4a8fc828971c1f9ded12a4ac368478c3607a7.tar.bz2
gentoo-2-e1a4a8fc828971c1f9ded12a4ac368478c3607a7.zip
version bump, drop old
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/uwsgi/ChangeLog8
-rw-r--r--www-servers/uwsgi/files/2.0.8-threaded-php.patch39
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.8.ebuild (renamed from www-servers/uwsgi/uwsgi-2.0.6-r2.ebuild)7
3 files changed, 50 insertions, 4 deletions
diff --git a/www-servers/uwsgi/ChangeLog b/www-servers/uwsgi/ChangeLog
index 0ddef9e9758a..46515f0739c5 100644
--- a/www-servers/uwsgi/ChangeLog
+++ b/www-servers/uwsgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/uwsgi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/ChangeLog,v 1.61 2014/10/08 09:34:08 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/ChangeLog,v 1.62 2014/10/27 16:40:14 ultrabug Exp $
+
+*uwsgi-2.0.8 (27 Oct 2014)
+
+ 27 Oct 2014; Ultrabug <ultrabug@gentoo.org> -uwsgi-2.0.6-r2.ebuild,
+ +uwsgi-2.0.8.ebuild, +files/2.0.8-threaded-php.patch:
+ version bump, drop old
*uwsgi-2.0.7-r1 (08 Oct 2014)
*uwsgi-2.0.6-r2 (08 Oct 2014)
diff --git a/www-servers/uwsgi/files/2.0.8-threaded-php.patch b/www-servers/uwsgi/files/2.0.8-threaded-php.patch
new file mode 100644
index 000000000000..10bd5189ad6f
--- /dev/null
+++ b/www-servers/uwsgi/files/2.0.8-threaded-php.patch
@@ -0,0 +1,39 @@
+--- a/plugins/php/php_plugin.c 2014-10-27 17:23:50.909755436 +0100
++++ b/plugins/php/php_plugin.c 2014-10-27 17:25:24.970534680 +0100
+@@ -88,7 +88,7 @@
+ return str_length;
+ }
+
+-static int sapi_uwsgi_send_headers(sapi_headers_struct *sapi_headers)
++static int sapi_uwsgi_send_headers(sapi_headers_struct *sapi_headers TSRMLS_DC)
+ {
+ sapi_header_struct *h;
+ zend_llist_position pos;
+@@ -146,7 +146,7 @@
+ }
+
+
+-static char *sapi_uwsgi_read_cookies(void)
++static char *sapi_uwsgi_read_cookies(TSRMLS_D)
+ {
+ uint16_t len = 0;
+ struct wsgi_request *wsgi_req = (struct wsgi_request *) SG(server_context);
+@@ -570,6 +570,10 @@
+ struct uwsgi_string_list *pset = uphp.set;
+ struct uwsgi_string_list *append_config = uphp.append_config;
+
++#ifdef ZTS
++ tsrm_startup(1, 1, 0, NULL);
++#endif
++
+ if (!uphp.sapi_initialized) {
+ sapi_startup(&uwsgi_sapi_module);
+ uphp.sapi_initialized = 1;
+@@ -678,6 +682,7 @@
+
+ zend_file_handle file_handle;
+
++ TSRMLS_FETCH(); // fetch the threading state in case PHP is built with threading
+ SG(server_context) = (void *) wsgi_req;
+
+ if (uwsgi_parse_vars(wsgi_req)) {
diff --git a/www-servers/uwsgi/uwsgi-2.0.6-r2.ebuild b/www-servers/uwsgi/uwsgi-2.0.8.ebuild
index 651e10708151..ad69372e9b4d 100644
--- a/www-servers/uwsgi/uwsgi-2.0.6-r2.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/uwsgi-2.0.6-r2.ebuild,v 1.1 2014/10/08 09:34:08 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/uwsgi-2.0.8.ebuild,v 1.1 2014/10/27 16:40:14 ultrabug Exp $
EAPI="5"
@@ -37,7 +37,7 @@ UWSGI_PLUGINS_STD=( ping cache carbon nagios rpc rrdtool
UWSGI_PLUGINS_OPT=( alarm_{curl,xmpp} clock_{monotonic,realtime} curl_cron
dumbloop echo emperor_{amqp,pg,zeromq} forkptyrouter
geoip graylog2 legion_cache_fetch ldap log{crypto,pipe} notfound pam
- router_{access,radius,spnego,xmldir}
+ rados router_{access,radius,spnego,xmldir}
sqlite ssi stats_pusher_statsd
systemd_logger transformation_toupper tuntap webdav xattr xslt zabbix )
@@ -97,6 +97,7 @@ CDEPEND="sys-libs/zlib
uwsgi_plugins_ldap? ( net-nds/openldap )
uwsgi_plugins_pam? ( virtual/pam )
uwsgi_plugins_sqlite? ( dev-db/sqlite:3 )
+ uwsgi_plugins_rados? ( sys-cluster/ceph )
uwsgi_plugins_router_access? ( sys-apps/tcp-wrappers )
uwsgi_plugins_router_spnego? ( virtual/krb5 )
uwsgi_plugins_rsyslog? ( app-admin/rsyslog )
@@ -136,7 +137,7 @@ pkg_setup() {
src_prepare() {
epatch \
- "${FILESDIR}/1.1.2-threaded-php.patch"
+ "${FILESDIR}/2.0.8-threaded-php.patch"
sed -i \
-e "s|'-O2', ||" \