summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-11-01 23:06:46 +0000
committerVlastimil Babka <caster@gentoo.org>2009-11-01 23:06:46 +0000
commite75db0ee566e230c81934b5f744c9586ceea8e7e (patch)
treefaf9766dcd2a5bfb73ecf20a4665816d408b2886 /www-servers
parentVersion bump. (diff)
downloadgentoo-2-e75db0ee566e230c81934b5f744c9586ceea8e7e.tar.gz
gentoo-2-e75db0ee566e230c81934b5f744c9586ceea8e7e.tar.bz2
gentoo-2-e75db0ee566e230c81934b5f744c9586ceea8e7e.zip
Version bump, bug #268603.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/axis/ChangeLog12
-rw-r--r--www-servers/axis/axis-1.4.ebuild128
-rw-r--r--www-servers/axis/files/axis-1.4-build.xml.patch15
-rw-r--r--www-servers/axis/files/axis-1.4-path_refs.xml.patch20
-rw-r--r--www-servers/axis/files/axis-1.4-targets.xml.patch86
-rw-r--r--www-servers/axis/files/axis-1.4-tools-build.xml.patch26
-rw-r--r--www-servers/axis/files/build.properties15
7 files changed, 300 insertions, 2 deletions
diff --git a/www-servers/axis/ChangeLog b/www-servers/axis/ChangeLog
index 1352832a6655..186b9efbbe63 100644
--- a/www-servers/axis/ChangeLog
+++ b/www-servers/axis/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-servers/axis
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/axis/ChangeLog,v 1.21 2008/03/22 22:31:00 betelgeuse Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/axis/ChangeLog,v 1.22 2009/11/01 23:06:46 caster Exp $
+
+*axis-1.4 (01 Nov 2009)
+
+ 01 Nov 2009; Vlastimil Babka <caster@gentoo.org> +axis-1.4.ebuild,
+ +files/axis-1.4-build.xml.patch, +files/axis-1.4-path_refs.xml.patch,
+ +files/axis-1.4-targets.xml.patch, +files/axis-1.4-tools-build.xml.patch,
+ +files/build.properties:
+ Version bump, bug #268603.
22 Mar 2008; Petteri Räty <betelgeuse@gentoo.org>
-axis-1.2_rc2-r2.ebuild:
diff --git a/www-servers/axis/axis-1.4.ebuild b/www-servers/axis/axis-1.4.ebuild
new file mode 100644
index 000000000000..1da49c72c8e1
--- /dev/null
+++ b/www-servers/axis/axis-1.4.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/axis/axis-1.4.ebuild,v 1.1 2009/11/01 23:06:46 caster Exp $
+
+EAPI=2
+WANT_ANT_TASKS="ant-nodeps ant-trax"
+JAVA_PKG_IUSE="doc source examples"
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_PV="${PV//./_}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Apache's Axis1 implementation of the SOAP (Simple Object Access Protocol)"
+HOMEPAGE="http://ws.apache.org/axis/index.html"
+SRC_URI="mirror://apache/ws/${PN}/${MY_PV}/${PN}-src-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-java/commons-discovery:0
+ dev-java/wsdl4j:0
+ dev-java/sun-jaf:0
+ dev-java/commons-logging:0
+ java-virtuals/javamail:0
+ dev-java/bsf:2.3
+ dev-java/castor:1.0
+ dev-java/commons-httpclient:3
+ dev-java/commons-net:0
+ dev-java/sun-jimi:0
+ dev-java/servletapi:2.4
+ dev-java/saaj:0
+ dev-java/jax-rpc:0
+ dev-java/log4j:0
+ dev-java/xml-commons:0
+ dev-java/xml-xmlbeans:1"
+
+DEPEND="|| ( =virtual/jdk-1.5* =virtual/jdk-1.4* )
+ ${RDEPEND}"
+RDEPEND=">=virtual/jre-1.4
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+AXIS_NAME="${PN}-${SLOT}"
+
+# not declared mandatory but fails without it
+# mailapi.jar would be enough but that's only in -bin, mail.jar superseedes
+EANT_GENTOO_CLASSPATH="sun-jaf,javamail,log4j,xml-xmlbeans-1,servletapi-2.4,bsf-2.3,sun-jimi,commons-httpclient-3,castor-1.0,xml-commons,commons-net"
+EANT_EXTRA_ARGS="-Ddeprecation=false -Dbase.path=/opt
+-Dservlet.jar=servlet-api.jar -Dwsdl4j-1.5.1.jar=wsdl4j.jar
+-Dcommons-logging-1.0.4.jar=commons-logging.jar"
+EANT_BUILD_TARGET="compile"
+EANT_DOC_TARGET="javadocs"
+EANT_NEEDS_TOOLS="true"
+
+#TODO-tests require Atlassian clover, need to figure out which ones
+RESTRICT="test"
+
+java_prepare() {
+ # remove some <copy> actions
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+ # remove exact lib paths and global java.classpath from classpath
+ epatch "${FILESDIR}/${P}-path_refs.xml.patch"
+ # add missing target to javac, xml rewriting would break entities
+ epatch "${FILESDIR}/${P}-tools-build.xml.patch"
+ # remove most of <available> checks
+ epatch "${FILESDIR}/${P}-targets.xml.patch"
+ # and replace them with predefined properties
+ cp "${FILESDIR}/build.properties" . \
+ || die "failed to copy build.properties from ${FILESDIR}"
+
+ rm -rf "${S}"/docs/apiDocs || die
+
+ #Remove test till they are working
+ rm -rf "${S}"/test || die
+ #cd "${S}"/test
+ #mv build_ant.xml build.xml
+ cd "${S}"/webapps/axis/WEB-INF/lib
+ rm -v *.jar || die
+
+ cd "${S}/lib"
+ rm -v *.jar || die
+ java-pkg_jar-from --build-only ant-core
+ java-pkg_jar-from wsdl4j wsdl4j.jar
+ java-pkg_jar-from commons-logging commons-logging.jar
+ java-pkg_jar-from commons-discovery commons-discovery.jar
+
+ if use debug; then
+ EANT_EXTRA_ARGS+=" -Ddebug=on"
+ else
+ EANT_EXTRA_ARGS+=" -Ddebug=off"
+ fi
+
+ cd "${S}"
+ java-ant_rewrite-classpath
+}
+
+src_install() {
+ dodir /usr/share/${AXIS_NAME}
+ mv build/lib/axis-ant.jar build/lib/ant-axis.jar || die
+ java-pkg_dojar build/lib/axis.jar
+ java-pkg_dojar build/lib/ant-axis.jar
+ java-pkg_dojar build/lib/jaxrpc.jar
+ java-pkg_register-ant-task
+ dodir /usr/share/${AXIS_NAME}/webapps
+
+ cp -pR "${S}"/webapps/axis "${D}"/usr/share/${AXIS_NAME}/webapps || die
+
+ dodoc NOTICE README
+ dohtml release-notes.html changelog.html
+
+ if use doc; then
+ java-pkg_dojavadoc build/javadocs/
+ dohtml -r docs/*
+ dodoc xmls/*
+ fi
+
+ use source && java-pkg_dosrc src
+ use examples && java-pkg_doexamples samples
+}
+
+pkg_postinst() {
+ elog "Please note that this package is mainly a dependency library. Contributions"
+ elog "to webapp packaging welcome at https://bugs.gentoo.org/show_bug.cgi?id=89556"
+}
diff --git a/www-servers/axis/files/axis-1.4-build.xml.patch b/www-servers/axis/files/axis-1.4-build.xml.patch
new file mode 100644
index 000000000000..92e5116934da
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-build.xml.patch
@@ -0,0 +1,15 @@
+--- build.xml.orig 2006-04-23 03:57:27.000000000 +0200
++++ build.xml 2006-10-01 21:18:20.000000000 +0200
+@@ -223,10 +223,12 @@
+ </section>
+ </manifest>
+ </jar>
++ <!--
+ <copy file="${wsdl4j.jar}" toDir="${build.lib}"/>
+ <copy file="${commons-logging.jar}" toDir="${build.lib}"/>
+ <copy file="${commons-discovery.jar}" toDir="${build.lib}"/>
+ <copy file="${log4j-core.jar}" toDir="${build.lib}"/>
++ -->
+ <copy file="${src.dir}/log4j.properties"
+ toDir="${build.lib}"/>
+
diff --git a/www-servers/axis/files/axis-1.4-path_refs.xml.patch b/www-servers/axis/files/axis-1.4-path_refs.xml.patch
new file mode 100644
index 000000000000..7c0ad2455bd4
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-path_refs.xml.patch
@@ -0,0 +1,20 @@
+--- xmls/path_refs.xml.orig 2006-04-23 03:56:52.000000000 +0200
++++ xmls/path_refs.xml 2006-10-01 15:31:34.000000000 +0200
+@@ -1,4 +1,5 @@
+ <path id="classpath">
++ <!--
+ <pathelement location="${xercesImpl.jar}"/>
+ <pathelement location="${xmlParserAPIs.jar}"/>
+ <pathelement location="${xalan.jar}"/>
+@@ -14,10 +15,10 @@
+ <pathelement location="${j2ee.jar}"/>
+ <pathelement location="${junit.jar}"/>
+ <pathelement location="${servlet.jar}"/>
++ -->
+ <fileset dir="${lib.dir}">
+ <include name="**/*.jar"/>
+ </fileset>
+- <pathelement path="${java.class.path}"/>
+ <pathelement location="${build.dest}" />
+ <pathelement location="${build.dir}/tools" />
+ <pathelement location="${build.lib}/axis-ant.jar" />
diff --git a/www-servers/axis/files/axis-1.4-targets.xml.patch b/www-servers/axis/files/axis-1.4-targets.xml.patch
new file mode 100644
index 000000000000..1f5f63ee1831
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-targets.xml.patch
@@ -0,0 +1,86 @@
+--- xmls/targets.xml.orig 2006-10-01 15:08:41.000000000 +0200
++++ xmls/targets.xml 2006-10-01 15:14:27.000000000 +0200
+@@ -84,6 +84,7 @@
+ <mkdir dir="${build.lib}"/>
+ <mkdir dir="${build.dir}/work"/>
+
++ <!--
+ <available property="servlet.present"
+ classname="javax.servlet.Servlet"
+ classpathref="classpath"/>
+@@ -135,18 +136,18 @@
+ <available property="httpunit.present"
+ classname="com.meterware.httpunit.GetMethodWebRequest"
+ classpathref="classpath"/>
+-
++ -->
+ <available property="jsse.present"
+ classname="javax.net.ssl.SSLSocketFactory"
+ classpathref="classpath"/>
+-
++ <!--
+ <condition property="jetty.present" >
+ <and>
+ <available classname="javax.servlet.Servlet" classpathref="classpath" />
+ <available classname="org.mortbay.http.HttpServer" classpathref="classpath" />
+ </and>
+ </condition>
+-
++ -->
+ <condition property="jdk14.jsse.present" >
+ <and>
+ <available classname="javax.net.ssl.X509TrustManager" classpathref="classpath" />
+@@ -185,7 +186,7 @@
+ <condition property="sun.codec.present" >
+ <available classname="sun.awt.image.codec.JPEGImageEncoderImpl" classpathref="classpath" />
+ </condition>
+-
++ <!--
+ <condition property="jimi.present" >
+ <available classname="com.sun.jimi.core.Jimi" classpathref="classpath" />
+ </condition>
+@@ -193,7 +194,7 @@
+ <condition property="merlinio.present" >
+ <available classname="javax.imageio.ImageIO" classpathref="classpath" />
+ </condition>
+-
++ -->
+ <condition property="axis-ant.present" >
+ <available classname="org.apache.axis.tools.ant.foreach.ForeachTask">
+ <classpath>
+@@ -201,7 +202,7 @@
+ </classpath>
+ </available>
+ </condition>
+-
++ <!--
+ <condition property="jimiAndAttachments.present">
+ <and>
+ <available classname="javax.activation.DataHandler" classpathref="classpath" />
+@@ -220,7 +221,7 @@
+ <available classname="progress.message.jclient.Message" classpathref="classpath" />
+ </and>
+ </condition>
+-
++ -->
+ <available property="post-compile.present" file="post-compile.xml" />
+
+ <property environment="env"/>
+@@ -229,7 +230,7 @@
+ <equals arg1="on" arg2="${env.debug}"/>
+ </and>
+ </condition>
+-
++ <!--
+ <condition property="castor.present" >
+ <available classname="org.exolab.castor.xml.MarshalException" classpathref="classpath" />
+ </condition>
+@@ -248,7 +249,7 @@
+ <condition property="combridge.present" >
+ <available classname="org.apache.axis.components.bridge.COMBridge" classpathref="classpath" />
+ </condition>
+-
++ -->
+ <!-- look for WSDL support on the platform -->
+ <condition property="wsdl.found">
+ <or>
diff --git a/www-servers/axis/files/axis-1.4-tools-build.xml.patch b/www-servers/axis/files/axis-1.4-tools-build.xml.patch
new file mode 100644
index 000000000000..ce9759264eda
--- /dev/null
+++ b/www-servers/axis/files/axis-1.4-tools-build.xml.patch
@@ -0,0 +1,26 @@
+--- tools/build.xml.orig 2006-10-02 10:18:43.000000000 +0200
++++ tools/build.xml 2006-10-02 10:21:34.000000000 +0200
+@@ -66,6 +66,7 @@
+ <javac srcdir="${tools.dir}"
+ debug="${debug}"
+ source="${source}"
++ target="${target}"
+ nowarn="${nowarn}"
+ destdir="${tools.build.dir}">
+ <classpath refid="classpath"/>
+@@ -77,6 +78,7 @@
+ <javac srcdir="${tools.dir}"
+ debug="${debug}"
+ source="${source}"
++ target="${target}"
+ nowarn="${nowarn}"
+ destdir="${tools.build.dir}">
+ <classpath refid="classpath"/>
+@@ -88,6 +90,7 @@
+ <javac srcdir="${tools.dir}"
+ debug="${debug}"
+ source="${source}"
++ target="${target}"
+ nowarn="${nowarn}"
+ destdir="${tools.build.dir}">
+ <classpath>
diff --git a/www-servers/axis/files/build.properties b/www-servers/axis/files/build.properties
new file mode 100644
index 000000000000..9387391ab441
--- /dev/null
+++ b/www-servers/axis/files/build.properties
@@ -0,0 +1,15 @@
+source=1.4
+target=1.4
+
+activation.present=true
+commons-discovery.present=true
+commons-logging.present=true
+wsdl4j.present=true
+mailapi.present=true
+
+bsf.present=true
+castor.present=true
+commons-httpclient.present=true
+commons-net.present=true
+jimi.present=true
+servlet.present=true