summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-07-04 20:43:46 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-07-04 20:43:46 +0000
commit515a895ab7b05e8ec4e17e0760cd25fac000cfb5 (patch)
tree473dfeaf143fd8dadfa20cfdf3fa9c2d55594b62 /x11-apps/radeontop
parentneed libICE and libSM for proper linking (fixes #515172) (diff)
downloadgentoo-2-515a895ab7b05e8ec4e17e0760cd25fac000cfb5.tar.gz
gentoo-2-515a895ab7b05e8ec4e17e0760cd25fac000cfb5.tar.bz2
gentoo-2-515a895ab7b05e8ec4e17e0760cd25fac000cfb5.zip
don't recompile at src_install, report correct version
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'x11-apps/radeontop')
-rw-r--r--x11-apps/radeontop/ChangeLog9
-rw-r--r--x11-apps/radeontop/radeontop-0.7-r1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/x11-apps/radeontop/ChangeLog b/x11-apps/radeontop/ChangeLog
index 991d8b65cbdc..6821a1220a13 100644
--- a/x11-apps/radeontop/ChangeLog
+++ b/x11-apps/radeontop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-apps/radeontop
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/radeontop/ChangeLog,v 1.1 2013/12/19 21:40:21 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/radeontop/ChangeLog,v 1.2 2014/07/04 20:43:46 hasufell Exp $
+
+*radeontop-0.7-r1 (04 Jul 2014)
+
+ 04 Jul 2014; Julian Ospald <hasufell@gentoo.org> +radeontop-0.7-r1.ebuild:
+ don't recompile at src_install, report correct version
*radeontop-0.7 (19 Dec 2013)
*radeontop-9999 (19 Dec 2013)
diff --git a/x11-apps/radeontop/radeontop-0.7-r1.ebuild b/x11-apps/radeontop/radeontop-0.7-r1.ebuild
new file mode 100644
index 000000000000..8a792dd06249
--- /dev/null
+++ b/x11-apps/radeontop/radeontop-0.7-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/radeontop/radeontop-0.7-r1.ebuild,v 1.1 2014/07/04 20:43:46 hasufell Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to view Radeon GPU utilization"
+HOMEPAGE="https://github.com/clbr/radeontop"
+LICENSE="GPL-3"
+SRC_URI="https://github.com/clbr/radeontop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses
+ x11-libs/libpciaccess
+ nls? ( sys-libs/ncurses[unicode] virtual/libintl )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch_user
+
+cat > include/version.h << EOF || die
+#ifndef VER_H
+#define VER_H
+
+#define VERSION "${PV}"
+
+#endif
+EOF
+ >getver.sh || die
+ touch .git || die
+}
+
+src_configure() {
+ tc-export CC
+ export nls=$(usex nls 1 0)
+ # Do not add -g or -s to CFLAGS
+ export plain=1
+}