summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-03-14 12:34:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-03-14 12:34:00 +0000
commit88282cbd60945c22ebe3f8641f4b4df5389ea97e (patch)
tree10a69214803dc2ae6ef68eca7d824f320178fc6d /x11-apps/xinit
parentfix incorrect patchrev, #504554 (diff)
downloadgentoo-2-88282cbd60945c22ebe3f8641f4b4df5389ea97e.tar.gz
gentoo-2-88282cbd60945c22ebe3f8641f4b4df5389ea97e.tar.bz2
gentoo-2-88282cbd60945c22ebe3f8641f4b4df5389ea97e.zip
Support $XDG_VTNR for setting vt -parameter to /usr/bin/X launch wrt #451956 for use of systemd-logind by Mike Gilbert
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-apps/xinit')
-rw-r--r--x11-apps/xinit/ChangeLog9
-rw-r--r--x11-apps/xinit/files/xserverrc6
-rw-r--r--x11-apps/xinit/xinit-1.3.3-r1.ebuild67
3 files changed, 80 insertions, 2 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 80b158a54501..8f02394842e8 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.252 2014/03/14 12:17:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.253 2014/03/14 12:34:00 ssuominen Exp $
+
+*xinit-1.3.3-r1 (14 Mar 2014)
+
+ 14 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +xinit-1.3.3-r1.ebuild,
+ files/xserverrc:
+ Support $XDG_VTNR for setting vt -parameter to /usr/bin/X launch wrt #451956
+ for use of systemd-logind by Mike Gilbert
14 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> files/Xsession.desktop:
Punt deprecated Encoding= line from .desktop file
diff --git a/x11-apps/xinit/files/xserverrc b/x11-apps/xinit/files/xserverrc
index b4de2528749e..6b57eeba6da3 100644
--- a/x11-apps/xinit/files/xserverrc
+++ b/x11-apps/xinit/files/xserverrc
@@ -1,2 +1,6 @@
#!/bin/sh
-exec /usr/bin/X -nolisten tcp "$@"
+if [ -z "$XDG_VTNR" ]; then
+ exec /usr/bin/X -nolisten tcp "$@"
+else
+ exec /usr/bin/X -nolisten tcp "$@" vt$XDG_VTNR
+fi
diff --git a/x11-apps/xinit/xinit-1.3.3-r1.ebuild b/x11-apps/xinit/xinit-1.3.3-r1.ebuild
new file mode 100644
index 000000000000..0427d2b6a8a3
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.3.3-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.3.3-r1.ebuild,v 1.1 2014/03/14 12:34:00 ssuominen Exp $
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+minimal"
+
+RDEPEND="
+ !<x11-base/xorg-server-1.8.0
+ x11-apps/xauth
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+PDEPEND="x11-apps/xrdb
+ !minimal? (
+ x11-apps/xclock
+ x11-apps/xsm
+ x11-terms/xterm
+ x11-wm/twm
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.3-gentoo-customizations.patch"
+)
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xinitdir=/etc/X11/xinit
+ )
+ xorg-2_src_configure
+}
+
+src_install() {
+ xorg-2_src_install
+
+ exeinto /etc/X11
+ doexe "${FILESDIR}"/chooser.sh "${FILESDIR}"/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/Xsession
+ exeinto /etc/X11/xinit
+ doexe "${FILESDIR}"/xserverrc
+ exeinto /etc/X11/xinit/xinitrc.d/
+ doexe "${FILESDIR}"/00-xhost
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/Xsession.desktop
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ ewarn "If you use startx to start X instead of a login manager like gdm/kdm,"
+ ewarn "you can set the XSESSION variable to anything in /etc/X11/Sessions/ or"
+ ewarn "any executable. When you run startx, it will run this as the login session."
+ ewarn "You can set this in a file in /etc/env.d/ for the entire system,"
+ ewarn "or set it per-user in ~/.bash_profile (or similar for other shells)."
+ ewarn "Here's an example of setting it for the whole system:"
+ ewarn " echo XSESSION=\"Gnome\" > /etc/env.d/90xsession"
+ ewarn " env-update && source /etc/profile"
+}