summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-14 15:57:07 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-14 15:57:07 +0000
commit2b135fedd605893a40b7c4011774dd4b4b56182e (patch)
tree25332572680ab1230469f6eb51a8e08609a5a898 /x11-apps
parentVersion bump. Using the gem from now on. (diff)
downloadgentoo-2-2b135fedd605893a40b7c4011774dd4b4b56182e.tar.gz
gentoo-2-2b135fedd605893a40b7c4011774dd4b4b56182e.tar.bz2
gentoo-2-2b135fedd605893a40b7c4011774dd4b4b56182e.zip
This provides glxgears and glxinfo. In the future, it may be enhanced to optionally build more of the programs and demos Mesa distributes.
(Portage version: 2.0.53)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/mesa-progs/ChangeLog11
-rw-r--r--x11-apps/mesa-progs/Manifest2
-rw-r--r--x11-apps/mesa-progs/files/digest-mesa-progs-6.4.12
-rw-r--r--x11-apps/mesa-progs/mesa-progs-6.4.1.ebuild73
-rw-r--r--x11-apps/mesa-progs/metadata.xml5
5 files changed, 93 insertions, 0 deletions
diff --git a/x11-apps/mesa-progs/ChangeLog b/x11-apps/mesa-progs/ChangeLog
new file mode 100644
index 000000000000..13e80aaccdf1
--- /dev/null
+++ b/x11-apps/mesa-progs/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-apps/mesa-progs
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/mesa-progs/ChangeLog,v 1.1 2005/12/14 15:57:07 spyderous Exp $
+
+*mesa-progs-6.4.1 (14 Dec 2005)
+
+ 14 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>; +metadata.xml,
+ +mesa-progs-6.4.1.ebuild:
+ This provides glxgears and glxinfo. In the future, it may be enhanced to
+ optionally build more of the programs and demos Mesa distributes.
+
diff --git a/x11-apps/mesa-progs/Manifest b/x11-apps/mesa-progs/Manifest
new file mode 100644
index 000000000000..0f011d6346c0
--- /dev/null
+++ b/x11-apps/mesa-progs/Manifest
@@ -0,0 +1,2 @@
+MD5 4078a0e3e9757cd821c51b6cf7495cbd files/digest-mesa-progs-6.4.1 135
+MD5 74eff9f7cee60b4540d5ae8b86ff21f7 mesa-progs-6.4.1.ebuild 1598
diff --git a/x11-apps/mesa-progs/files/digest-mesa-progs-6.4.1 b/x11-apps/mesa-progs/files/digest-mesa-progs-6.4.1
new file mode 100644
index 000000000000..d4bdd98046cf
--- /dev/null
+++ b/x11-apps/mesa-progs/files/digest-mesa-progs-6.4.1
@@ -0,0 +1,2 @@
+MD5 99df1fdcb98d391666b476ca6f1dda8a MesaDemos-6.4.1.tar.bz2 819391
+MD5 ea148c828ec6f645526451db1b8556f1 MesaLib-6.4.1.tar.bz2 2913887
diff --git a/x11-apps/mesa-progs/mesa-progs-6.4.1.ebuild b/x11-apps/mesa-progs/mesa-progs-6.4.1.ebuild
new file mode 100644
index 000000000000..755050e1dabf
--- /dev/null
+++ b/x11-apps/mesa-progs/mesa-progs-6.4.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/mesa-progs/mesa-progs-6.4.1.ebuild,v 1.1 2005/12/14 15:57:07 spyderous Exp $
+
+inherit toolchain-funcs
+
+MY_PN="${PN/m/M}"
+MY_PN="${MY_PN/-progs}"
+MY_P="${MY_PN}-${PV}"
+LIB_P="${MY_PN}Lib-${PV}"
+PROG_P="${MY_PN}Demos-${PV}"
+DESCRIPTION="Mesa's OpenGL utility and demo programs"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mesa3d/${LIB_P}.tar.bz2
+ mirror://sourceforge/mesa3d/${PROG_P}.tar.bz2"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/glut
+ virtual/opengl
+ virtual/glu"
+
+S=${WORKDIR}/Mesa-${PV}
+
+pkg_setup() {
+ if [[ ${KERNEL} == "FreeBSD" ]]; then
+ CONFIG="freebsd"
+ elif use x86; then
+ CONFIG="linux-dri-x86"
+ # amd64 people need to look at this file to deal with lib64 issues, unless
+ # they're fine with hardcoded lib64.
+ elif use amd64; then
+ CONFIG="linux-dri-x86-64"
+ elif use ppc; then
+ CONFIG="linux-dri-ppc"
+ else
+ CONFIG="linux-dri"
+ fi
+}
+
+src_unpack() {
+ HOSTCONF="${S}/configs/${CONFIG}"
+
+ unpack ${A}
+ cd ${S}
+
+ # Kill this; we don't want /usr/X11R6/lib ever to be searched in this
+ # build.
+ echo "EXTRA_LIB_PATH =" >> ${HOSTCONF}
+
+ echo "OPT_FLAGS = ${CFLAGS}" >> ${HOSTCONF}
+ echo "CC = $(tc-getCC)" >> ${HOSTCONF}
+ echo "CXX = $(tc-getCXX)" >> ${HOSTCONF}
+ # bug #110840 - Build with PIC, since it hasn't been shown to slow it down
+ echo "PIC_FLAGS = -fPIC" >> ${HOSTCONF}
+}
+
+src_compile() {
+ cd ${S}/configs
+ ln -s ${CONFIG} current
+
+ cd ${S}/progs/xdemos
+
+ emake glxinfo
+ emake glxgears
+}
+
+src_install() {
+ dobin ${S}/progs/xdemos/glxgears
+ dobin ${S}/progs/xdemos/glxinfo
+}
diff --git a/x11-apps/mesa-progs/metadata.xml b/x11-apps/mesa-progs/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-apps/mesa-progs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>