summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-10-02 00:40:13 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-10-02 00:40:13 +0000
commitc79f5a70bcb406024723ff58305bef22626ded53 (patch)
tree60ffae9a0a3883cf0dcb17a9b5ea9d8b8e4b12b8 /x11-apps
parentRe-add old version for FlowScan. (diff)
downloadgentoo-2-c79f5a70bcb406024723ff58305bef22626ded53.tar.gz
gentoo-2-c79f5a70bcb406024723ff58305bef22626ded53.tar.bz2
gentoo-2-c79f5a70bcb406024723ff58305bef22626ded53.zip
Version bump, drop obsolete patches.
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xdm/ChangeLog8
-rw-r--r--x11-apps/xdm/xdm-1.1.11.ebuild66
2 files changed, 73 insertions, 1 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index 426f13f5a22f..8a65b306248b 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.123 2011/09/21 00:30:46 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.124 2011/10/02 00:40:13 chithanh Exp $
+
+*xdm-1.1.11 (02 Oct 2011)
+
+ 02 Oct 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xdm-1.1.11.ebuild:
+ Version bump, drop obsolete patches.
21 Sep 2011; Jeroen Roovers <jer@gentoo.org> xdm-1.1.10-r2.ebuild:
Stable for HPPA (bug #380421).
diff --git a/x11-apps/xdm/xdm-1.1.11.ebuild b/x11-apps/xdm/xdm-1.1.11.ebuild
new file mode 100644
index 000000000000..7644ffa70a0b
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.11.ebuild,v 1.1 2011/10/02 00:40:13 chithanh Exp $
+
+EAPI=3
+
+inherit multilib xorg-2 pam systemd
+
+DEFAULTVT="vt7"
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 pam"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-apps/sessreg
+ x11-apps/xconsole
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession || die
+ if use pam; then
+ # Use system-local-login to get pam_loginuid and pam_ck_connector from
+ # pambase. This is required to get active ConsoleKit session since 0.4.2.
+ pamd_mimic system-local-login xdm auth account session
+ fi
+ # Keep /var/lib/xdm. This is where authfiles are stored. See #286350.
+ keepdir /var/lib/xdm
+
+ systemd_dounit "${FILESDIR}"/xdm.service || die
+}
+
+pkg_postinst() {
+ # Mea culpa, feel free to remove that after some time --mgorny.
+ if [[ -L "${ROOT}"/etc/systemd/system/graphical.target.wants/${PN}'@tty7'.service ]]
+ then
+ ebegin "Renaming ${PN}@tty7.service to ${PN}.service"
+ ln -s "${ROOT}"/lib/systemd/system/xdm.service \
+ "${ROOT}"/etc/systemd/system/graphical.target.wants/${PN}.service && \
+ rm -f "${ROOT}"/etc/systemd/system/graphical.target.wants/${PN}'@tty7'.service
+ eend ${?} \
+ "Please try to re-enable xdm.service"
+ fi
+}