summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2003-06-29 05:30:24 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2003-06-29 05:30:24 +0000
commitec49115c97d1f6b371f8c1b44050fb74b6a0f929 (patch)
tree96c653d796d506164840cea632a324bf53cbad26 /x11-base
parentcd support funcs (diff)
downloadgentoo-2-ec49115c97d1f6b371f8c1b44050fb74b6a0f929.tar.gz
gentoo-2-ec49115c97d1f6b371f8c1b44050fb74b6a0f929.tar.bz2
gentoo-2-ec49115c97d1f6b371f8c1b44050fb74b6a0f929.zip
Updated sources to June 18 CVS. Added XFREE_CARDS functionality and deprecated USE for video cards, similar to ALSA_CARDS for ALSA.
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xfree-drm/ChangeLog9
-rw-r--r--x11-base/xfree-drm/Manifest4
-rw-r--r--x11-base/xfree-drm/files/digest-xfree-drm-4.3.0-r42
-rw-r--r--x11-base/xfree-drm/xfree-drm-4.3.0-r4.ebuild181
4 files changed, 194 insertions, 2 deletions
diff --git a/x11-base/xfree-drm/ChangeLog b/x11-base/xfree-drm/ChangeLog
index a301d3a738ed..00605f359798 100644
--- a/x11-base/xfree-drm/ChangeLog
+++ b/x11-base/xfree-drm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-base/xfree-drm
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree-drm/ChangeLog,v 1.22 2003/06/27 08:26:12 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree-drm/ChangeLog,v 1.23 2003/06/29 05:30:19 spyderous Exp $
+
+*xfree-drm-4.3.0-r4 (29 Jun 2003)
+
+ 29 Jun 2003; Donnie Berkholz <spyderous@gentoo.org>;
+ xfree-drm-4.3.0-r4.ebuild:
+ Updated sources to June 18 CVS. Added XFREE_CARDS functionality and deprecated
+ USE for video cards, similar to ALSA_CARDS for ALSA.
27 Jun 2003; Donnie Berkholz <spyderous@gentoo.org>;
xfree-drm-4.3.0-r3.ebuild:
diff --git a/x11-base/xfree-drm/Manifest b/x11-base/xfree-drm/Manifest
index 991de632feed..76430de81e62 100644
--- a/x11-base/xfree-drm/Manifest
+++ b/x11-base/xfree-drm/Manifest
@@ -1,5 +1,7 @@
-MD5 660024b24f58e82eaec81e7b1d3041ce ChangeLog 5076
+MD5 cddcd1444cf940e07c9774b618ade335 ChangeLog 5332
MD5 6b1f0d725e8037cbf3c62d9ebee51ec8 xfree-drm-4.3.0-r2.ebuild 2655
MD5 0ed345e1687362bd46dbb26d1b3958e8 xfree-drm-4.3.0-r3.ebuild 2917
+MD5 58037f9eef2e7d56a63d57a80e01b80f xfree-drm-4.3.0-r4.ebuild 4291
MD5 b340ab262c964f235620a98d7626d6b9 files/digest-xfree-drm-4.3.0-r2 166
MD5 08d125fc239e02143fe64d48dcadb64c files/digest-xfree-drm-4.3.0-r3 169
+MD5 c94c5e6e652df3fe2dac3f4979333f49 files/digest-xfree-drm-4.3.0-r4 168
diff --git a/x11-base/xfree-drm/files/digest-xfree-drm-4.3.0-r4 b/x11-base/xfree-drm/files/digest-xfree-drm-4.3.0-r4
new file mode 100644
index 000000000000..aff6238e4904
--- /dev/null
+++ b/x11-base/xfree-drm/files/digest-xfree-drm-4.3.0-r4
@@ -0,0 +1,2 @@
+MD5 2913d31c0a9bedac202e7cdae7e2ef8c linux-drm-4.3.0-kernelsource-20030618.tar.gz 248949
+MD5 fe8cb91f2094fe2e63be84238e5bacdd xfree-drm-4.3.0-r4-gentoo-0.1.tar.bz2 804
diff --git a/x11-base/xfree-drm/xfree-drm-4.3.0-r4.ebuild b/x11-base/xfree-drm/xfree-drm-4.3.0-r4.ebuild
new file mode 100644
index 000000000000..75ef5c93666d
--- /dev/null
+++ b/x11-base/xfree-drm/xfree-drm-4.3.0-r4.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree-drm/xfree-drm-4.3.0-r4.ebuild,v 1.1 2003/06/29 05:30:19 spyderous Exp $
+
+# Small note: we should prob consider using a DRM only tarball, as it will ease
+# some of the overhead on older systems, and will enable us to
+# update DRM if there are fixes not already in XFree86 tarballs ...
+
+IUSE="3dfx gamma i8x0 matrox rage128 radeon sis"
+
+# XFREE_CARDS="3dfx gamma i810 i830 matrox rage128 radeon sis"
+
+inherit eutils
+
+# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
+# that only we only strip stuff that are safe to strip ...
+DEBUG="yes"
+RESTRICT="nostrip"
+
+SNAPSHOT="20030618"
+PATCHVER="0.1"
+
+S="${WORKDIR}/drm"
+DESCRIPTION="Xfree86 Kernel DRM modules"
+HOMEPAGE="http://www.xfree.org"
+SRC_URI="mirror://gentoo/linux-drm-${PV}-kernelsource-${SNAPSHOT}.tar.gz
+ mirror://gentoo/${PF}-gentoo-${PATCHVER}.tar.bz2"
+
+# These sources come from one of four places:
+#
+# http://www.xfree86.org/~alanh/ -- DRM snapshots, outdated
+# http://people.debian.org/~daenzer/ -- full tree, often patched but
+# somewhat outdated
+# http://dri.sourceforge.net/snapshots/ -- daily CVS snapshots, lacking
+# gamma and sis
+# http://dri.sourceforge.net CVS -- full tree
+# http://cvs.sourceforge.net/cvstarballs/dri-cvsroot.tar.gz -- backup
+#
+# We throw all necessary files into one folder and turn that into our tarball.
+
+SLOT="${KV}"
+LICENSE="X11"
+KEYWORDS="~x86 ~ppc ~alpha"
+
+DEPEND=">=x11-base/xfree-${PV}
+ virtual/linux-sources"
+
+PROVIDE="virtual/drm"
+
+
+VIDCARDS=""
+
+if use matrox &>/dev/null
+then
+ VIDCARDS="${VIDCARDS} mga.o"
+fi
+if use 3dfx &>/dev/null
+then
+ VIDCARDS="${VIDCARDS} tdfx.o"
+fi
+if use rage128 &>/dev/null
+then
+ VIDCARDS="${VIDCARDS} r128.o"
+fi
+if use radeon &>/dev/null
+then
+ VIDCARDS="${VIDCARDS} radeon.o"
+fi
+if use sis &>/dev/null
+then
+ VIDCARDS="${VIDCARDS} sis.o"
+fi
+if use i8x0 &>/dev/null
+then
+ VIDCARDS="${VIDCARDS} i810.o i830.o"
+fi
+if use gamma &>/dev/null
+then
+ VIDCARDS="${VIDCARDS} gamma.o"
+fi
+
+# Add XFREE_CARDS functionality.
+# Having a module twice (once from USE, once from XFREE_CARDS)
+# doesn't matter at all.
+
+case "${XFREE_CARDS}" in
+ *matrox*)
+ VIDCARDS="${VIDCARDS} mga.o" ;;
+esac
+case "${XFREE_CARDS}" in
+ *3dfx*)
+ VIDCARDS="${VIDCARDS} tdfx.o" ;;
+esac
+case "${XFREE_CARDS}" in
+ *rage128*)
+ VIDCARDS="${VIDCARDS} r128.o" ;;
+esac
+case "${XFREE_CARDS}" in
+ *radeon*)
+ VIDCARDS="${VIDCARDS} radeon.o" ;;
+esac
+case "${XFREE_CARDS}" in
+ *sis*)
+ VIDCARDS="${VIDCARDS} sis.o" ;;
+esac
+case "${XFREE_CARDS}" in
+ *i810*)
+ VIDCARDS="${VIDCARDS} i810.o" ;;
+esac
+case "${XFREE_CARDS}" in
+ *i830*)
+ VIDCARDS="${VIDCARDS} i830.o" ;;
+esac
+case "${XFREE_CARDS}" in
+ *gamma*)
+ VIDCARDS="${VIDCARDS} gamma.o" ;;
+esac
+
+# This builds everything if none of the cards are in USE.
+#if [ -z "${VIDCARDS}" ]
+#then
+# if [ "${ARCH}" = "ppc" ]
+# then
+# VIDCARDS="r128.o radeon.o"
+# else
+# VIDCARDS="mga.o tdfx.o r128.o radeon.o sis.o i810.o i830.o gamma.o"
+# fi
+#fi
+
+src_unpack() {
+ if [ ! -f /usr/src/linux/include/config/MARKER ] ; then
+ die "Please compile kernel sources."
+ fi
+
+ if [ -z "${VIDCARDS}" ] ; then
+ die "Please set at least one video card in XFREE_CARDS. USE is deprecated."
+ fi
+
+ unpack ${A}
+ cd ${S}
+
+ local PATCHDIR=${WORKDIR}/patch
+
+ epatch ${PATCHDIR}/${PF}-gentoo-Makefile-fixup.patch
+ epatch ${PATCHDIR}/${PF}-dristat.patch
+}
+
+src_compile() {
+ check_KV
+ ln -sf Makefile.linux Makefile
+ einfo "Building DRM..."
+ make ${VIDCARDS} \
+ TREE="/usr/src/linux/include" KV="${KV}"
+ make dristat || die
+}
+
+src_install() {
+
+ einfo "installing DRM..."
+ make \
+ TREE="/usr/src/linux/include" \
+ KV="${KV}" \
+ DESTDIR="${D}" \
+ MODS="${VIDCARDS}" \
+ install || die
+ dodoc README*
+ exeinto /usr/X11R6/bin
+ doexe dristat
+}
+
+pkg_postinst() {
+
+ if [ "${ROOT}" = "/" ]
+ then
+ /sbin/modules-update
+ fi
+
+ einfo "USE is deprecated. Please set your video cards using XFREE_CARDS."
+ einfo "Possible XFREE_CARDS values are matrox, 3dfx, rage128, radeon, sis, i810, i830, and gamma."
+
+}