summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-04-20 20:21:53 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-04-20 20:21:53 +0000
commitbdf43c48a283e9a557cd984a45568b5b59076906 (patch)
treea994266629044b0fc09283e84a74b61583c5410e /x11-drivers/xf86-video-ati/xf86-video-ati-7.1.0.ebuild
parentStable for alpha, wrt bug #449298 (diff)
downloadgentoo-2-bdf43c48a283e9a557cd984a45568b5b59076906.tar.gz
gentoo-2-bdf43c48a283e9a557cd984a45568b5b59076906.tar.bz2
gentoo-2-bdf43c48a283e9a557cd984a45568b5b59076906.zip
Import David Heidelberger's CONFIG_CHECK improvements from the x11 overlay.
(Portage version: 2.1.11.55/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers/xf86-video-ati/xf86-video-ati-7.1.0.ebuild')
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-7.1.0.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-7.1.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-7.1.0.ebuild
index 64075c0d6c2d..8ece67e9022e 100644
--- a/x11-drivers/xf86-video-ati/xf86-video-ati-7.1.0.ebuild
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-7.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-7.1.0.ebuild,v 1.2 2013/03/19 09:55:37 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-7.1.0.ebuild,v 1.3 2013/04/20 20:21:53 chithanh Exp $
EAPI=5
@@ -17,7 +17,16 @@ RDEPEND=">=x11-libs/libdrm-2.4.36[video_cards_radeon]
udev? ( virtual/udev )"
DEPEND="${RDEPEND}"
-CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
src_configure() {
XORG_CONFIGURE_OPTIONS=(