summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2005-12-04 23:06:52 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2005-12-04 23:06:52 +0000
commitba9a9c6c7d2014b8a528ce0e50ec5e82f664e829 (patch)
treebc3ac4b1e40057810c93ef31a0c7f405db205d03 /x11-drivers/xf86-video-ati
parentKeep the old libdrm.so.1 around so things don't break horribly on upgrade. (diff)
downloadgentoo-2-ba9a9c6c7d2014b8a528ce0e50ec5e82f664e829.tar.gz
gentoo-2-ba9a9c6c7d2014b8a528ce0e50ec5e82f664e829.tar.bz2
gentoo-2-ba9a9c6c7d2014b8a528ce0e50ec5e82f664e829.zip
Bump for 7.0RC3.
(Portage version: 2.0.53)
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.7.11
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.1.ebuild25
3 files changed, 33 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index f0cef572e627..a9eecea04547 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.12 2005/11/11 18:57:59 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.13 2005/12/04 23:03:57 joshuabaergen Exp $
+
+*xf86-video-ati-6.5.7.1 (04 Dec 2005)
+
+ 04 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xf86-video-ati-6.5.7.1.ebuild:
+ Bump for 7.0RC3.
*xf86-video-ati-6.5.7 (11 Nov 2005)
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.7.1 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.7.1
new file mode 100644
index 000000000000..3c8b791b1876
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.7.1
@@ -0,0 +1 @@
+MD5 7c584d62026d8ac84b7624f8bb4c8340 xf86-video-ati-6.5.7.1.tar.bz2 600734
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.1.ebuild
new file mode 100644
index 000000000000..296ab05a75ef
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.7.1.ebuild,v 1.1 2005/12/04 23:03:57 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for ati cards"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="dri"
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2)"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}